summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-10-24 20:36:44 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-10-24 20:37:43 +0200
commitfa5afa61befbe287b98df7f718e673c94b4a4c48 (patch)
tree69563062d82d932c21890904ed618166f149c359 /kde-plasma/kscreenlocker
parentsci-mathematics/why3-for-spark: Adding examples (diff)
downloadgentoo-fa5afa61befbe287b98df7f718e673c94b4a4c48.tar.gz
gentoo-fa5afa61befbe287b98df7f718e673c94b4a4c48.tar.bz2
gentoo-fa5afa61befbe287b98df7f718e673c94b4a4c48.zip
kde-plasma: Add KDE Plasma 5.11.2
Package-Manager: Portage-2.3.12, Repoman-2.3.3
Diffstat (limited to 'kde-plasma/kscreenlocker')
-rw-r--r--kde-plasma/kscreenlocker/Manifest1
-rw-r--r--kde-plasma/kscreenlocker/kscreenlocker-5.11.2.ebuild92
2 files changed, 93 insertions, 0 deletions
diff --git a/kde-plasma/kscreenlocker/Manifest b/kde-plasma/kscreenlocker/Manifest
index a875cfe56c11..26c195f9dfc6 100644
--- a/kde-plasma/kscreenlocker/Manifest
+++ b/kde-plasma/kscreenlocker/Manifest
@@ -1,2 +1,3 @@
DIST kscreenlocker-5.10.5.1.tar.xz 118440 SHA256 777f7a67539f9e32e687525e5b119774ce1c9dd6ebd64339205b52e97d03300e SHA512 cef3a7f48f9cdd0b3967a403848a5c8a37d1253d6d7fc73cdb12feddfe088e7a8a9128f2ae8d53e1847c75d64b369cf92facce725f17654ea085f9d03024a70d WHIRLPOOL 662d46064feda302fe4897c942a87affbd3ebadd31aa8b269df7b6034ca45d6a9f5f24321a552505c0b81a2480b98480666ca1a39d075f129bcafdfe6d3df34b
DIST kscreenlocker-5.11.1.tar.xz 118424 SHA256 6f0f4bb27183e99857d12dbd363b1596cd350394e1bbea68e32486f80f17f849 SHA512 b12f99433262d5b0170780f12f271dede6237972ccabc8a116c3a47e7c482ab07c4006b33033978dfde9143d39455690d7466f86aa9629eee3e7e4da04f0c5e1 WHIRLPOOL 0c67bac68a835f3d9d763a58101ebc907dc688152a62393208ca7156558766abda7f4b280d6c1c7d4d8ae84799ade9a0608ae0842d6c9fce7d1d6b9989c4e16f
+DIST kscreenlocker-5.11.2.tar.xz 118452 SHA256 bc573c3752ef102e3b0998c79c9d102fc872a11074a13e652c8fb4b4e1b762cc SHA512 ed51ff7ddad6ba84e1d5e685c30263a5209d96c6a9b6d979999c4222c32e822c567c9727cfec4de64ae2b910ed72fe9e1776d900ad7e8cffc147449b3ce287bc WHIRLPOOL 9305f7eb04ad7e9df788b059e9bd665d771a2cea430ce8f61f874728697051ab7ed38ca105c06d981d9164abaf8d78e74db78f9e541dd68c5bb576a8b3a9cfac
diff --git a/kde-plasma/kscreenlocker/kscreenlocker-5.11.2.ebuild b/kde-plasma/kscreenlocker/kscreenlocker-5.11.2.ebuild
new file mode 100644
index 000000000000..221164a5e488
--- /dev/null
+++ b/kde-plasma/kscreenlocker/kscreenlocker-5.11.2.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_TEST="forceoptional"
+VIRTUALX_REQUIRED="test"
+inherit kde5 pam
+
+DESCRIPTION="Library and components for secure lock screen architecture"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="+pam seccomp"
+
+REQUIRED_USE="seccomp? ( pam )"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep kglobalaccel)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kidletime)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kpackage)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwayland)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative 'widgets')
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtx11extras)
+ dev-libs/wayland
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libxcb
+ x11-libs/xcb-util-keysyms
+ pam? ( virtual/pam )
+ seccomp? ( sys-libs/libseccomp )
+"
+DEPEND="${COMMON_DEPEND}
+ x11-proto/xproto
+"
+RDEPEND="${COMMON_DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+ !<kde-plasma/kcheckpass-4.11.22-r1:4
+ !kde-plasma/kdebase-pam:0
+"
+
+RESTRICT+=" test"
+
+src_prepare() {
+ kde5_src_prepare
+
+ use test || sed -i \
+ -e "/add_subdirectory(autotests)/ s/^/#/" greeter/CMakeLists.txt || die
+}
+
+src_test() {
+ # requires running environment
+ local myctestargs=(
+ -E x11LockerTest
+ )
+ kde5_src_test
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DPAM_REQUIRED=$(usex pam)
+ $(cmake-utils_use_find_package pam PAM)
+ $(cmake-utils_use_find_package seccomp Seccomp)
+ )
+ kde5_src_configure
+}
+
+src_install() {
+ kde5_src_install
+
+ newpamd "${FILESDIR}/kde.pam" kde
+ newpamd "${FILESDIR}/kde-np.pam" kde-np
+
+ if ! use pam; then
+ chown root "${ED}"usr/$(get_libdir)/libexec/kcheckpass || die
+ chmod +s "${ED}"usr/$(get_libdir)/libexec/kcheckpass || die
+ fi
+}