summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-03-14 20:39:55 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-03-14 21:13:52 +0100
commitc22c2d1d8ba89b3c0c458efd0ad337f439b9f44d (patch)
treea66e8c3ec269e30c1aee313177ceb70f6c42964f /kde-plasma/ksshaskpass
parentkde-plasma/kscreenlocker: 5.27.3 version bump (diff)
downloadgentoo-c22c2d1d8ba89b3c0c458efd0ad337f439b9f44d.tar.gz
gentoo-c22c2d1d8ba89b3c0c458efd0ad337f439b9f44d.tar.bz2
gentoo-c22c2d1d8ba89b3c0c458efd0ad337f439b9f44d.zip
kde-plasma/ksshaskpass: 5.27.3 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/ksshaskpass')
-rw-r--r--kde-plasma/ksshaskpass/Manifest1
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-5.27.3.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/Manifest b/kde-plasma/ksshaskpass/Manifest
index 918e9cf79ab5..055e05def949 100644
--- a/kde-plasma/ksshaskpass/Manifest
+++ b/kde-plasma/ksshaskpass/Manifest
@@ -1,2 +1,3 @@
DIST ksshaskpass-5.26.5.tar.xz 27580 BLAKE2B e5fed3921804b91f5f7e9a38a327a4b03cbf1fae2a6ba7a4ce123171ea70122f0c86a20f8c719c0459b5084098f042b731a912b9c0bd9979b80793043796184d SHA512 a1e50379415d006f5a2ca8292147e3bf33cb7588a6c03d5ed6dc11c0e77a3c2abf93e950f61391f464a9d17389b75dadc6e16721ec9cad7e71266ca7c0496bfd
DIST ksshaskpass-5.27.2.tar.xz 27748 BLAKE2B c6155b156e52e0e81a75796d80b4b28ffa27b8f758029cbdaae575d03db00abde6d00b1d65ee394a1496b2549480cf73f020c23332ad5a6e34ccd7fdd58dc08b SHA512 7731592a86d09c4a14193dad3d19220fac6338e69435c84ebed0142b165ad6b5663c3ce4d283747e46633895a9fe02d1a36348fa9d2487ed43fb75eededf4733
+DIST ksshaskpass-5.27.3.tar.xz 27776 BLAKE2B 741ea4a7673ffcf870e2c333ca69e0440c5740c56e94dd9b50ea12e7692d09ff0340f380b56308944fda3616c0800acc2db161e9308578e25135f51bd205a01d SHA512 11fab85f011ae038ff439f47d4b6f2ef675d09f93b9554e385a208bb00b4beb5a94edbb1b1e1e85db70c41616efbd3c039442ff8acda561e2edcf8beeb32a871
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-5.27.3.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-5.27.3.ebuild
new file mode 100644
index 000000000000..406a6e3e3596
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-5.27.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.102.0
+QTMIN=5.15.7
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Implementation of ssh-askpass with KDE Wallet integration"
+HOMEPAGE+=" https://invent.kde.org/plasma/ksshaskpass"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ ecm_src_install
+
+ insinto /etc/xdg/plasma-workspace/env/
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+
+ elog "In order to have ssh-agent start with Plasma 5,"
+ elog "edit /etc/xdg/plasma-workspace/env/10-agent-startup.sh"
+ elog "and uncomment the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/xdg/plasma-workspace/shutdown/10-agent-shutdown.sh"
+ elog "to properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 5 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/xdg/plasma-workspace/env/05-ksshaskpass.sh"
+
+ # Clean up pre-5.17.4 dirs
+ rmdir -v "${EROOT}"/etc/plasma{/startup,} 2> /dev/null
+}