summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-10-18 14:05:52 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-10-18 15:46:39 +0200
commitce0ba6d529af3537783515b6b3e9ad909d6e1dc9 (patch)
tree1f1f4e9114b3dcca9a9a9292817e8f191085952f /kde-plasma/ksshaskpass
parentkde-plasma/kscreenlocker: 5.26.1 version bump (diff)
downloadgentoo-ce0ba6d529af3537783515b6b3e9ad909d6e1dc9.tar.gz
gentoo-ce0ba6d529af3537783515b6b3e9ad909d6e1dc9.tar.bz2
gentoo-ce0ba6d529af3537783515b6b3e9ad909d6e1dc9.zip
kde-plasma/ksshaskpass: 5.26.1 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/ksshaskpass')
-rw-r--r--kde-plasma/ksshaskpass/Manifest1
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-5.26.1.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/Manifest b/kde-plasma/ksshaskpass/Manifest
index abda6cf443a4..20b4afd9a91b 100644
--- a/kde-plasma/ksshaskpass/Manifest
+++ b/kde-plasma/ksshaskpass/Manifest
@@ -1,2 +1,3 @@
DIST ksshaskpass-5.25.5.tar.xz 24904 BLAKE2B eac317c2c0658ade7607fdc73298f07312ac336e5fb4d69161a4c9c6d886c5b778858a26f8477a230068fe9d302097e34841b1c0c0e81809fea4ac63696f20f4 SHA512 ac055caca9c4bcfc6fa40d2eb54bbc72bbbd3b825bc8e831e8f1ec4fc089f334b70a9ba796901ce2c14b565e8519994655c0d32455ef90a1448e1ffdfaaf1c79
DIST ksshaskpass-5.26.0.tar.xz 27536 BLAKE2B e1d4dc7b890647ecf003ed1a157b5062a711623af1b906f8e5adefa52606cf27a87976d731da474659ab99f4e6e4bf2c2822f607b773c498bb1599ca1d55f350 SHA512 1f29f73709fc04405acc83ed170d9848a9319a26a07f9e6c318a762eb9816edefdcfc6c69de268107ac1004d239f8ae1e7e58a8f0413acb116eb474561e80ffd
+DIST ksshaskpass-5.26.1.tar.xz 27548 BLAKE2B 67c363010082d7f324a906fcf4cfd3e009d4d07a73df6ba8401373511d8a0dc29b571f14d4eb1f5c0e0de734adc269987cad117f64e3403235193c48cb449958 SHA512 731675033cfce9b004bd0829355609c7dd03f6f1e31b09bb2794d358f397a6bac420a1078fb13cbb2666068c1a89f9aa5a790a55f285c78a3bfecfc2b63dec9c
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-5.26.1.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-5.26.1.ebuild
new file mode 100644
index 000000000000..2385a577646f
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-5.26.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.99.0
+QTMIN=5.15.5
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Implementation of ssh-askpass with KDE Wallet integration"
+HOMEPAGE+=" https://invent.kde.org/plasma/ksshaskpass"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ ecm_src_install
+
+ insinto /etc/xdg/plasma-workspace/env/
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+
+ elog "In order to have ssh-agent start with Plasma 5,"
+ elog "edit /etc/xdg/plasma-workspace/env/10-agent-startup.sh"
+ elog "and uncomment the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/xdg/plasma-workspace/shutdown/10-agent-shutdown.sh"
+ elog "to properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 5 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/xdg/plasma-workspace/env/05-ksshaskpass.sh"
+
+ # Clean up pre-5.17.4 dirs
+ rmdir -v "${EROOT}"/etc/plasma{/startup,} 2> /dev/null
+}