summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-06-10 14:49:00 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-06-10 17:29:49 +0200
commit26b0c66418a96e2d882d034f90a1f9be7a3b591a (patch)
treecbe742d36a4aa00e9e5da1a0d59d2dd6780f675e /kde-plasma/kwallet-pam/kwallet-pam-5.22.0.ebuild
parentkde-plasma/ksystemstats: New package, version 5.22.0 (diff)
downloadgentoo-26b0c66418a96e2d882d034f90a1f9be7a3b591a.tar.gz
gentoo-26b0c66418a96e2d882d034f90a1f9be7a3b591a.tar.bz2
gentoo-26b0c66418a96e2d882d034f90a1f9be7a3b591a.zip
kde-plasma/kwallet-pam: 5.22.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kwallet-pam/kwallet-pam-5.22.0.ebuild')
-rw-r--r--kde-plasma/kwallet-pam/kwallet-pam-5.22.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/kde-plasma/kwallet-pam/kwallet-pam-5.22.0.ebuild b/kde-plasma/kwallet-pam/kwallet-pam-5.22.0.ebuild
new file mode 100644
index 000000000000..2e0699fcb3bc
--- /dev/null
+++ b/kde-plasma/kwallet-pam/kwallet-pam-5.22.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KFMIN=5.82.0
+PVCUT=$(ver_cut 1-3)
+inherit ecm kde.org
+
+DESCRIPTION="PAM module to not enter KWallet password again after login"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-libs/libgcrypt:0=
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ sys-libs/pam
+"
+RDEPEND="${DEPEND}
+ net-misc/socat
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_LIBDIR="/$(get_libdir)"
+ )
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+ elog "This package enables auto-unlocking of kde-frameworks/kwallet:5."
+ elog "See also: https://wiki.gentoo.org/wiki/KDE#KWallet_auto-unlocking"
+}