summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-09-02 12:18:31 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-09-02 18:46:43 +0200
commitb36186dd291325d99f7cff0ca509f81f231a4d17 (patch)
tree966087f0e19701533b7d1851bb7079984dc41491 /kde-plasma/kwallet-pam/kwallet-pam-5.22.5.ebuild
parentkde-plasma/ksystemstats: 5.22.5 version bump (diff)
downloadgentoo-b36186dd291325d99f7cff0ca509f81f231a4d17.tar.gz
gentoo-b36186dd291325d99f7cff0ca509f81f231a4d17.tar.bz2
gentoo-b36186dd291325d99f7cff0ca509f81f231a4d17.zip
kde-plasma/kwallet-pam: 5.22.5 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kwallet-pam/kwallet-pam-5.22.5.ebuild')
-rw-r--r--kde-plasma/kwallet-pam/kwallet-pam-5.22.5.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/kde-plasma/kwallet-pam/kwallet-pam-5.22.5.ebuild b/kde-plasma/kwallet-pam/kwallet-pam-5.22.5.ebuild
new file mode 100644
index 000000000000..2db13f66ab1f
--- /dev/null
+++ b/kde-plasma/kwallet-pam/kwallet-pam-5.22.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.82.0
+PVCUT=$(ver_cut 1-3)
+inherit ecm kde.org
+
+DESCRIPTION="PAM module to not enter KWallet password again after login"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/libgcrypt:0=
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ sys-libs/pam
+"
+RDEPEND="${DEPEND}
+ net-misc/socat
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_LIBDIR="/$(get_libdir)"
+ )
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+ elog "This package enables auto-unlocking of kde-frameworks/kwallet:5."
+ elog "See also: https://wiki.gentoo.org/wiki/KDE#KWallet_auto-unlocking"
+}