summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-02-15 15:46:34 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-02-15 18:50:14 +0100
commitf25957c38f2138b1ae7826d45857f0a8d30959ac (patch)
treed1ee53002ab97132373e4a1cb805e4d210f5d508 /kde-plasma/kwallet-pam
parentkde-plasma/ksystemstats: 5.24.1 version bump (diff)
downloadgentoo-f25957c38f2138b1ae7826d45857f0a8d30959ac.tar.gz
gentoo-f25957c38f2138b1ae7826d45857f0a8d30959ac.tar.bz2
gentoo-f25957c38f2138b1ae7826d45857f0a8d30959ac.zip
kde-plasma/kwallet-pam: 5.24.1 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kwallet-pam')
-rw-r--r--kde-plasma/kwallet-pam/Manifest1
-rw-r--r--kde-plasma/kwallet-pam/kwallet-pam-5.24.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/kde-plasma/kwallet-pam/Manifest b/kde-plasma/kwallet-pam/Manifest
index 449fcea1fd35..f5dd266dbf4f 100644
--- a/kde-plasma/kwallet-pam/Manifest
+++ b/kde-plasma/kwallet-pam/Manifest
@@ -1,2 +1,3 @@
DIST kwallet-pam-5.23.5.tar.xz 20128 BLAKE2B 8c6aab56cce55f750981d9bdf2c0b9daf9855d64fd69d406828c426c588f80a042761db795b754f1c0e02d28fd4946f7a26f03d66db029223f2775c3279714b5 SHA512 d7f876c6ede1719fa0d7886fd4f79ff52d8d62b175e52552bbc587ecd5464812eb19c875c51e64ab557af4668446a4b3838b76637555604239f3e314a605d18b
DIST kwallet-pam-5.24.0.tar.xz 20488 BLAKE2B f2edffea580954c2e405ff0a4e042071cd0ccce9d90fce609b78c8a673d942bd264247ee9ac283e4ce485ef46ef780dfb2f057b41af9ae6d7763a638db0b3f11 SHA512 a1448930fc0489a4e307cccb015083b0882181b399c676e6f359af9239e7ce1fb4afed3aa537c4701b22548534335901c8303cd4f0da92a8a7366462bb21b740
+DIST kwallet-pam-5.24.1.tar.xz 20476 BLAKE2B ca08d6a5ffca41bb250fb586886664b60864379651aa6cd44702735ab5e0618bf92a8774ec76b900a9af148f6774e1c40e8b9530edce00253c5e34ded5b31ffb SHA512 26cf93a698e6a5dc7ae94fc9babb926bb3c212da0f3ee389f01bfe81b5a3b37f5383373276f326590d69f858b2d0eb618cd46030f1bc37e6bf3142f89ad74ac2
diff --git a/kde-plasma/kwallet-pam/kwallet-pam-5.24.1.ebuild b/kde-plasma/kwallet-pam/kwallet-pam-5.24.1.ebuild
new file mode 100644
index 000000000000..940910a2e750
--- /dev/null
+++ b/kde-plasma/kwallet-pam/kwallet-pam-5.24.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.90.0
+PVCUT=$(ver_cut 1-3)
+inherit ecm kde.org
+
+DESCRIPTION="PAM module to not enter KWallet password again after login"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/libgcrypt:0=
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ sys-libs/pam
+"
+RDEPEND="${DEPEND}
+ net-misc/socat
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_LIBDIR="/$(get_libdir)"
+ )
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+ elog "This package enables auto-unlocking of kde-frameworks/kwallet:5."
+ elog "See also: https://wiki.gentoo.org/wiki/KDE#KWallet_auto-unlocking"
+}