summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-01-18 18:22:53 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-01-18 18:36:30 +0100
commit19da06f678851809cb86de041de0337a6174ab25 (patch)
tree637bde2ded893aecd7be9b9cae97e10083dc4aa7 /kde-plasma/kwallet-pam
parentkde-plasma/ksystemstats: 5.23.90 version bump (diff)
downloadgentoo-19da06f678851809cb86de041de0337a6174ab25.tar.gz
gentoo-19da06f678851809cb86de041de0337a6174ab25.tar.bz2
gentoo-19da06f678851809cb86de041de0337a6174ab25.zip
kde-plasma/kwallet-pam: 5.23.90 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kwallet-pam')
-rw-r--r--kde-plasma/kwallet-pam/Manifest1
-rw-r--r--kde-plasma/kwallet-pam/kwallet-pam-5.23.90.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/kde-plasma/kwallet-pam/Manifest b/kde-plasma/kwallet-pam/Manifest
index b624d7810bcc..fbca70d6e6d6 100644
--- a/kde-plasma/kwallet-pam/Manifest
+++ b/kde-plasma/kwallet-pam/Manifest
@@ -1,2 +1,3 @@
DIST kwallet-pam-5.23.4.tar.xz 20116 BLAKE2B a18c9b8de493c068ffae6310631c39b0bf8691c8ed8c923c51544d7ab72d9d8f3a917638b59f22953113cb6e4fb3a0687021ab25ff7484b33b2f837c076179d7 SHA512 256e33b63ffeab99b5d1758baec794abbc0d838b338341461b179a5ac80f8ee91a85987677cd33ad25f449a85b9959f92c7cc18dca46fd319577203659e2727f
DIST kwallet-pam-5.23.5.tar.xz 20128 BLAKE2B 8c6aab56cce55f750981d9bdf2c0b9daf9855d64fd69d406828c426c588f80a042761db795b754f1c0e02d28fd4946f7a26f03d66db029223f2775c3279714b5 SHA512 d7f876c6ede1719fa0d7886fd4f79ff52d8d62b175e52552bbc587ecd5464812eb19c875c51e64ab557af4668446a4b3838b76637555604239f3e314a605d18b
+DIST kwallet-pam-5.23.90.tar.xz 20380 BLAKE2B 46826af2ba41505693b50762a47cb39e048d3797fc3425bc5ae665e557dcf071f2437e40e02964068a18ad15ceb3bf7dc7156bb65a8eb4c0fbc667a71722d9dc SHA512 522de8fa3d95be08e5e7bfe0a360dc9acda08140a144d7fd08e9bbcc1f7b93c4eb305c749af4016875b42677b00aaddadd7efd59383023979a91a6d8caf85189
diff --git a/kde-plasma/kwallet-pam/kwallet-pam-5.23.90.ebuild b/kde-plasma/kwallet-pam/kwallet-pam-5.23.90.ebuild
new file mode 100644
index 000000000000..940910a2e750
--- /dev/null
+++ b/kde-plasma/kwallet-pam/kwallet-pam-5.23.90.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.90.0
+PVCUT=$(ver_cut 1-3)
+inherit ecm kde.org
+
+DESCRIPTION="PAM module to not enter KWallet password again after login"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/libgcrypt:0=
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ sys-libs/pam
+"
+RDEPEND="${DEPEND}
+ net-misc/socat
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_LIBDIR="/$(get_libdir)"
+ )
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+ elog "This package enables auto-unlocking of kde-frameworks/kwallet:5."
+ elog "See also: https://wiki.gentoo.org/wiki/KDE#KWallet_auto-unlocking"
+}