summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-02-13 11:34:09 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-02-14 12:26:14 +0100
commit2e758dc53e3220d81c45ef09e97b6c556bb54b8e (patch)
tree03d086ca43c883170b305ba441fb107f80571deb /kde-plasma/kwayland-integration
parentkde-plasma/kwallet-pam: 5.27.0 version bump (diff)
downloadgentoo-2e758dc53e3220d81c45ef09e97b6c556bb54b8e.tar.gz
gentoo-2e758dc53e3220d81c45ef09e97b6c556bb54b8e.tar.bz2
gentoo-2e758dc53e3220d81c45ef09e97b6c556bb54b8e.zip
kde-plasma/kwayland-integration: 5.27.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kwayland-integration')
-rw-r--r--kde-plasma/kwayland-integration/Manifest1
-rw-r--r--kde-plasma/kwayland-integration/kwayland-integration-5.27.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/kde-plasma/kwayland-integration/Manifest b/kde-plasma/kwayland-integration/Manifest
index a7b07738431b..2bc149e34bab 100644
--- a/kde-plasma/kwayland-integration/Manifest
+++ b/kde-plasma/kwayland-integration/Manifest
@@ -1,2 +1,3 @@
DIST kwayland-integration-5.26.5.tar.xz 26972 BLAKE2B 108eeebc92768755fba22d7435829f514904a3f39c748a70f220c1ae4fa078d5def0921f6c96effc2c7cc1ae0580d8c251034e87acaf4107d340b7bfdac1e443 SHA512 de252e67f488f920538a15e69836d4b8779a3123e1913c78cb7d69833a8fa475eb1166928cc965bc7ad69aa26d3dc58395ac7d06fb2349120bd014939d81e229
DIST kwayland-integration-5.26.90.tar.xz 25700 BLAKE2B b94d7c9381e87b092a6ed76e424228b2de0a1d5c7a1c6bb75f46b09a8ba5da15e66eee85e28bba52cc7822ac980af6e59ee80853c15ab6e9ec45543466538f24 SHA512 4dadc89b268199d79642c3b62cea1b7ce67eab47bbc88929f29dc33c712670a02db06f05790f45d5d699cc37a2605945cf8880b1c3c1c4442edfb6b15d07dcfd
+DIST kwayland-integration-5.27.0.tar.xz 25692 BLAKE2B e9b966957fc62e90ab82a0e1b6fa3b6f93bc7b8c97d66452687286bc35739c228262ac867deacc8f8d63df03c84e6ba62210fa6ee392eb07cc0f38fa5b8bb4b1 SHA512 9d9d18100a07ba26714a2bddc73729d8e91cc2c74b57b2093a3aacf9b138583c4224f803b34b13c9c0543ef0131a4e7a7b1d7079c69644b0928bbf272e7d01be
diff --git a/kde-plasma/kwayland-integration/kwayland-integration-5.27.0.ebuild b/kde-plasma/kwayland-integration/kwayland-integration-5.27.0.ebuild
new file mode 100644
index 000000000000..8c56787c316b
--- /dev/null
+++ b/kde-plasma/kwayland-integration/kwayland-integration-5.27.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.102.0
+QTMIN=5.15.7
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Provides KWindowSystem integration plugin for Wayland"
+HOMEPAGE="https://invent.kde.org/plasma/kwayland-integration"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+# dev-qt/qtgui: QtXkbCommonSupport is provided by either IUSE libinput or X
+# slot ops:
+# dev-qt/qtgui: QtXkbCommonSupportPrivate
+# dev-qt/qtwayland: Qt::WaylandClientPrivate (private/qwayland*_p.h) stuff
+# kde-frameworks/kwindowsystem: Various private headers
+DEPEND="
+ >=dev-libs/wayland-1.15
+ >=dev-qt/qtgui-${QTMIN}:5=
+ || (
+ >=dev-qt/qtgui-${QTMIN}:5[libinput]
+ >=dev-qt/qtgui-${QTMIN}:5[X]
+ )
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtwayland-${QTMIN}:5=
+ >=kde-frameworks/kwayland-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5=
+ x11-libs/libxkbcommon
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ >=dev-qt/qtwaylandscanner-${QTMIN}:5
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ ecm_src_prepare
+ ecm_punt_kf_module IdleTime
+ cmake_comment_add_subdirectory autotests # only contains idletime test
+ cmake_run_in src cmake_comment_add_subdirectory idletime
+}