summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-02-22 09:58:57 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-02-22 11:22:28 +0100
commit375c4f8d80ac2947deed202d56ecd285818ee2af (patch)
treec116bd2806b5b4e87ca11ce82d9f2d873b17ffc6 /kde-plasma/kwayland-integration
parentkde-plasma/kwallet-pam: 5.27.1 version bump (diff)
downloadgentoo-375c4f8d80ac2947deed202d56ecd285818ee2af.tar.gz
gentoo-375c4f8d80ac2947deed202d56ecd285818ee2af.tar.bz2
gentoo-375c4f8d80ac2947deed202d56ecd285818ee2af.zip
kde-plasma/kwayland-integration: 5.27.1 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kwayland-integration')
-rw-r--r--kde-plasma/kwayland-integration/Manifest1
-rw-r--r--kde-plasma/kwayland-integration/kwayland-integration-5.27.1.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/kde-plasma/kwayland-integration/Manifest b/kde-plasma/kwayland-integration/Manifest
index ed1ab51a9b03..29329e4235db 100644
--- a/kde-plasma/kwayland-integration/Manifest
+++ b/kde-plasma/kwayland-integration/Manifest
@@ -1,2 +1,3 @@
DIST kwayland-integration-5.26.5.tar.xz 26972 BLAKE2B 108eeebc92768755fba22d7435829f514904a3f39c748a70f220c1ae4fa078d5def0921f6c96effc2c7cc1ae0580d8c251034e87acaf4107d340b7bfdac1e443 SHA512 de252e67f488f920538a15e69836d4b8779a3123e1913c78cb7d69833a8fa475eb1166928cc965bc7ad69aa26d3dc58395ac7d06fb2349120bd014939d81e229
DIST kwayland-integration-5.27.0.tar.xz 25692 BLAKE2B e9b966957fc62e90ab82a0e1b6fa3b6f93bc7b8c97d66452687286bc35739c228262ac867deacc8f8d63df03c84e6ba62210fa6ee392eb07cc0f38fa5b8bb4b1 SHA512 9d9d18100a07ba26714a2bddc73729d8e91cc2c74b57b2093a3aacf9b138583c4224f803b34b13c9c0543ef0131a4e7a7b1d7079c69644b0928bbf272e7d01be
+DIST kwayland-integration-5.27.1.tar.xz 25688 BLAKE2B cf3528a7f11fe9777bc26e060b5d8c78edae65ec7e442298eeafb3f2270a92375903ee2671374d6ae190b93146f80b57580bccd88020822bd2d034ae6757fb7e SHA512 1e618ffa118bbcb362dee66f1532daf2943ea324d6a65540a8088a325f22084a56938fbad7d7f1b8104bb8628d97a814820a79ab1538332c331091feb517a278
diff --git a/kde-plasma/kwayland-integration/kwayland-integration-5.27.1.ebuild b/kde-plasma/kwayland-integration/kwayland-integration-5.27.1.ebuild
new file mode 100644
index 000000000000..8c56787c316b
--- /dev/null
+++ b/kde-plasma/kwayland-integration/kwayland-integration-5.27.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.102.0
+QTMIN=5.15.7
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Provides KWindowSystem integration plugin for Wayland"
+HOMEPAGE="https://invent.kde.org/plasma/kwayland-integration"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+# dev-qt/qtgui: QtXkbCommonSupport is provided by either IUSE libinput or X
+# slot ops:
+# dev-qt/qtgui: QtXkbCommonSupportPrivate
+# dev-qt/qtwayland: Qt::WaylandClientPrivate (private/qwayland*_p.h) stuff
+# kde-frameworks/kwindowsystem: Various private headers
+DEPEND="
+ >=dev-libs/wayland-1.15
+ >=dev-qt/qtgui-${QTMIN}:5=
+ || (
+ >=dev-qt/qtgui-${QTMIN}:5[libinput]
+ >=dev-qt/qtgui-${QTMIN}:5[X]
+ )
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtwayland-${QTMIN}:5=
+ >=kde-frameworks/kwayland-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5=
+ x11-libs/libxkbcommon
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ >=dev-qt/qtwaylandscanner-${QTMIN}:5
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ ecm_src_prepare
+ ecm_punt_kf_module IdleTime
+ cmake_comment_add_subdirectory autotests # only contains idletime test
+ cmake_run_in src cmake_comment_add_subdirectory idletime
+}