summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-02-05 10:55:01 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-02-05 11:12:02 +0100
commit5c041cf3b703ddc1f635a9d56b1412f2675f366e (patch)
treee7ca955425afaf93a52860da69f7b3ce95652eb1 /kde-plasma/plasma-desktop
parentnet-analyzer/testssl: remove 3.0.2 (diff)
downloadgentoo-5c041cf3b703ddc1f635a9d56b1412f2675f366e.tar.gz
gentoo-5c041cf3b703ddc1f635a9d56b1412f2675f366e.tar.bz2
gentoo-5c041cf3b703ddc1f635a9d56b1412f2675f366e.zip
kde-plasma/plasma-desktop: Input related fixes
Upstream commits: cfdaf8636830df3760bf370d48bd4be890ada709 199cad52f0599872e57a2fcb391a459e48146be0 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/plasma-desktop')
-rw-r--r--kde-plasma/plasma-desktop/files/plasma-desktop-5.20.5-compress-new-input-notifications.patch109
-rw-r--r--kde-plasma/plasma-desktop/files/plasma-desktop-5.20.5-kcm_keyboard-no-setxkbmap-on-camera.patch27
-rw-r--r--kde-plasma/plasma-desktop/plasma-desktop-5.20.5-r1.ebuild165
3 files changed, 301 insertions, 0 deletions
diff --git a/kde-plasma/plasma-desktop/files/plasma-desktop-5.20.5-compress-new-input-notifications.patch b/kde-plasma/plasma-desktop/files/plasma-desktop-5.20.5-compress-new-input-notifications.patch
new file mode 100644
index 000000000000..734ae0ef46cf
--- /dev/null
+++ b/kde-plasma/plasma-desktop/files/plasma-desktop-5.20.5-compress-new-input-notifications.patch
@@ -0,0 +1,109 @@
+From 199cad52f0599872e57a2fcb391a459e48146be0 Mon Sep 17 00:00:00 2001
+From: David Faure <faure@kde.org>
+Date: Sun, 31 Jan 2021 20:59:41 +0100
+Subject: [PATCH] Compress notifications about new mouse/keyboard.
+
+When resuming from suspend, I get 5 "new pointer" and 5 "new keyboard"
+events (on a laptop with USB mouse/keyboard, but also stuff like
+"Thinkpad Extra Buttons" adds more notifications than one would expect)
+
+KGlobalAccelImpl::x11MappingNotify is still called 15 times, but
+that's better than 145 times...
+
+"new pointer" notifications end up calling `kcminit mouse`, better
+also compress that.
+---
+ kcms/keyboard/xinput_helper.cpp | 30 +++++++++++++++++++++++++-----
+ kcms/keyboard/xinput_helper.h | 5 ++++-
+ 2 files changed, 29 insertions(+), 6 deletions(-)
+
+diff --git a/kcms/keyboard/xinput_helper.cpp b/kcms/keyboard/xinput_helper.cpp
+index 14974ada7..bade5ea33 100644
+--- a/kcms/keyboard/xinput_helper.cpp
++++ b/kcms/keyboard/xinput_helper.cpp
+@@ -23,6 +23,7 @@
+ #include <QCoreApplication>
+ #include <QX11Info>
+ #include <QDebug>
++#include <QTimer>
+
+ #include <X11/X.h>
+ #include <X11/Xlib.h>
+@@ -56,9 +57,21 @@ static const int DEVICE_POINTER = 2;
+ XInputEventNotifier::XInputEventNotifier(QWidget* parent):
+ XEventNotifier(), //TODO: destruct properly?
+ xinputEventType(-1),
+- udevNotifier(nullptr)
++ udevNotifier(nullptr),
++ keyboardNotificationTimer(new QTimer(this)),
++ mouseNotificationTimer(new QTimer(this))
+ {
+- Q_UNUSED(parent)
++ Q_UNUSED(parent)
++
++ // emit signal only once, even after X11 re-enables N keyboards after resuming from suspend
++ keyboardNotificationTimer->setSingleShot(true);
++ keyboardNotificationTimer->setInterval(500);
++ connect(keyboardNotificationTimer, &QTimer::timeout, this, &XInputEventNotifier::newKeyboardDevice);
++
++ // same for mouse
++ mouseNotificationTimer->setSingleShot(true);
++ mouseNotificationTimer->setInterval(500);
++ connect(mouseNotificationTimer, &QTimer::timeout, this, &XInputEventNotifier::newPointerDevice);
+ }
+
+ void XInputEventNotifier::start()
+@@ -83,11 +96,18 @@ bool XInputEventNotifier::processOtherEvents(xcb_generic_event_t* event)
+ {
+ int newDeviceType = getNewDeviceEventType(event);
+ if( newDeviceType == DEVICE_KEYBOARD ) {
+- emit(newKeyboardDevice());
++ if (!keyboardNotificationTimer->isActive()) {
++ keyboardNotificationTimer->start();
++ }
+ }
+ else if( newDeviceType == DEVICE_POINTER ) {
+- emit(newPointerDevice());
+- emit(newKeyboardDevice()); // arghhh, looks like X resets xkb map even when only pointer device is connected
++ if (!mouseNotificationTimer->isActive()) {
++ mouseNotificationTimer->start();
++ }
++ // arghhh, looks like X resets xkb map even when only pointer device is connected
++ if (!keyboardNotificationTimer->isActive()) {
++ keyboardNotificationTimer->start();
++ }
+ }
+ return true;
+ }
+diff --git a/kcms/keyboard/xinput_helper.h b/kcms/keyboard/xinput_helper.h
+index e29fdc22a..52b6a12b4 100644
+--- a/kcms/keyboard/xinput_helper.h
++++ b/kcms/keyboard/xinput_helper.h
+@@ -25,13 +25,14 @@
+ #include <X11/Xlib.h>
+ #include <fixx11h.h>
+
++class QTimer;
+ class UdevDeviceNotifier;
+
+ class XInputEventNotifier: public XEventNotifier {
+ Q_OBJECT
+
+ public:
+- XInputEventNotifier(QWidget* parent=nullptr);
++ explicit XInputEventNotifier(QWidget* parent=nullptr);
+
+ void start() override;
+ void stop() override;
+@@ -51,6 +52,8 @@ private:
+ int xinputEventType;
+ Display* display;
+ UdevDeviceNotifier *udevNotifier;
++ QTimer* keyboardNotificationTimer;
++ QTimer* mouseNotificationTimer;
+ };
+
+ #endif /* XINPUT_HELPER_H_ */
+--
+GitLab
+
diff --git a/kde-plasma/plasma-desktop/files/plasma-desktop-5.20.5-kcm_keyboard-no-setxkbmap-on-camera.patch b/kde-plasma/plasma-desktop/files/plasma-desktop-5.20.5-kcm_keyboard-no-setxkbmap-on-camera.patch
new file mode 100644
index 000000000000..a2bee27e83d3
--- /dev/null
+++ b/kde-plasma/plasma-desktop/files/plasma-desktop-5.20.5-kcm_keyboard-no-setxkbmap-on-camera.patch
@@ -0,0 +1,27 @@
+From cfdaf8636830df3760bf370d48bd4be890ada709 Mon Sep 17 00:00:00 2001
+From: David Faure <faure@kde.org>
+Date: Sun, 31 Jan 2021 12:04:19 +0100
+Subject: [PATCH] kcm_keyboard: Cameras are not keyboards, don't setxkbmap when
+ plugging a camera
+
+---
+ kcms/keyboard/xinput_helper.cpp | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/kcms/keyboard/xinput_helper.cpp b/kcms/keyboard/xinput_helper.cpp
+index 9cae43369..14974ada7 100644
+--- a/kcms/keyboard/xinput_helper.cpp
++++ b/kcms/keyboard/xinput_helper.cpp
+@@ -102,7 +102,8 @@ static bool isRealKeyboard(const char* deviceName)
+ return strstr(deviceName, "Video Bus") == nullptr
+ && strstr(deviceName, "Sleep Button") == nullptr
+ && strstr(deviceName, "Power Button") == nullptr
+- && strstr(deviceName, "WMI hotkeys") == nullptr;
++ && strstr(deviceName, "WMI hotkeys") == nullptr
++ && strstr(deviceName, "Camera") == nullptr;
+ }
+
+ int XInputEventNotifier::getNewDeviceEventType(xcb_generic_event_t* event)
+--
+GitLab
+
diff --git a/kde-plasma/plasma-desktop/plasma-desktop-5.20.5-r1.ebuild b/kde-plasma/plasma-desktop/plasma-desktop-5.20.5-r1.ebuild
new file mode 100644
index 000000000000..5030782af343
--- /dev/null
+++ b/kde-plasma/plasma-desktop/plasma-desktop-5.20.5-r1.ebuild
@@ -0,0 +1,165 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_HANDBOOK="forceoptional"
+ECM_TEST="true"
+KFMIN=5.74.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.1
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="KDE Plasma desktop"
+XORGHDRS="${PN}-override-include-dirs-0"
+SRC_URI+=" https://dev.gentoo.org/~asturm/distfiles/${XORGHDRS}.tar.xz"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="emoji ibus +kaccounts +policykit scim +semantic-desktop"
+
+BDEPEND="virtual/pkgconfig"
+COMMON_DEPEND="
+ >=dev-qt/qtconcurrent-${QTMIN}:5
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtprintsupport-${QTMIN}:5
+ >=dev-qt/qtsql-${QTMIN}:5
+ >=dev-qt/qtsvg-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ >=kde-frameworks/attica-${KFMIN}:5
+ >=kde-frameworks/kactivities-${KFMIN}:5
+ >=kde-frameworks/kactivities-stats-${KFMIN}:5
+ >=kde-frameworks/karchive-${KFMIN}:5
+ >=kde-frameworks/kauth-${KFMIN}:5
+ >=kde-frameworks/kbookmarks-${KFMIN}:5
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kcodecs-${KFMIN}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-frameworks/kded-${KFMIN}:5
+ >=kde-frameworks/kdelibs4support-${KFMIN}:5
+ >=kde-frameworks/kglobalaccel-${KFMIN}:5
+ >=kde-frameworks/kguiaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kitemmodels-${KFMIN}:5
+ >=kde-frameworks/kitemviews-${KFMIN}:5
+ >=kde-frameworks/kjobwidgets-${KFMIN}:5
+ >=kde-frameworks/knewstuff-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/knotifyconfig-${KFMIN}:5
+ >=kde-frameworks/kparts-${KFMIN}:5
+ >=kde-frameworks/krunner-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ >=kde-frameworks/plasma-${KFMIN}:5
+ >=kde-frameworks/solid-${KFMIN}:5
+ >=kde-frameworks/sonnet-${KFMIN}:5
+ >=kde-plasma/kwin-${PVCUT}:5
+ >=kde-plasma/libksysguard-${PVCUT}:5
+ >=kde-plasma/libkworkspace-${PVCUT}:5
+ >=kde-plasma/plasma-workspace-${PVCUT}:5
+ >=media-libs/phonon-4.11.0
+ x11-libs/libX11
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libxcb[xkb]
+ x11-libs/libxkbfile
+ emoji? (
+ app-i18n/ibus[emoji]
+ dev-libs/glib:2
+ media-fonts/noto-emoji
+ )
+ ibus? (
+ app-i18n/ibus
+ dev-libs/glib:2
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ x11-libs/libxcb
+ x11-libs/xcb-util-keysyms
+ )
+ kaccounts? (
+ kde-apps/kaccounts-integration:5
+ net-libs/accounts-qt
+ )
+ scim? ( app-i18n/scim )
+ semantic-desktop? ( >=kde-frameworks/baloo-${KFMIN}:5 )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-libs/boost
+ x11-base/xorg-proto
+"
+RDEPEND="${COMMON_DEPEND}
+ !<kde-plasma/kdeplasma-addons-5.15.80
+ !kde-plasma/user-manager
+ >=dev-qt/qtgraphicaleffects-${QTMIN}:5
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-frameworks/kirigami-${KFMIN}:5
+ >=kde-frameworks/qqc2-desktop-style-${KFMIN}:5
+ >=kde-plasma/kde-cli-tools-${PVCUT}:5
+ >=kde-plasma/oxygen-${PVCUT}:5
+ sys-apps/util-linux
+ x11-apps/setxkbmap
+ kaccounts? ( net-libs/signon-oauth2 )
+ policykit? ( sys-apps/accountsservice )
+"
+
+PATCHES=(
+ "${WORKDIR}/${XORGHDRS}/override-include-dirs.patch" # downstream patch
+ "${FILESDIR}/${P}-kcm_keyboard-no-setxkbmap-on-camera.patch"
+ "${FILESDIR}/${P}-compress-new-input-notifications.patch"
+)
+
+src_prepare() {
+ ecm_src_prepare
+
+ use policykit || cmake_run_in kcms cmake_comment_add_subdirectory users
+
+ if ! use ibus; then
+ sed -e "s/Qt5X11Extras_FOUND AND XCB_XCB_FOUND AND XCB_KEYSYMS_FOUND/false/" \
+ -i applets/kimpanel/backend/ibus/CMakeLists.txt || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DEvdev_INCLUDE_DIRS="${WORKDIR}/${XORGHDRS}"/include
+ -DXORGLIBINPUT_INCLUDE_DIRS="${WORKDIR}/${XORGHDRS}"/include
+ -DXORGSERVER_INCLUDE_DIRS="${WORKDIR}/${XORGHDRS}"/include
+ -DSynaptics_INCLUDE_DIRS="${WORKDIR}/${XORGHDRS}"/include
+ $(cmake_use_find_package kaccounts AccountsQt5)
+ $(cmake_use_find_package kaccounts KAccounts)
+ $(cmake_use_find_package scim SCIM)
+ $(cmake_use_find_package semantic-desktop KF5Baloo)
+ )
+ if ! use emoji && ! use ibus; then
+ mycmakeargs+=( -DCMAKE_DISABLE_FIND_PACKAGE_IBus=ON )
+ fi
+
+ ecm_src_configure
+}
+
+src_test() {
+ # parallel tests fail, foldermodeltest,positionertest hang, bug #646890
+ # test_kio_fonts needs D-Bus, bug #634166
+ # lookandfeel-kcmTest is unreliable for a long time, bug #607918
+ local myctestargs=(
+ -j1
+ -E "(foldermodeltest|positionertest|test_kio_fonts|lookandfeel-kcmTest)"
+ )
+
+ ecm_src_test
+}