summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-11-28 21:21:50 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-11-28 21:22:16 +0100
commit7a66df3ef78aab42f0e33427c35e5c865cda88c2 (patch)
treec8baf6df564df66acc8c9572e01caeb94bbcd6cc /kde-plasma/plasma-integration/plasma-integration-5.11.4.ebuild
parentwww-client/opera-beta: Old. (diff)
downloadgentoo-7a66df3ef78aab42f0e33427c35e5c865cda88c2.tar.gz
gentoo-7a66df3ef78aab42f0e33427c35e5c865cda88c2.tar.bz2
gentoo-7a66df3ef78aab42f0e33427c35e5c865cda88c2.zip
kde-plasma: Add KDE Plasma 5.11.4
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'kde-plasma/plasma-integration/plasma-integration-5.11.4.ebuild')
-rw-r--r--kde-plasma/plasma-integration/plasma-integration-5.11.4.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/kde-plasma/plasma-integration/plasma-integration-5.11.4.ebuild b/kde-plasma/plasma-integration/plasma-integration-5.11.4.ebuild
new file mode 100644
index 000000000000..2621b8fe1c94
--- /dev/null
+++ b/kde-plasma/plasma-integration/plasma-integration-5.11.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Qt Platform Theme integration plugins for the Plasma workspaces"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwayland)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_plasma_dep breeze)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui 'dbus' '' '5=')
+ $(add_qt_dep qtquickcontrols2)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtx11extras)
+ x11-libs/libXcursor
+ x11-libs/libxcb
+"
+RDEPEND="${DEPEND}
+ media-fonts/hack
+ media-fonts/noto
+"
+
+# requires running kde environment
+RESTRICT+=" test"