summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-10-06 06:03:32 +1100
committerMichael Palimaka <kensington@gentoo.org>2016-10-06 06:10:38 +1100
commit79dfb13de3a7bf196ee8b0f9a7908026d0544a5f (patch)
tree7009950966e6efbbc8b18676ee99e242fde5b221 /kde-plasma/plasma-integration/plasma-integration-5.8.0.ebuild
parentdev-perl/XML-SAX-Writer: arm stable, bug #595058 (diff)
downloadgentoo-79dfb13de3a7bf196ee8b0f9a7908026d0544a5f.tar.gz
gentoo-79dfb13de3a7bf196ee8b0f9a7908026d0544a5f.tar.bz2
gentoo-79dfb13de3a7bf196ee8b0f9a7908026d0544a5f.zip
kde-plasma: version bump 5.8.0
Package-Manager: portage-2.3.1
Diffstat (limited to 'kde-plasma/plasma-integration/plasma-integration-5.8.0.ebuild')
-rw-r--r--kde-plasma/plasma-integration/plasma-integration-5.8.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/kde-plasma/plasma-integration/plasma-integration-5.8.0.ebuild b/kde-plasma/plasma-integration/plasma-integration-5.8.0.ebuild
new file mode 100644
index 000000000000..2805c9b63a61
--- /dev/null
+++ b/kde-plasma/plasma-integration/plasma-integration-5.8.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Qt Platform Theme integration plugins for the Plasma workspaces"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwayland)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_plasma_dep breeze)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui '' '' '5=')
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtx11extras)
+ x11-libs/libXcursor
+"
+RDEPEND="${DEPEND}
+ media-fonts/hack
+ media-fonts/noto
+"
+
+# requires running kde environment
+RESTRICT+=" test"