summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-10-11 19:36:26 +0200
committerMichael Palimaka <kensington@gentoo.org>2016-10-13 05:06:35 +1100
commite559b1743038622ade87249c595dd945a2827b7f (patch)
tree3807d81d8966e59519e9fcaff8f72c1b101cbb82 /kde-plasma/plasma-integration/plasma-integration-5.8.1.ebuild
parentkde-frameworks: remove 5.23.0 (diff)
downloadgentoo-e559b1743038622ade87249c595dd945a2827b7f.tar.gz
gentoo-e559b1743038622ade87249c595dd945a2827b7f.tar.bz2
gentoo-e559b1743038622ade87249c595dd945a2827b7f.zip
kde-plasma: 5.8.1 version bump
Package-Manager: portage-2.3.0
Diffstat (limited to 'kde-plasma/plasma-integration/plasma-integration-5.8.1.ebuild')
-rw-r--r--kde-plasma/plasma-integration/plasma-integration-5.8.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/kde-plasma/plasma-integration/plasma-integration-5.8.1.ebuild b/kde-plasma/plasma-integration/plasma-integration-5.8.1.ebuild
new file mode 100644
index 000000000000..2805c9b63a61
--- /dev/null
+++ b/kde-plasma/plasma-integration/plasma-integration-5.8.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Qt Platform Theme integration plugins for the Plasma workspaces"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwayland)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_plasma_dep breeze)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui '' '' '5=')
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtx11extras)
+ x11-libs/libXcursor
+"
+RDEPEND="${DEPEND}
+ media-fonts/hack
+ media-fonts/noto
+"
+
+# requires running kde environment
+RESTRICT+=" test"