summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-plasma/plasma-meta/plasma-meta-5.3.2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-plasma/plasma-meta/plasma-meta-5.3.2.ebuild')
-rw-r--r--kde-plasma/plasma-meta/plasma-meta-5.3.2.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/kde-plasma/plasma-meta/plasma-meta-5.3.2.ebuild b/kde-plasma/plasma-meta/plasma-meta-5.3.2.ebuild
new file mode 100644
index 000000000000..5a79d6cb306d
--- /dev/null
+++ b/kde-plasma/plasma-meta/plasma-meta-5.3.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit kde5-functions
+
+DESCRIPTION="Merge this to pull in all Plasma 5 packages"
+HOMEPAGE="http://www.kde.org/workspaces/plasmadesktop/"
+
+LICENSE="metapackage"
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE="bluetooth +display-manager gtk +sddm networkmanager +wallpapers"
+
+RDEPEND="
+ $(add_plasma_dep baloo)
+ $(add_plasma_dep breeze)
+ $(add_plasma_dep kde-cli-tools)
+ $(add_plasma_dep kdecoration)
+ $(add_plasma_dep kdeplasma-addons)
+ $(add_plasma_dep kfilemetadata)
+ $(add_plasma_dep khelpcenter)
+ $(add_plasma_dep khotkeys)
+ $(add_plasma_dep kinfocenter)
+ $(add_plasma_dep kmenuedit)
+ $(add_plasma_dep kscreen)
+ $(add_plasma_dep ksshaskpass)
+ $(add_plasma_dep ksysguard)
+ $(add_plasma_dep kwayland)
+ $(add_plasma_dep kwin)
+ $(add_plasma_dep kwrited)
+ $(add_plasma_dep libkscreen)
+ $(add_plasma_dep milou)
+ $(add_plasma_dep oxygen)
+ $(add_plasma_dep oxygen-fonts)
+ $(add_plasma_dep plasma-desktop)
+ $(add_plasma_dep plasma-mediacenter)
+ $(add_plasma_dep plasma-sdk)
+ $(add_plasma_dep plasma-workspace)
+ $(add_plasma_dep polkit-kde-agent)
+ $(add_plasma_dep powerdevil)
+ $(add_plasma_dep systemsettings)
+ bluetooth? (
+ $(add_plasma_dep bluedevil)
+ )
+ display-manager? (
+ sddm? ( x11-misc/sddm )
+ !sddm? ( x11-misc/lightdm )
+ )
+ gtk? ( $(add_plasma_dep kde-gtk-config) )
+ networkmanager? ( $(add_plasma_dep plasma-nm) )
+ sddm? ( $(add_plasma_dep sddm-kcm) )
+ wallpapers? ( $(add_plasma_dep plasma-workspace-wallpapers) )
+"