summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-07-21 04:05:55 +1000
committerMichael Palimaka <kensington@gentoo.org>2016-07-21 04:06:40 +1000
commit724b734d8f30db1b69d3b10e7bc078b58ec94687 (patch)
tree5d2d0c6e994c109f8c643bc2bd09fd1fb6219280 /kde-plasma
parentnet-dns/bind-tools: Remove old Version (diff)
downloadgentoo-724b734d8f30db1b69d3b10e7bc078b58ec94687.tar.gz
gentoo-724b734d8f30db1b69d3b10e7bc078b58ec94687.tar.bz2
gentoo-724b734d8f30db1b69d3b10e7bc078b58ec94687.zip
kde-plasma/breeze: introduce wayland USE flag
Gentoo-bug: 589216 Package-Manager: portage-2.3.0
Diffstat (limited to 'kde-plasma')
-rw-r--r--kde-plasma/breeze/breeze-5.7.2.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/kde-plasma/breeze/breeze-5.7.2.ebuild b/kde-plasma/breeze/breeze-5.7.2.ebuild
index 0dd27ab7628e..7a46fbc4719c 100644
--- a/kde-plasma/breeze/breeze-5.7.2.ebuild
+++ b/kde-plasma/breeze/breeze-5.7.2.ebuild
@@ -9,7 +9,7 @@ inherit kde5 multibuild
DESCRIPTION="Breeze visual style for the Plasma desktop"
HOMEPAGE="https://projects.kde.org/projects/kde/workspace/breeze"
KEYWORDS="~amd64 ~arm ~x86"
-IUSE="qt4"
+IUSE="qt4 wayland"
COMMON_DEPEND="
$(add_frameworks_dep frameworkintegration)
@@ -19,7 +19,6 @@ COMMON_DEPEND="
$(add_frameworks_dep kcoreaddons)
$(add_frameworks_dep kguiaddons)
$(add_frameworks_dep ki18n)
- $(add_frameworks_dep kwayland)
$(add_frameworks_dep kwidgetsaddons)
$(add_frameworks_dep kwindowsystem)
$(add_plasma_dep kdecoration)
@@ -32,6 +31,7 @@ COMMON_DEPEND="
kde-base/kdelibs:4
x11-libs/libX11
)
+ wayland? ( $(add_frameworks_dep kwayland) )
"
DEPEND="${COMMON_DEPEND}
$(add_frameworks_dep kpackage)
@@ -48,7 +48,9 @@ pkg_setup() {
src_configure() {
myconfigure() {
- local mycmakeargs=()
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package wayland KF5Wayland)
+ )
if [[ ${MULTIBUILD_VARIANT} = qt4 ]] ; then
mycmakeargs+=( -DUSE_KDE4=true )