summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /lxqt-base/lxqt-globalkeys
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'lxqt-base/lxqt-globalkeys')
-rw-r--r--lxqt-base/lxqt-globalkeys/Manifest3
-rw-r--r--lxqt-base/lxqt-globalkeys/lxqt-globalkeys-0.7.0.ebuild28
-rw-r--r--lxqt-base/lxqt-globalkeys/lxqt-globalkeys-0.8.0.ebuild44
-rw-r--r--lxqt-base/lxqt-globalkeys/lxqt-globalkeys-0.9.0.ebuild37
-rw-r--r--lxqt-base/lxqt-globalkeys/metadata.xml9
5 files changed, 121 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-globalkeys/Manifest b/lxqt-base/lxqt-globalkeys/Manifest
new file mode 100644
index 000000000000..86c6d536a7f1
--- /dev/null
+++ b/lxqt-base/lxqt-globalkeys/Manifest
@@ -0,0 +1,3 @@
+DIST lxqt-globalkeys-0.7.0.tar.xz 51672 SHA256 588152d64aed4fe767b8eeb4d241fdf51fbcf13cace16bc4c5304c22b09c83e2 SHA512 6fb588d9fc801f44be9f093e9372cc7d226e02ef83e7204ab489ef45f425109b3d50b75bcf41c48375de3f9681e37fb1878320c3af37ad2a169e63075e849d20 WHIRLPOOL a42de2ab8159987a329c0f26e81fab1d93b26e1bd55b15ec8e2fc40141abbf0ba0760676522115cfdb660b93ce6281b0f2018c84c7b35689dcebbe009ab73d84
+DIST lxqt-globalkeys-0.8.0.tar.xz 52676 SHA256 dd15a5d6f5818ddd00a7b3fbde483bbd8ce88d2dfaa4a6e98ca54c7492cbd713 SHA512 1afb5b1080c2005545dd74b064b7b9da653ae8a8107898e2f4303ec7e77b4e8377094dc50dc3d36b07521fa6dbbf1b7cb812444d62a429b20428667da491a6e2 WHIRLPOOL c17c625163c509ab1ccd732c640eb67e72cc0f59ff5b285b360e55b19175ff9b5abe5cf443d077066aaeb9ea86c86887fde41fa3d1e76e6b1065bbdf07307d68
+DIST lxqt-globalkeys-0.9.0.tar.xz 50692 SHA256 45292e125e8cc2f18afa7d358366ade670c8d73871caf04f4536a4be985d9f12 SHA512 c3f282b8a915a10f754165d83434c693ecdcc3b0d033b19d378c536f5490e6eebfd539ecac361b41c95d1243a30d4c2eeba6ac57bf74ed5de115effac1cc4e23 WHIRLPOOL 972ad21e8ae67c42111270b99f0cafdea327833703937462cfd56ea51823afb45793fa2c0f40c58dbe451029c437b020cbb32b80636037cff675564e6d89525e
diff --git a/lxqt-base/lxqt-globalkeys/lxqt-globalkeys-0.7.0.ebuild b/lxqt-base/lxqt-globalkeys/lxqt-globalkeys-0.7.0.ebuild
new file mode 100644
index 000000000000..dc11d828bac3
--- /dev/null
+++ b/lxqt-base/lxqt-globalkeys/lxqt-globalkeys-0.7.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="Daemon and library for global keyboard shortcuts registration"
+HOMEPAGE="http://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
+else
+ SRC_URI="http://downloads.lxqt.org/lxqt/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~x86"
+ S=${WORKDIR}
+fi
+
+LICENSE="GPL-2 LGPL-2.1+"
+SLOT="0"
+
+DEPEND="dev-qt/qtcore:4
+ dev-qt/qtdbus:4
+ dev-qt/qtgui:4
+ ~lxqt-base/liblxqt-${PV}
+ x11-libs/libX11"
+RDEPEND="${DEPEND}"
diff --git a/lxqt-base/lxqt-globalkeys/lxqt-globalkeys-0.8.0.ebuild b/lxqt-base/lxqt-globalkeys/lxqt-globalkeys-0.8.0.ebuild
new file mode 100644
index 000000000000..c1e3f29a58b2
--- /dev/null
+++ b/lxqt-base/lxqt-globalkeys/lxqt-globalkeys-0.8.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="Daemon and library for global keyboard shortcuts registration"
+HOMEPAGE="http://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
+else
+ SRC_URI="http://downloads.lxqt.org/lxqt/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2 LGPL-2.1+"
+SLOT="0"
+
+DEPEND="
+ dev-qt/linguist-tools:5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtxml:5
+ ~lxqt-base/liblxqt-${PV}
+ >=dev-libs/libqtxdg-1.0.0
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_QT5=ON
+ )
+ cmake-utils_src_configure
+}
diff --git a/lxqt-base/lxqt-globalkeys/lxqt-globalkeys-0.9.0.ebuild b/lxqt-base/lxqt-globalkeys/lxqt-globalkeys-0.9.0.ebuild
new file mode 100644
index 000000000000..e1ab0cab4136
--- /dev/null
+++ b/lxqt-base/lxqt-globalkeys/lxqt-globalkeys-0.9.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="Daemon and library for global keyboard shortcuts registration"
+HOMEPAGE="http://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
+else
+ SRC_URI="http://downloads.lxqt.org/lxqt/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="GPL-2 LGPL-2.1+"
+SLOT="0"
+
+DEPEND="
+ dev-qt/linguist-tools:5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtxml:5
+ ~lxqt-base/liblxqt-${PV}
+ >=dev-libs/libqtxdg-1.0.0
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+"
+RDEPEND="${DEPEND}"
diff --git a/lxqt-base/lxqt-globalkeys/metadata.xml b/lxqt-base/lxqt-globalkeys/metadata.xml
new file mode 100644
index 000000000000..d89dead0ed86
--- /dev/null
+++ b/lxqt-base/lxqt-globalkeys/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>lxqt</herd>
+ <maintainer>
+ <email>jauhien@gentoo.org</email>
+ <name>Jauhien Piatlicki</name>
+ </maintainer>
+</pkgmetadata>