summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Feldman <NP-Hardass@gentoo.org>2020-03-03 22:52:41 -0500
committerAdam Feldman <NP-Hardass@gentoo.org>2020-04-06 13:47:44 -0400
commit6c1f3af8c6b934df65e18c3152e3ec248bd71c44 (patch)
tree040d39a6fc136f7a1c52eda950174eef0a63caa8 /mate-base/mate-applets
parentmedia-gfx/eom: Bump to 1.22.2 (diff)
downloadgentoo-6c1f3af8c6b934df65e18c3152e3ec248bd71c44.tar.gz
gentoo-6c1f3af8c6b934df65e18c3152e3ec248bd71c44.tar.bz2
gentoo-6c1f3af8c6b934df65e18c3152e3ec248bd71c44.zip
mate-base/mate-applets: Bump to 1.22.2, make cpupower optional
Package-Manager: Portage-2.3.82, Repoman-2.3.18 Signed-off-by: Adam Feldman <NP-Hardass@gentoo.org>
Diffstat (limited to 'mate-base/mate-applets')
-rw-r--r--mate-base/mate-applets/Manifest1
-rw-r--r--mate-base/mate-applets/mate-applets-1.22.2.ebuild92
-rw-r--r--mate-base/mate-applets/metadata.xml5
3 files changed, 98 insertions, 0 deletions
diff --git a/mate-base/mate-applets/Manifest b/mate-base/mate-applets/Manifest
index 358d40e2d93f..17f8098decb0 100644
--- a/mate-base/mate-applets/Manifest
+++ b/mate-base/mate-applets/Manifest
@@ -1,2 +1,3 @@
DIST mate-applets-1.22.0.tar.xz 7739668 BLAKE2B dc3768d2f5eb987907f1ffb1a049dff990140c66c51427dc9095298be92b17b2b1e9695f3c35dae73433e1e50d05477e94aad1697b2bf15706515c16150096d7 SHA512 2f3e17414171ec5ab6967b76b1291d99783c3091b51127788f99148f46d5f2068edf7d890c3ebca1a59c29cbda4a06be11c852e5e88d4dc58e9981d906c9e34c
DIST mate-applets-1.22.1.tar.xz 7602112 BLAKE2B 22dc076d188cddf9c5160d7ecaddb14ecc41a575abac91b72959054f3fe1c961c80b1aa9171150e7c4ce61ccee0783572726386319312dc97f64d4f9266c1a6d SHA512 d132c8b5e433a557785745032235a5792d04edd7c249269d9a4066fb345b76955bdca71164f7b321f41f566803694d85d9cd7690fbd699daa54788572f0eb986
+DIST mate-applets-1.22.2.tar.xz 7648744 BLAKE2B 85235f12c1436c3caaa6429aabd16822ae34c5c4bd7a575aa9be2c2e9080734b39180e34b22fdf265a64b5ebffb24071d8768b99f55736631403da02882e45fe SHA512 a57ed37d6ddef303e40cbd8f811d1c6be473eeee78a5b56c5eb280d7dba10668678bf9203425f735fb3b356f4ec33eb2369867aa3ab4b446748fe36b80194e8f
diff --git a/mate-base/mate-applets/mate-applets-1.22.2.ebuild b/mate-base/mate-applets/mate-applets-1.22.2.ebuild
new file mode 100644
index 000000000000..c584a18c500d
--- /dev/null
+++ b/mate-base/mate-applets/mate-applets-1.22.2.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="Applets for the MATE Desktop and Panel"
+LICENSE="GPL-2 FDL-1.1 LGPL-2"
+SLOT="0"
+
+IUSE="X +cpupower ipv6 policykit +upower"
+
+REQUIRED_USE="policykit? ( cpupower )"
+
+COMMON_DEPEND="dev-libs/atk
+ >=dev-libs/dbus-glib-0.74
+ >=dev-libs/glib-2.50:2
+ >=dev-libs/libmateweather-1.17.0
+ >=dev-libs/libxml2-2.5:2
+ >=gnome-base/libgtop-2.12.0:2=
+ >=gnome-extra/gucharmap-3.0:2.90
+ >=mate-base/mate-panel-1.17.0
+ >=net-wireless/wireless-tools-28_pre9:0
+ >=sys-apps/dbus-1.1.2
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22:3
+ x11-libs/gtksourceview:3.0
+ >=x11-libs/libnotify-0.7
+ x11-libs/libX11
+ >=x11-libs/libwnck-3.0:3
+ x11-libs/pango
+ virtual/libintl
+ cpupower? (
+ sys-power/cpupower
+ policykit? ( >=sys-auth/polkit-0.97:0 )
+ )
+ upower? ( >=sys-power/upower-0.9.23 )
+ !!net-analyzer/mate-netspeed"
+
+RDEPEND="${COMMON_DEPEND}
+ >=mate-base/mate-settings-daemon-1.6"
+
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.3
+ app-text/rarian
+ >=app-text/scrollkeeper-dtd-1:1.0
+ app-text/yelp-tools
+ >=dev-util/intltool-0.50.1
+ dev-libs/libxslt
+ sys-devel/gettext:*
+ virtual/pkgconfig:*"
+
+src_configure() {
+
+ # configure.ac logic is a little hinky
+ # and ignores --enable flags for cpufreq
+ use cpupower || myconf="--disable-cpufreq"
+
+ mate_src_configure \
+ --libexecdir=/usr/libexec/mate-applets \
+ $(use_with X x) \
+ $(use_with upower) \
+ $(use_enable ipv6) \
+ $(use_enable policykit polkit) \
+ "${myconf[@]}"
+}
+
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ emake check
+}
+
+src_install() {
+ mate_src_install
+
+ local APPLETS="accessx-status battstat charpick command cpufreq drivemount
+ geyes mateweather multiload netspeed stickynotes
+ timerapplet trashapplet"
+
+ for applet in ${APPLETS}; do
+ docinto ${applet}
+
+ for d in AUTHORS ChangeLog NEWS README README.themes TODO; do
+ [ -s ${applet}/${d} ] && dodoc ${applet}/${d}
+ done
+ done
+}
diff --git a/mate-base/mate-applets/metadata.xml b/mate-base/mate-applets/metadata.xml
index b0eeaf57aae6..0d83665f3d52 100644
--- a/mate-base/mate-applets/metadata.xml
+++ b/mate-base/mate-applets/metadata.xml
@@ -5,6 +5,11 @@
<email>mate@gentoo.org</email>
<name>Gentoo MATE Desktop</name>
</maintainer>
+ <use>
+ <flag name="cpupower">
+ Enable support for cpu frequency manipulation using <pkg>sys-power/cpupower</pkg>
+ </flag>
+ </use>
<upstream>
<remote-id type="github">mate-desktop/mate-applets</remote-id>
</upstream>