summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2016-08-11 02:31:31 -0400
committerNP-Hardass <NP-Hardass@gentoo.org>2016-08-12 01:11:50 -0400
commit971e0471537dc3780793ea4d82dadacaed8147cf (patch)
tree0b8b76ef86dc3d961b5e2873c902bd96446f432a /mate-base/mate-desktop/mate-desktop-1.12.1-r2.ebuild
parentmate-base/mate-common: 1.12.x vbump, import from project repo (diff)
downloadgentoo-971e0471537dc3780793ea4d82dadacaed8147cf.tar.gz
gentoo-971e0471537dc3780793ea4d82dadacaed8147cf.tar.bz2
gentoo-971e0471537dc3780793ea4d82dadacaed8147cf.zip
mate-base/mate-desktop: 1.12.x vbump, add gtk3 support, import from project repo
Package-Manager: portage-2.3.0
Diffstat (limited to 'mate-base/mate-desktop/mate-desktop-1.12.1-r2.ebuild')
-rw-r--r--mate-base/mate-desktop/mate-desktop-1.12.1-r2.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/mate-base/mate-desktop/mate-desktop-1.12.1-r2.ebuild b/mate-base/mate-desktop/mate-desktop-1.12.1-r2.ebuild
new file mode 100644
index 000000000000..ae78a7acd8cc
--- /dev/null
+++ b/mate-base/mate-desktop/mate-desktop-1.12.1-r2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MATE_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit mate multilib python-r1
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="Libraries for the MATE desktop that are not part of the UI"
+LICENSE="GPL-2 FDL-1.1 LGPL-2"
+SLOT="0"
+
+IUSE="X debug gtk3 +introspection startup-notification"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-libs/glib-2.36:2
+ x11-libs/cairo:0
+ >=x11-libs/gdk-pixbuf-2.4:2[introspection?]
+ x11-libs/libX11:0
+ >=x11-libs/libXrandr-1.3:0
+ virtual/libintl:0
+ !gtk3? ( >=x11-libs/gtk+-2.24:2[introspection?] )
+ gtk3? ( >=x11-libs/gtk+-3.0:3[introspection?] )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.7:= )
+ startup-notification? ( >=x11-libs/startup-notification-0.5:0 )"
+
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.40:*
+ >=gnome-base/dconf-0.13.4:0
+ sys-devel/gettext:*
+ >=x11-proto/randrproto-1.3:0
+ x11-proto/xproto:0
+ virtual/pkgconfig:*"
+
+src_configure() {
+ mate_src_configure \
+ --enable-mate-about \
+ --disable-mate-conf-import \
+ --with-gtk=$(usex gtk3 3.0 2.0) \
+ $(use_with X x) \
+ $(use_enable debug) \
+ $(use_enable introspection) \
+ $(use_enable startup-notification)
+}