summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2019-03-17 01:50:25 +0300
committerMikle Kolyada <zlogene@gentoo.org>2019-03-17 14:11:01 +0300
commit73f113ea713a96b2620b3298464e0d6b3615572a (patch)
treed6b43bac5ff360090cb3c1774971ba2ae660e800 /mate-base
parentmate-base/mate-applets-meta: Version bump (v1.22.0) (diff)
downloadgentoo-73f113ea713a96b2620b3298464e0d6b3615572a.tar.gz
gentoo-73f113ea713a96b2620b3298464e0d6b3615572a.tar.bz2
gentoo-73f113ea713a96b2620b3298464e0d6b3615572a.zip
mate-base/mate-desktop: Version bump (v1.22.0)
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'mate-base')
-rw-r--r--mate-base/mate-desktop/Manifest1
-rw-r--r--mate-base/mate-desktop/mate-desktop-1.22.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/mate-base/mate-desktop/Manifest b/mate-base/mate-desktop/Manifest
index 0f27e7551437..611216c84816 100644
--- a/mate-base/mate-desktop/Manifest
+++ b/mate-base/mate-desktop/Manifest
@@ -1 +1,2 @@
DIST mate-desktop-1.18.0.tar.xz 827332 BLAKE2B e5a0439c768a388a76f1bd2a7ba819d92fd020565d63d4b412c5edac54c28493e83d9fa9c5b9f7c82dd5d76338f257e7cb8db7318d7743f6101098f20d47db5c SHA512 0490e9810009923fa315e7f191103bc797c37f4417cf41bf317c55d26f7b52a848a65c28dde6903a861694c131ca52f3ed0be05cbbf6b2dd1cb216539f513220
+DIST mate-desktop-1.22.0.tar.xz 962580 BLAKE2B 0bc3418ab25fd9f30e216a5b845722327449f8d05944c028b4cb967acd6415ca9c3c560856485f34e90752c9a3263ba093e1eb69daaea2586c6371ad4c4ee22f SHA512 3950249c0bc026163da7f38a6fd5551c0e1e863e298e9d2ca224679b6c802d1deaf12e16ea873a2ea0539a7989a523d0495fb0dc4c556857203c0b04ab6edf7a
diff --git a/mate-base/mate-desktop/mate-desktop-1.22.0.ebuild b/mate-base/mate-desktop/mate-desktop-1.22.0.ebuild
new file mode 100644
index 000000000000..1841eb283ae9
--- /dev/null
+++ b/mate-base/mate-desktop/mate-desktop-1.22.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="Libraries for the MATE desktop that are not part of the UI"
+LICENSE="GPL-2 FDL-1.1 LGPL-2"
+SLOT="0"
+
+IUSE="X debug +introspection startup-notification"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.50:2
+ >=gnome-base/dconf-0.13.4
+ x11-libs/cairo
+ x11-libs/libX11
+ >=x11-libs/libXrandr-1.3
+ virtual/libintl
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.7:= )
+ startup-notification? ( >=x11-libs/startup-notification-0.5:0 )"
+
+RDEPEND="${COMMON_DEPEND}"
+
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.40:*
+ sys-devel/gettext:*
+ x11-base/xorg-proto
+ virtual/pkgconfig:*"
+
+src_configure() {
+ mate_src_configure \
+ --enable-mate-about \
+ $(use_with X x) \
+ $(use_enable debug) \
+ $(use_enable introspection) \
+ $(use_enable startup-notification)
+}