summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-03-30 23:50:17 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-03-31 12:47:30 +0200
commite833a3cb5ddd06db4819af66b8c2a513438aa2b7 (patch)
treeb417c689cfd47016abb213bb687815420ca96dd3 /mate-extra/mate-power-manager
parentmate-extra/mate-screensaver: add elogind support (diff)
downloadgentoo-e833a3cb5ddd06db4819af66b8c2a513438aa2b7.tar.gz
gentoo-e833a3cb5ddd06db4819af66b8c2a513438aa2b7.tar.bz2
gentoo-e833a3cb5ddd06db4819af66b8c2a513438aa2b7.zip
mate-extra/mate-power-manager: Add USE elogind
logind is detected at runtime, so move the session manager trifecta to RDEPEND. Closes: https://bugs.gentoo.org/633336 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'mate-extra/mate-power-manager')
-rw-r--r--mate-extra/mate-power-manager/mate-power-manager-1.22.0.ebuild15
1 files changed, 10 insertions, 5 deletions
diff --git a/mate-extra/mate-power-manager/mate-power-manager-1.22.0.ebuild b/mate-extra/mate-power-manager/mate-power-manager-1.22.0.ebuild
index 6414a546dfbc..9b2c5e906964 100644
--- a/mate-extra/mate-power-manager/mate-power-manager-1.22.0.ebuild
+++ b/mate-extra/mate-power-manager/mate-power-manager-1.22.0.ebuild
@@ -10,10 +10,12 @@ if [[ ${PV} != 9999 ]]; then
fi
DESCRIPTION="A session daemon for MATE that makes it easy to manage your laptop or desktop"
+
LICENSE="GPL-2"
SLOT="0"
+IUSE="+applet elogind gnome-keyring policykit systemd test"
-IUSE="+applet gnome-keyring policykit systemd test"
+REQUIRED_USE="?? ( elogind systemd )"
# Interactive testsuite.
RESTRICT="test"
@@ -33,12 +35,15 @@ COMMON_DEPEND=">=dev-libs/dbus-glib-0.70
x11-libs/pango
applet? ( >=mate-base/mate-panel-1.17.0 )
gnome-keyring? ( >=gnome-base/libgnome-keyring-3 )
- >=sys-power/upower-0.9.23:=
- systemd? ( sys-apps/systemd )
- !systemd? ( >=sys-auth/consolekit-0.9.2 )"
+ >=sys-power/upower-0.9.23:="
RDEPEND="${COMMON_DEPEND}
- policykit? ( >=mate-extra/mate-polkit-1.6 )"
+ policykit? ( >=mate-extra/mate-polkit-1.6 )
+ systemd? ( sys-apps/systemd )
+ !systemd? (
+ elogind? ( sys-auth/elogind )
+ !elogind? ( >=sys-auth/consolekit-0.9.2 )
+ )"
DEPEND="${COMMON_DEPEND}
app-text/docbook-xml-dtd:4.3