summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEttore Di Giacinto <mudler@gentoo.org>2016-11-03 11:49:07 +0100
committerEttore Di Giacinto <mudler@gentoo.org>2016-12-08 16:29:53 +0100
commit1fec6544211cf561d1f89dce9ff45f7b7bc48c77 (patch)
treec12f2764c32812a106eacdc5e83eecd45382bd16 /mate-extra
parentmate-base/caja: version bump to 1.16.1 (diff)
downloadgentoo-1fec6544211cf561d1f89dce9ff45f7b7bc48c77.tar.gz
gentoo-1fec6544211cf561d1f89dce9ff45f7b7bc48c77.tar.bz2
gentoo-1fec6544211cf561d1f89dce9ff45f7b7bc48c77.zip
mate-extra/mate-polkit: version bump to 1.16.0
* now is gtk3 only, dropping gtk3 useflag Package-Manager: portage-2.3.1
Diffstat (limited to 'mate-extra')
-rw-r--r--mate-extra/mate-polkit/Manifest1
-rw-r--r--mate-extra/mate-polkit/mate-polkit-1.16.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/mate-extra/mate-polkit/Manifest b/mate-extra/mate-polkit/Manifest
index 6a9ab0811558..93a58402ef5a 100644
--- a/mate-extra/mate-polkit/Manifest
+++ b/mate-extra/mate-polkit/Manifest
@@ -1,2 +1,3 @@
DIST mate-polkit-1.12.0.tar.xz 324708 SHA256 c38f0a0c3d4e10fc95d27fa4e8d47eb6948e8c9279a82f316f563666571bf8b9 SHA512 b6e771062e29d2f4f2823638e39f5e5b349b98fcf8fd8d652d847d568eee919d37956089d7bef1463d96f801f852d10d9423bb8c20f8a54dfe8188d19ab6fb0c WHIRLPOOL bc35601f824af52ac1162aeb3342789e8fbb4f6a09b5352fffd5db87d9c02f6ddba326002a13533531c772234994c845dfbe1473563bec1c442606688b6909f4
DIST mate-polkit-1.14.0.tar.xz 339872 SHA256 929d5710d6284f924dc65824b75e9da23b5809c50033da18b6b4b79e0f599ddd SHA512 f3507380152798af192e3338b5f056b1105fd297e935f098803c21450b04b6d149bc22106f34129a6394655be2e6505c91ad1433e817c68274a1243cc862bcdf WHIRLPOOL 034f05c91c5f79f1c77b073ff8f310e0264541e9783d98dabdc0dda5b0bc36da83ad4468563d9ecb6bdd389065b1b5d828deba02c15a94867124c6687ff54098
+DIST mate-polkit-1.16.0.tar.xz 340500 SHA256 e0aba1f4be2fef30a74509aef92c5773ee17c2279f158a7295415f700713457c SHA512 9b2a1870fdbe828b39ced7b24e1096edb559dcd553bac3fb15a6ab8d5dbc442870916f5105550a0e14cf3e85ac06c798d7daf0b464a182ba686bb3eb1bac1cb4 WHIRLPOOL feab6da57d80707f12dc42d3acd75dff58e1c61023d726579929b5b1901edc35629d68265ff369f020ca18e0be64a238d8d6acace2437a66df8dfefd3f201873
diff --git a/mate-extra/mate-polkit/mate-polkit-1.16.0.ebuild b/mate-extra/mate-polkit/mate-polkit-1.16.0.ebuild
new file mode 100644
index 000000000000..09eaf4dc9bf2
--- /dev/null
+++ b/mate-extra/mate-polkit/mate-polkit-1.16.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="A MATE specific DBUS service that is used to bring up authentication dialogs"
+LICENSE="LGPL-2"
+SLOT="0"
+
+IUSE="accountsservice appindicator debug examples +introspection"
+
+COMMON_DEPEND=">=dev-libs/glib-2.36:2
+ >=sys-auth/polkit-0.102:0[introspection?]
+ x11-libs/gdk-pixbuf:2[introspection?]
+ virtual/libintl:0
+ >=x11-libs/gtk+-3.14.0:3[introspection?]
+ appindicator? ( dev-libs/libappindicator:3 )
+ introspection? ( >=dev-libs/gobject-introspection-0.6.2:= )"
+
+RDEPEND="${COMMON_DEPEND}
+ accountsservice? ( sys-apps/accountsservice:0[introspection?] )"
+
+DEPEND="${COMMON_DEPEND}
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.35:*
+ sys-devel/gettext:*
+ >=sys-devel/libtool-2.2.6
+ virtual/pkgconfig:*
+ !<gnome-extra/polkit-gnome-0.102:0"
+
+src_configure() {
+ mate_src_configure \
+ --disable-static \
+ $(use_enable accountsservice) \
+ $(use_enable appindicator) \
+ $(use_enable debug) \
+ $(use_enable examples) \
+ $(use_enable introspection)
+}