summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2016-11-27 16:45:13 +0900
committerAkinori Hattori <hattya@gentoo.org>2016-11-27 16:45:13 +0900
commit8fe63cc7a61810e2738e0b1c65d2d18c8e4268b2 (patch)
tree4c9b6b87dc1ee54a971e85facdb512904af94258 /media-fonts
parentmedia-fonts/mplus-outline-fonts: drop old (diff)
downloadgentoo-8fe63cc7a61810e2738e0b1c65d2d18c8e4268b2.tar.gz
gentoo-8fe63cc7a61810e2738e0b1c65d2d18c8e4268b2.tar.bz2
gentoo-8fe63cc7a61810e2738e0b1c65d2d18c8e4268b2.zip
media-fonts/mplus-outline-fonts: new upstream release
Package-Manager: portage-2.3.0
Diffstat (limited to 'media-fonts')
-rw-r--r--media-fonts/mplus-outline-fonts/Manifest1
-rw-r--r--media-fonts/mplus-outline-fonts/mplus-outline-fonts-0_pre062.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/media-fonts/mplus-outline-fonts/Manifest b/media-fonts/mplus-outline-fonts/Manifest
index e2ac1de40a68..ddec3bed5c81 100644
--- a/media-fonts/mplus-outline-fonts/Manifest
+++ b/media-fonts/mplus-outline-fonts/Manifest
@@ -1,2 +1,3 @@
DIST mplus-TESTFLIGHT-059.tar.xz 9626000 SHA256 7862e113e04986646117267c4baee30aea163d43a382c14693f15287f16bbf25 SHA512 2e46a92b2132590488341b314dea94c8c6ca40bf032bab7ebb5bf06bfd789be47be4596f42a6a5e0815cca374279c781ff3a1b2eff485c17f0f07677f1e620b8 WHIRLPOOL 2c773837ae657c239d1859a471df5e757b33034b3c577b307ba03f536e787ba7ea0b7da7ed9d706a09041af2d146a8c5dc7d1e6bb5fc4240f81885feb648f034
DIST mplus-TESTFLIGHT-061.tar.xz 9995208 SHA256 0f8983267ae274b5c47d17db4aca193dfce3558c6561aa6e95c9212f68313bfb SHA512 108688ecc4c00cfe65156a80b1b784526d45d7261a8a203924abf7589e8e771d670de128d4ff306d3a07a2eacd548867311bf5d73b3bb56a731791eabb6ff16f WHIRLPOOL 46550c87a4d335cf384e14a8ed40f1b76efcffb9509a85c52aed203b665d1cc8e01fd38434aaf582128ec55ceff03cf103880c9c6860e338f1338cd353e0d923
+DIST mplus-TESTFLIGHT-062.tar.xz 10173592 SHA256 0ac2b66f814129dcf327061944b6b409b6dae9e22f94f1a383d216556ddd84b8 SHA512 c8c4a9419423c9e98a64e344db7bcbc3b2d6b1ef08219a445acc18a6c5d39bdf3216a827c20ed41b25368e792986937623de31579a9ece5109954db7f0dd6d9c WHIRLPOOL 6aa3ce6741a05583c744a099eaeb6549a33d77f238ff910911d60534bc28e986898a38d9a9bbafe848bdf430b7aa257f31bdfef3db5bdc3f31eeb90b0728baef
diff --git a/media-fonts/mplus-outline-fonts/mplus-outline-fonts-0_pre062.ebuild b/media-fonts/mplus-outline-fonts/mplus-outline-fonts-0_pre062.ebuild
new file mode 100644
index 000000000000..a270da4bd3a4
--- /dev/null
+++ b/media-fonts/mplus-outline-fonts/mplus-outline-fonts-0_pre062.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+inherit font
+
+MY_P="mplus-${PV/0_pre/TESTFLIGHT-}"
+
+DESCRIPTION="M+ Japanese outline fonts"
+HOMEPAGE="http://mplus-fonts.osdn.jp/ http://ossipedia.ipa.go.jp/ipafont/"
+SRC_URI="mirror://sourceforge.jp/mplus-fonts/62344/${MY_P}.tar.xz"
+
+LICENSE="mplus-fonts ipafont? ( IPAfont )"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~x86 ~ppc-macos ~x86-macos"
+IUSE="ipafont"
+RESTRICT="binchecks strip"
+
+DEPEND="ipafont? (
+ media-gfx/fontforge
+ media-fonts/ja-ipafonts
+ )"
+RDEPEND=""
+S="${WORKDIR}/${MY_P}"
+
+FONT_SUFFIX="ttf"
+FONT_S="${S}"
+DOCS="README_J README_E"
+
+IPAFONT_DIR="${EPREFIX}/usr/share/fonts/ja-ipafonts"
+
+src_prepare() {
+ if use ipafont; then
+ cp -p "${IPAFONT_DIR}"/ipag.ttf "${S}" || die
+ fi
+ default
+}
+
+src_compile() {
+ if use ipafont; then
+ fontforge -script m++ipa.pe || die
+ rm -f ipag.ttf
+ fi
+}