summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-12-07 13:28:20 +0100
committerPacho Ramos <pacho@gentoo.org>2016-12-07 13:29:02 +0100
commit04b137623323d98502764efa999c91efddebd951 (patch)
tree0b32c9ad82518e0f4c75cfd6880912e887c1defd /media-gfx/displaycal
parentsys-kernel/vanilla-sources: Automated version bump to 4.4.36 - remove old. (diff)
downloadgentoo-04b137623323d98502764efa999c91efddebd951.tar.gz
gentoo-04b137623323d98502764efa999c91efddebd951.tar.bz2
gentoo-04b137623323d98502764efa999c91efddebd951.zip
media-gfx/displaycal: Version bump (#601182)
Package-Manager: portage-2.3.2
Diffstat (limited to 'media-gfx/displaycal')
-rw-r--r--media-gfx/displaycal/Manifest1
-rw-r--r--media-gfx/displaycal/displaycal-3.2.1.0.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/media-gfx/displaycal/Manifest b/media-gfx/displaycal/Manifest
index 463325fae987..d9c5d10aa0c8 100644
--- a/media-gfx/displaycal/Manifest
+++ b/media-gfx/displaycal/Manifest
@@ -1,3 +1,4 @@
DIST DisplayCAL-3.1.2.0.tar.gz 9361108 SHA256 78dbfd2be1cf7542657cc0f5ed9e16e27558206a4878ffae5ce68bd62460680d SHA512 2c14ed0230e6bdd6f8876a5e8887498e3005941e2f68aedad2926f9b8dda642e909f9aa70205977123b1b7c1376dd3f361ad08ecc5015bfae77342ff1b848837 WHIRLPOOL 74f311618190974e6e9c0c5b895ab7f0dba18de06e52dcf1cca4df0373a278b4c4e170b6add51bdf550b21499ff1ecf249cae6f2eb2f3e0813c666bd0bc4f941
DIST DisplayCAL-3.1.3.1.tar.gz 9555280 SHA256 d48e0b12c0b4fe75e0c99eb5fd85c8651afc2c3a2e72d29ade9bb0a76e61f645 SHA512 ef560155cf0eebf4fcd9beab699afd6f0e766901e44d6aba8f33242662aae68a5644e6e253f3bdfe2bb687b30e967190ddf746ef4467c41c9cda06c6bd9326ef WHIRLPOOL b696c68d7b25388b51c056534ca37f7e14d0f918b2471cd1e6662cfadc186eb989ad9429c3a40bc74992c9352d762c40e05add69773a834e99971ac46339f015
DIST DisplayCAL-3.1.6.0.tar.gz 9592426 SHA256 fc27814cf29b3643f8a44973f2139518c133f6a2549ffe51658e765a67cd02fd SHA512 ea5d0c5028c9dcfc834c03bd50d9e4cd5f4528ac0adf1312117128f8969533f857eaab738019d561b8197ad595ca73ad085db4feb36101df1e303933e1edbd87 WHIRLPOOL 6a23f57e606852838b43834d81acd346be1746040d47ac5884c997d828130ddf5b2049b8684d2de42b555ab7b6b6fb4d0430544d2586ca388eb769fbecc86be6
+DIST DisplayCAL-3.2.1.0.tar.gz 9725546 SHA256 41e71fcec3c0867c94c68e9c56753a3aab614ca3b815cab547b6510926f5321f SHA512 b2a6fdab470f551361de5743f39a8ed9f23ae1ee47d0573f2f68a30d4cb2be89102f4272f2f99fd674e23ec99c6ee2ab2c89632cdad2394c618275af92d2b942 WHIRLPOOL 7081cb274598ca0cdf159c7f3e684a1bd33467f56d49662946740ce8033b002ef0e7060d707354d4d911fe7589788c1ea4f6700f1de25fdb1b34a564b6e5f8a7
diff --git a/media-gfx/displaycal/displaycal-3.2.1.0.ebuild b/media-gfx/displaycal/displaycal-3.2.1.0.ebuild
new file mode 100644
index 000000000000..367dfb5bf65b
--- /dev/null
+++ b/media-gfx/displaycal/displaycal-3.2.1.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 xdg
+
+MY_PN="DisplayCAL"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Display calibration and characterization powered by Argyll CMS"
+HOMEPAGE="https://displaycal.net/"
+SRC_URI="mirror://sourceforge/dispcalgui/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=media-gfx/argyllcms-1.1.0
+ dev-python/wxpython:3.0
+ >=x11-libs/libX11-1.3.3
+ >=x11-apps/xrandr-1.3.2
+ >=x11-libs/libXxf86vm-1.1.0
+ >=x11-proto/xineramaproto-1.2
+ >=x11-libs/libXinerama-1.1
+"
+RDEPEND="${DEPEND}
+ >=dev-python/numpy-1.2.1
+"
+
+# Just in case someone renames the ebuild
+S="${WORKDIR}/${MY_P}"
+
+DOCS=(
+ README.html
+)
+
+src_prepare() {
+ # Prohibit setup from running xdg-* programs, resulting to sandbox violation
+ cd "${S}/DisplayCAL" || die "Cannot cd to source directory."
+ sed -e 's/if which(\"xdg-icon-resource\"):/if which(\"xdg-icon-resource-non-existant\"):/' \
+ -e 's/if which(\"xdg-desktop-menu\"):/if which(\"xdg-desktop-menu-non-existant\"):/' \
+ -i postinstall.py || die "sed'ing out the xdg-* setup functions failed"
+
+ # Remove deprecated Encoding key from .desktop file
+ cd "${S}" || die "Cannot cd to work directory."
+ for offendingFile in $(grep -r -l "Encoding=UTF-8" .); do
+ sed -e '/Encoding=UTF-8/d' -i "${offendingFile}" || \
+ die "removing deprecated Encoding key from .desktop files failed"
+ done
+
+ # Remove x-world Media Type
+ cd "${S}/misc" || die "Cannot cd to misc directory."
+ sed -e 's/x\-world\/x\-vrml\;//g' -i "displaycal-vrml-to-x3d-converter.desktop" \
+ || die "removing x-world media type failed"
+
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ distutils-r1_src_install
+ #remove udev files
+ rm -rf "${D}"/etc/udev/rules.d
+}