summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/fr0st
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/fr0st')
-rw-r--r--media-gfx/fr0st/Manifest1
-rw-r--r--media-gfx/fr0st/fr0st-1.4-r1.ebuild63
-rw-r--r--media-gfx/fr0st/metadata.xml8
3 files changed, 72 insertions, 0 deletions
diff --git a/media-gfx/fr0st/Manifest b/media-gfx/fr0st/Manifest
new file mode 100644
index 000000000000..ab6bd8469ab8
--- /dev/null
+++ b/media-gfx/fr0st/Manifest
@@ -0,0 +1 @@
+DIST fr0st-1.4-src.tgz 1535978 SHA256 88b545245c1cea6506c4c59a32f3c302703365c1fb477d951fcb465281589989
diff --git a/media-gfx/fr0st/fr0st-1.4-r1.ebuild b/media-gfx/fr0st/fr0st-1.4-r1.ebuild
new file mode 100644
index 000000000000..3459bd20643b
--- /dev/null
+++ b/media-gfx/fr0st/fr0st-1.4-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+WX_GTK_VER="2.8"
+PYTHON_DEPEND="2:2.7"
+
+inherit eutils multilib python wxwidgets
+
+DESCRIPTION="A fractal flame editor"
+HOMEPAGE="http://fr0st.wordpress.com/"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}.0/+download/${P}-src.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/wxpython:2.8
+ >=media-gfx/flam3-3.0.1"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${P}-src
+
+pkg_setup() {
+ fr0st_libdir="/usr/$(get_libdir)/fr0st"
+ fr0st_sharedir="/usr/share/fr0st"
+
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ python_convert_shebangs 2 fr0st.py
+}
+
+src_install() {
+ insinto "${fr0st_sharedir}"
+ doins -r icons samples || die
+
+ insinto "${fr0st_libdir}"
+ doins -r fr0stlib || die
+
+ exeinto "${fr0st_libdir}"
+ doexe fr0st.py || die
+
+ dosym "${fr0st_libdir}"/fr0st.py /usr/bin/fr0st || die
+ dosym "${fr0st_sharedir}"/icons/fr0st.png /usr/share/pixmaps/fr0st.png || die
+
+ make_desktop_entry fr0st fr0st
+
+ dodoc changelog.txt
+}
+
+pkg_postinst() {
+ python_mod_optimize "${fr0st_libdir}"
+}
+
+pkg_postrm() {
+ python_mod_cleanup "${fr0st_libdir}"
+}
diff --git a/media-gfx/fr0st/metadata.xml b/media-gfx/fr0st/metadata.xml
new file mode 100644
index 000000000000..7c84dffebda5
--- /dev/null
+++ b/media-gfx/fr0st/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>graphics</herd>
+ <upstream>
+ <remote-id type="launchpad">fr0st</remote-id>
+ </upstream>
+</pkgmetadata>