summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-11-30 10:10:32 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-11-30 10:25:32 +0100
commitdab551f6f5ddc47d02fa6c9738ecae3dfc2cca55 (patch)
tree4a56a967d12f9a8fb77e11f17efa6e088bf2d794 /media-libs
parentdev-libs/sord: bump to 0.16.0 (diff)
downloadgentoo-dab551f6f5ddc47d02fa6c9738ecae3dfc2cca55.tar.gz
gentoo-dab551f6f5ddc47d02fa6c9738ecae3dfc2cca55.tar.bz2
gentoo-dab551f6f5ddc47d02fa6c9738ecae3dfc2cca55.zip
media-libs/sratom: bump to 0.6.0
Package-Manager: portage-2.3.2
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/sratom/Manifest1
-rw-r--r--media-libs/sratom/sratom-0.6.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/media-libs/sratom/Manifest b/media-libs/sratom/Manifest
index 3aabc6069dc3..2c4bcf18798d 100644
--- a/media-libs/sratom/Manifest
+++ b/media-libs/sratom/Manifest
@@ -1,2 +1,3 @@
DIST sratom-0.4.4.tar.bz2 134625 SHA256 fa0c29f4fed822d5d2c41e4b4694d3a01bda1e25ae16af1054b85ad42a2180e0 SHA512 f485da575810348ed9f5016d326b1e82bd9e52d096fa91598c626bdad3f3ba15bbacdd5153b09134f1ad3112fc00132678d096e38f9f7ce2af3cef9f6fe1585a WHIRLPOOL 9dafa3ec0990b8f562d11efe6870e3b0a47e86b15f79665d1677e9cf30b9f75607d3f76a299c6c63b38b2c2a1a364e3e62131ca86aac084dd3ab008808ff272b
DIST sratom-0.4.6.tar.bz2 138165 SHA256 a4b9beaeaedc4f651beb15cd1cfedff905b0726a9010548483475ad97d941220 SHA512 198ab8fd7b027bf62db5d215e1af020695304339df552af6a336be661b30228d9c1ab2befeca959fdde0920dad2c33666fbd6bbf833ba1e24e4fde23d850dc0e WHIRLPOOL 82e0f8ab618b911b949da3d4d42e9084f906476f626d743a9920b572b64b6bf472ad1041bf07c64135636e88ec9f5ef62769c75aff3468ad5d4cd93a12b1f281
+DIST sratom-0.6.0.tar.bz2 149340 SHA256 440ac2b1f4f0b7878f8b95698faa1e8f8c50929a498f68ec5d066863626a3d43 SHA512 899bb01896e2b65b69482041c7e06edc9e45e9a3466392c82a58f16dfc71462a6c3e3e16a5aa50a6347c8366ea72898468910a59a084762f75eb8c7031ceacf8 WHIRLPOOL 6f7557397e96f3597a60e629987fcf23ea1125d97e5bd4540c7b110d160858a4a6d5689c830126538cc95d9320690d0d13e556251490e67b2b59fcd5746e9cd3
diff --git a/media-libs/sratom/sratom-0.6.0.ebuild b/media-libs/sratom/sratom-0.6.0.ebuild
new file mode 100644
index 000000000000..93a5f351fb58
--- /dev/null
+++ b/media-libs/sratom/sratom-0.6.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+PYTHON_COMPAT=( python{2_7,3_4} )
+PYTHON_REQ_USE='threads(+)'
+inherit python-any-r1 waf-utils
+
+DESCRIPTION="Library for serialising LV2 atoms to/from RDF, particularly the Turtle syntax"
+HOMEPAGE="http://drobilla.net/software/sratom/"
+SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc static-libs test"
+
+RDEPEND=">=media-libs/lv2-1.8.1
+ >=dev-libs/serd-0.14.0
+ >=dev-libs/sord-0.12.0"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig"
+
+DOCS=( "NEWS" "README" )
+
+src_prepare() {
+ sed -i -e 's/^.*run_ldconfig/#\0/' wscript || die
+}
+
+src_configure() {
+ waf-utils_src_configure \
+ --docdir=/usr/share/doc/${PF} \
+ $(use test && echo "--test") \
+ $(use doc && echo "--docs") \
+ $(use static-libs && echo "--static")
+}
+
+src_test() {
+ ./waf test || die
+}