summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2018-07-31 10:44:52 +0300
committerMart Raudsepp <leio@gentoo.org>2018-07-31 11:02:26 +0300
commitbc769d36e7bdf0b1fcb6602767b5466bda55b323 (patch)
treeded93d9d82d073838f972b131c7dcc8a3330a852 /media-plugins
parentmedia-plugins/gst-plugins-lv2: bump to 1.14.2, no code changes from 1.14.1 (diff)
downloadgentoo-bc769d36e7bdf0b1fcb6602767b5466bda55b323.tar.gz
gentoo-bc769d36e7bdf0b1fcb6602767b5466bda55b323.tar.bz2
gentoo-bc769d36e7bdf0b1fcb6602767b5466bda55b323.zip
media-plugins/gst-plugins-smoothstreaming: bump to 1.14.2, no code changes from 1.14.1
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/gst-plugins-smoothstreaming/Manifest1
-rw-r--r--media-plugins/gst-plugins-smoothstreaming/gst-plugins-smoothstreaming-1.14.2.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-smoothstreaming/Manifest b/media-plugins/gst-plugins-smoothstreaming/Manifest
index cf4b3ed4ae3f..8732a3755b6a 100644
--- a/media-plugins/gst-plugins-smoothstreaming/Manifest
+++ b/media-plugins/gst-plugins-smoothstreaming/Manifest
@@ -1,2 +1,3 @@
DIST gst-plugins-bad-1.12.4.tar.xz 4709272 BLAKE2B a4d1fec48fdd67fc66eb5588dbee820c22b19a41dda4f5643b1ae326bfc827cd4796fc7a523fb0a9758605952377a2491f4e53ea74237ca7841659dea4ddcbc0 SHA512 a8e281aee1f1d0bb3f171fbe4242e997c661cbfd0be78da3913c0f55d68d6b7c3d34cabfcdd8c25728217ff885b86a7bedc0be34a7b14e2eb2a6c6236753231b
DIST gst-plugins-bad-1.14.1.tar.xz 4651852 BLAKE2B 915798f9d07e18b445cae818978def1356299034d14ca2cba8f07df93d5dcf5ed257290bf111298c4f8063b32ceee38dd78c02eae508f6e88956b132740bfa36 SHA512 6969b6c91279fb96bc28acde0284ce980b3982ae0c77820284a903beee61dffa863554dcfadb55de1987404b59c3c7c421372e65dc7b4014fe64a0c91d4ce729
+DIST gst-plugins-bad-1.14.2.tar.xz 4664260 BLAKE2B 477c9a864088676ead3170dc11017ad997c4d0ef136845a7ad34d15745d5f1abf4486dda7a226feb5ff6c7c65c8788cd39eb5e9901f3f15a426d79bf2b81e78c SHA512 7282c8941f1eabf7141362bb8e61097b3b26ef39410ae767712c34d7e40779fc22f6ea97a950009fdb6d62175f9a153d435ead8f663cf66cc6af5aac7f2a73db
diff --git a/media-plugins/gst-plugins-smoothstreaming/gst-plugins-smoothstreaming-1.14.2.ebuild b/media-plugins/gst-plugins-smoothstreaming/gst-plugins-smoothstreaming-1.14.2.ebuild
new file mode 100644
index 000000000000..2ec5feec35fd
--- /dev/null
+++ b/media-plugins/gst-plugins-smoothstreaming/gst-plugins-smoothstreaming-1.14.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GST_ORG_MODULE=gst-plugins-bad
+
+inherit gstreamer
+
+DESCRIPTION="Smooth Streaming plugin for GStreamer"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/libxml2-2.9.1-r4[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ # FIXME: gsturidownloader does not have a .pc
+ # gst-libs/gst/uridownloader:gsturidownloader \
+ # gst-libs/gst/adaptativedemux:gstadaptivedemux \
+ # gst-libs/gst/isoff:gstisoff
+ gstreamer_system_link \
+ gst-libs/gst/codecparsers:gstreamer-codecparsers
+
+ local directory libs
+ directory="gst-libs/gst/uridownloader"
+ libs="-lgstbase-1.0 -lgstreamer-1.0 -lgobject-2.0 -lglib-2.0 -lgsturidownloader-1.0"
+ sed -e "s:\$(top_builddir)/${directory}/.*\.la:${libs}:" \
+ -i ext/smoothstreaming/Makefile.{am,in} || die
+
+ directory="gst-libs/gst/adaptivedemux"
+ libs="-lgsturidownloader-1.0 -lgstapp-1.0 -lgstbase-1.0 -lgstreamer-1.0 -lgobject-2.0 -lglib-2.0 -lgstadaptivedemux-1.0"
+ sed -e "s:\$(top_builddir)/${directory}/.*\.la:${libs}:" \
+ -i ext/smoothstreaming/Makefile.{am,in} || die
+
+ directory="gst-libs/gst/isoff"
+ libs="-lgstbase-1.0 -lgstreamer-1.0 -lgobject-2.0 -lglib-2.0 -lgstisoff-1.0"
+ sed -e "s:\$(top_builddir)/${directory}/.*\.la:${libs}:" \
+ -i ext/smoothstreaming/Makefile.{am,in} || die
+}