summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2019-03-27 10:53:08 -0400
committerRick Farina <zerochaos@gentoo.org>2019-03-27 10:53:23 -0400
commit1417b917d13ddf8eb72279a3ed3499444eb9d4bb (patch)
tree872133c4b17607a01ac6182d469de78c3155554e /media-radio
parentnet-wireless/uhd: version bump (diff)
downloadgentoo-1417b917d13ddf8eb72279a3ed3499444eb9d4bb.tar.gz
gentoo-1417b917d13ddf8eb72279a3ed3499444eb9d4bb.tar.bz2
gentoo-1417b917d13ddf8eb72279a3ed3499444eb9d4bb.zip
media-radio/fsync-mdc1200-decode: initial commit
this tool decodes fsync and mdc1200 data transmissions in analog radio streams Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/fsync-mdc1200-decode/fsync-mdc1200-decode-9999.ebuild34
-rw-r--r--media-radio/fsync-mdc1200-decode/metadata.xml15
2 files changed, 49 insertions, 0 deletions
diff --git a/media-radio/fsync-mdc1200-decode/fsync-mdc1200-decode-9999.ebuild b/media-radio/fsync-mdc1200-decode/fsync-mdc1200-decode-9999.ebuild
new file mode 100644
index 000000000000..00ae9f5dee31
--- /dev/null
+++ b/media-radio/fsync-mdc1200-decode/fsync-mdc1200-decode-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Linux Fleetsync / MCD1200 decoder"
+HOMEPAGE="https://github.com/russinnes/fsync-mdc1200-decode"
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+if [ "${PV}" = 9999 ]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/russinnes/fsync-mdc1200-decode.git"
+else
+ KEYWORDS=""
+ SRC_URI=""
+fi
+
+IUSE=""
+
+DEPEND="media-sound/pulseaudio:="
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_compile() {
+ $(tc-getCC) -o fsync-mdc1200-decode ${CFLAGS} ${LDFLAGS} demod.c fsync_decode.c mdc_decode.c $(pkg-config --cflags --libs libpulse-simple)
+}
+
+src_install() {
+ dobin fsync-mdc1200-decode
+}
diff --git a/media-radio/fsync-mdc1200-decode/metadata.xml b/media-radio/fsync-mdc1200-decode/metadata.xml
new file mode 100644
index 000000000000..2a9199f84ec0
--- /dev/null
+++ b/media-radio/fsync-mdc1200-decode/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>zerochaos@gentoo.org</email>
+ <name>Rick Farina</name>
+</maintainer>
+<maintainer type="project">
+ <email>radio@gentoo.org</email>
+ <name>Radio</name>
+</maintainer>
+<upstream>
+ <remote-id type="github">russinnes/fsync-mdc1200-decode</remote-id>
+</upstream>
+</pkgmetadata>