summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2023-03-07 18:02:33 +0100
committerThomas Beierlein <tomjbe@gentoo.org>2023-03-07 18:03:09 +0100
commit1fb04c6812477a865bddc158842f24377a6eaa43 (patch)
treeb7d228f9a9f9553ee6bee389242d506e2268afc1 /media-radio
parentdev-python/mpmath: add 1.3.0 (diff)
downloadgentoo-1fb04c6812477a865bddc158842f24377a6eaa43.tar.gz
gentoo-1fb04c6812477a865bddc158842f24377a6eaa43.tar.bz2
gentoo-1fb04c6812477a865bddc158842f24377a6eaa43.zip
media-radio/xastir: Fix implicit function declaration in configure.ac
Closes: https://bugs.gentoo.org/899846 Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/xastir/files/xastir-2.1.8-configure.diff16
-rw-r--r--media-radio/xastir/xastir-2.1.8-r4.ebuild82
2 files changed, 98 insertions, 0 deletions
diff --git a/media-radio/xastir/files/xastir-2.1.8-configure.diff b/media-radio/xastir/files/xastir-2.1.8-configure.diff
new file mode 100644
index 000000000000..0340f00e241e
--- /dev/null
+++ b/media-radio/xastir/files/xastir-2.1.8-configure.diff
@@ -0,0 +1,16 @@
+# Fix implicit function declaration in configure.ac
+# bug 899846
+diff --git a/configure.ac b/configure.ac
+index 687bbe9..c137c80 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -646,7 +646,8 @@ fi
+ save_LDFLAGS="$LDFLAGS"
+ LDFLAGS="-Wl,--no-keep-memory $LDFLAGS"
+ AC_LINK_IFELSE(
+- [AC_LANG_PROGRAM([[#include <sys/types.h>]],
++ [AC_LANG_PROGRAM([[#include <sys/types.h>
++ #include <stdlib.h>]],
+ [[/* Stupid useless test for linker flags */
+ exit(0);]])],
+ [xa_cv_no_keep_memory=yes],
diff --git a/media-radio/xastir/xastir-2.1.8-r4.ebuild b/media-radio/xastir/xastir-2.1.8-r4.ebuild
new file mode 100644
index 000000000000..321686006d1b
--- /dev/null
+++ b/media-radio/xastir/xastir-2.1.8-r4.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit autotools flag-o-matic toolchain-funcs
+
+MY_P=${PN/x/X}-Release-${PV}
+
+DESCRIPTION="X Amateur Station Tracking and Information Reporting"
+HOMEPAGE="https://xastir.org/"
+SRC_URI="https://github.com/Xastir/Xastir/archive/Release-${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="geotiff"
+
+DEPEND=">=x11-libs/motif-2.3:0
+ x11-libs/libXt
+ x11-libs/libX11
+ x11-libs/libXpm
+ x11-apps/xfontsel
+ dev-libs/libpcre
+ net-misc/curl
+ sys-libs/db:=
+ sci-libs/shapelib
+ media-gfx/graphicsmagick:=[-q32]
+ geotiff? ( sci-libs/proj
+ sci-libs/libgeotiff:=
+ media-libs/tiff:= )"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.1.8-configure.diff )
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ eapply_user
+ eapply ${PATCHES}
+
+ # fix script location (bug #407185)
+ eapply "${FILESDIR}"/${PN}-2.1.8-scripts.diff
+
+ # do not filter duplicate flags (see bug #411095)
+ eapply -p0 "${FILESDIR}"/${PN}-2.0.0-dont-filter-flags.diff
+
+ eautoreconf
+}
+
+src_configure() {
+ # provide include path to GraphicsMagic for configure stage
+ append-cflags -I/usr/include/GraphicsMagick
+ econf \
+ --with-shapelib \
+ --without-ax25 \
+ --without-festival \
+ --without-gpsman \
+ --without-imagemagick \
+ --with-graphicsmagick \
+ $(use_with geotiff libproj) \
+ $(use_with geotiff)
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ rm -rf "${D}"/usr/share/doc/${PN}
+ dodoc AUTHORS ChangeLog CONTRIBUTING.md FAQ README \
+ README.Getting-Started README.MAPS README.OSM_maps
+}
+
+pkg_postinst() {
+ elog "Kernel mode AX.25 and GPSman library not supported."
+ elog
+ elog "Remember you have to be root to add addditional scripts,"
+ elog "maps and other configuration data under /usr/share/xastir."
+}