summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2016-09-29 20:34:46 +0200
committerThomas Beierlein <tomjbe@gentoo.org>2016-09-29 20:36:04 +0200
commit5d3e67b1032fe178a5efc7580d90a20b471b50ea (patch)
treebf29c20ccd618bcdf5f5daa29775c00bc6d9b318 /media-radio
parentnet-misc/networkmanager: util-linux is needed as it uses uuid (#595118 by Gor... (diff)
downloadgentoo-5d3e67b1032fe178a5efc7580d90a20b471b50ea.tar.gz
gentoo-5d3e67b1032fe178a5efc7580d90a20b471b50ea.tar.bz2
gentoo-5d3e67b1032fe178a5efc7580d90a20b471b50ea.zip
media-radio/flrig: Fix bug #594906 wrt GCC6. Thanks Thoralf for reporting.
Package-Manager: portage-2.3.1
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/flrig/files/flrig-1.3.26-gcc6.patch130
-rw-r--r--media-radio/flrig/flrig-1.3.26.ebuild1
2 files changed, 131 insertions, 0 deletions
diff --git a/media-radio/flrig/files/flrig-1.3.26-gcc6.patch b/media-radio/flrig/files/flrig-1.3.26-gcc6.patch
new file mode 100644
index 000000000000..58668654d5d6
--- /dev/null
+++ b/media-radio/flrig/files/flrig-1.3.26-gcc6.patch
@@ -0,0 +1,130 @@
+--- src/support/xml_io.cxx.orig 2016-09-29 17:43:03.299747587 +0000
++++ src/support/xml_io.cxx 2016-09-29 17:43:41.639222816 +0000
+@@ -85,7 +85,7 @@
+
+ bool ptt_on = false;
+
+-int ignore = 0; // skip next "ignore" read loops
++int xml_ignore = 0; // skip next "xml_ignore" read loops
+
+ int try_count = CHECK_UPDATE_COUNT;
+
+@@ -155,7 +155,7 @@
+
+ try {
+ execute(rig_set_modes, modes, res);
+- ignore = 2;
++ xml_ignore = 2;
+ err_count = 5;
+ } catch (const XmlRpc::XmlRpcException& e) {
+ err_count--;
+@@ -176,7 +176,7 @@
+
+ try {
+ execute(rig_set_bandwidths, bandwidths, res);
+- ignore = 2;
++ xml_ignore = 2;
+ err_count = 5;
+ } catch (const XmlRpc::XmlRpcException& e) {
+ err_count--;
+@@ -190,7 +190,7 @@
+ try {
+ XmlRpcValue res;
+ execute(rig_set_name, XmlRpcValue(selrig->name_), res);
+- ignore = 2;
++ xml_ignore = 2;
+ err_count = 5;
+ } catch (const XmlRpc::XmlRpcException& e) {
+ err_count--;
+@@ -204,7 +204,7 @@
+ try {
+ XmlRpcValue res;
+ execute((PTT ? main_set_tx : main_set_rx), XmlRpcValue(), res);
+- ignore = 2;
++ xml_ignore = 2;
+ err_count = 5;
+ } catch (const XmlRpc::XmlRpcException& e) {
+ err_count--;
+@@ -219,7 +219,7 @@
+ xmlvfo.freq = freq;
+ XmlRpcValue f((double)freq), res;
+ execute(rig_set_frequency, f, res);
+- ignore = 2;
++ xml_ignore = 2;
+ err_count = 5;
+ } catch (const XmlRpc::XmlRpcException& e) {
+ err_count--;
+@@ -233,7 +233,7 @@
+ try {
+ XmlRpcValue mval((int)val), res;
+ execute(rig_set_smeter, mval, res);
+- ignore = 2;
++ xml_ignore = 2;
+ err_count = 5;
+ } catch (const XmlRpc::XmlRpcException& e) {
+ err_count--;
+@@ -247,7 +247,7 @@
+ try {
+ XmlRpcValue mval((int)val), res;
+ execute(rig_set_pwrmeter, mval, res);
+- ignore = 2;
++ xml_ignore = 2;
+ err_count = 5;
+ } catch (const XmlRpc::XmlRpcException& e) {
+ err_count--;
+@@ -261,7 +261,7 @@
+ try {
+ XmlRpcValue i(freq), res;
+ execute(rig_set_notch, i, res);
+- ignore = 2;
++ xml_ignore = 2;
+ err_count = 5;
+ if (freq == 0)
+ xml_notch_on = false;
+@@ -299,7 +299,7 @@
+ xmlvfo.imode = md;
+ XmlRpcValue mode(selrig->modes_[md]), res;
+ execute(rig_set_mode, mode, res);
+- ignore = 2;
++ xml_ignore = 2;
+ err_count = 5;
+ } catch (const XmlRpc::XmlRpcException& e) {
+ err_count--;
+@@ -315,7 +315,7 @@
+ int selbw = (bw > 0x80) ? (bw >> 8 & 0x7F) : bw;
+ XmlRpcValue bandwidth(selrig->bandwidths_[selbw]), res;
+ execute(rig_set_bandwidth, bandwidth, res);
+- ignore = 2;
++ xml_ignore = 2;
+ err_count = 5;
+ } catch (const XmlRpc::XmlRpcException& e) {
+ err_count--;
+@@ -329,7 +329,7 @@
+ try {
+ XmlRpcValue sideband(selrig->get_modetype(vfo.imode) == 'U' ? "USB" : "LSB"), res;
+ execute(main_set_wf_sideband, sideband, res);
+- ignore = 2;
++ xml_ignore = 2;
+ err_count = 5;
+ } catch (const XmlRpc::XmlRpcException& e) {
+ err_count--;
+@@ -501,7 +501,7 @@
+ LOG_ERROR("Connected");
+ Fl::awake(set_fldigi_connect, (void *)1);
+ err_count = 5;
+- ignore = 2;
++ xml_ignore = 2;
+ } catch (const XmlRpc::XmlRpcException& e) {
+ throw e;
+ }
+@@ -526,8 +526,8 @@
+
+ static void get_fldigi_status()
+ {
+- if (ignore) {
+- --ignore;
++ if (xml_ignore) {
++ --xml_ignore;
+ return;
+ }
+ XmlRpcValue status;
diff --git a/media-radio/flrig/flrig-1.3.26.ebuild b/media-radio/flrig/flrig-1.3.26.ebuild
index 6cf5e96b0770..d73b4581f66d 100644
--- a/media-radio/flrig/flrig-1.3.26.ebuild
+++ b/media-radio/flrig/flrig-1.3.26.ebuild
@@ -23,6 +23,7 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch "${FILESDIR}"/fix-bashism.patch
+ epatch "${FILESDIR}"/${P}-gcc6.patch
eautoreconf
}