summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/dvda-author
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/dvda-author')
-rw-r--r--media-sound/dvda-author/Manifest1
-rw-r--r--media-sound/dvda-author/dvda-author-10.06-r1.ebuild53
-rw-r--r--media-sound/dvda-author/dvda-author-10.06.ebuild45
-rw-r--r--media-sound/dvda-author/metadata.xml8
4 files changed, 107 insertions, 0 deletions
diff --git a/media-sound/dvda-author/Manifest b/media-sound/dvda-author/Manifest
new file mode 100644
index 000000000000..9659fbfb71e0
--- /dev/null
+++ b/media-sound/dvda-author/Manifest
@@ -0,0 +1 @@
+DIST dvda-author-10.06-300.tar.gz 828028 SHA256 d16ff7fe9af9d1b53240cf9f62f79766e0dfc0236b64c9aa1befb88832339fbe SHA512 619215e5e9ac4a3e55d2bef0222a931412946f129927f1042807ee25541d64609a5a9189c843fdc30d34bb0e41e0779d821d8c32a16cf89c6227d9925ea07024 WHIRLPOOL 5e4d04ff93ec83aed3ecf7ba2e10662899a82bd5a527b6573e5a6c33c93dc66b3e5c96a99f79c212b1fb57a492274db6603780fbdf8983a3f90c55988dfe8028
diff --git a/media-sound/dvda-author/dvda-author-10.06-r1.ebuild b/media-sound/dvda-author/dvda-author-10.06-r1.ebuild
new file mode 100644
index 000000000000..d0a8bab138a3
--- /dev/null
+++ b/media-sound/dvda-author/dvda-author-10.06-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+DESCRIPTION="Author a DVD-Audio DVD"
+HOMEPAGE="http://dvd-audio.sourceforge.net"
+SRC_URI="mirror://sourceforge/dvd-audio/${P}-300.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND=">=media-sound/sox-14.1[png]
+ >=media-libs/flac-1.2.1[ogg]"
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-2"
+
+src_prepare() {
+ # Fix parallel make
+ sed -i -e 's:^\(\tcd ${MAYBE_CDRTOOLS}\):@HAVE_CDRTOOLS_BUILD_TRUE@\1:' \
+ Makefile.in || die "sed failed"
+
+ # Don't pre-strip binaries
+ sed -i -e 's:$LIBS -s:$LIBS:' configure || die "sed failed"
+
+ # Fix up --as-needed.
+ MY_AS_NEEDED_F='$(LINK) \($(dvda_OBJECTS)\)'
+ MY_AS_NEEDED_R='$(CCLD) $(AM_CFLAGS) $(CFLAGS) \1 $(AM_LDFLAGS) $(LDFLAGS) -o $@'
+ sed -i -e "s/${MY_AS_NEEDED_F}/${MY_AS_NEEDED_R}/" src/Makefile.in || die "sed failed"
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --with-config=/etc \
+ $(use_with debug debug full)
+}
+
+src_compile() {
+ # make[1]: warning: jobserver unavailable: using -j1.
+ # Add '+' to parent make rule.
+ emake -j1
+}
+
+src_install() {
+ newbin src/dvda ${PN}
+ insinto /etc
+ doins ${PN}.conf
+ dodoc AUTHORS BUGS ChangeLog EXAMPLES HOWTO.conf LIMITATIONS NEWS TODO
+}
diff --git a/media-sound/dvda-author/dvda-author-10.06.ebuild b/media-sound/dvda-author/dvda-author-10.06.ebuild
new file mode 100644
index 000000000000..d7775dac8bed
--- /dev/null
+++ b/media-sound/dvda-author/dvda-author-10.06.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="Author a DVD-Audio DVD"
+HOMEPAGE="http://dvd-audio.sourceforge.net"
+SRC_URI="mirror://sourceforge/dvd-audio/${P}-300.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND=">=media-sound/sox-14.1[png]
+ >=media-libs/flac-1.2.1[ogg]"
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-2"
+
+src_prepare() {
+ # Fix parallel make
+ sed -i -e 's:^\(\tcd ${MAYBE_CDRTOOLS}\):@HAVE_CDRTOOLS_BUILD_TRUE@\1:' \
+ Makefile.in || die "sed failed"
+
+ # Don't pre-strip binaries
+ sed -i -e 's:$LIBS -s:$LIBS:' configure || die "sed failed"
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --with-config=/etc \
+ $(use_with debug debug full)
+}
+
+src_install() {
+ newbin src/dvda ${PN} || die "newbin failed"
+ insinto /etc
+ doins ${PN}.conf || die "doins failed"
+ dodoc AUTHORS BUGS ChangeLog EXAMPLES HOWTO.conf LIMITATIONS NEWS TODO \
+ || die "dodoc failed"
+}
diff --git a/media-sound/dvda-author/metadata.xml b/media-sound/dvda-author/metadata.xml
new file mode 100644
index 000000000000..1d76118d5daf
--- /dev/null
+++ b/media-sound/dvda-author/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <upstream>
+ <remote-id type="sourceforge">dvd-audio</remote-id>
+ </upstream>
+</pkgmetadata>