summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/fluidsynth
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/fluidsynth')
-rw-r--r--media-sound/fluidsynth/Manifest1
-rw-r--r--media-sound/fluidsynth/fluidsynth-1.1.6-r1.ebuild70
-rw-r--r--media-sound/fluidsynth/fluidsynth-1.1.6.ebuild70
-rw-r--r--media-sound/fluidsynth/metadata.xml8
4 files changed, 149 insertions, 0 deletions
diff --git a/media-sound/fluidsynth/Manifest b/media-sound/fluidsynth/Manifest
new file mode 100644
index 000000000000..c590398e1485
--- /dev/null
+++ b/media-sound/fluidsynth/Manifest
@@ -0,0 +1 @@
+DIST fluidsynth-1.1.6.tar.gz 958735 SHA256 50853391d9ebeda9b4db787efb23f98b1e26b7296dd2bb5d0d96b5bccee2171c SHA512 2dcb8a8a1634273cc93c45b6e21b87ac45a023c768cffdadda0a4e611eab8d5bbea0e1ba59e5f147488054cfa6fcaf561399ae275a665c76082b8738a80778bb WHIRLPOOL c3ede7f1218b5f445cf3537ed52dd32ebdcf50c44774431323b17dda963e334f80ec255e086380007dad69b4f3338aacb22ef90c10904f57d946f4573ced869b
diff --git a/media-sound/fluidsynth/fluidsynth-1.1.6-r1.ebuild b/media-sound/fluidsynth/fluidsynth-1.1.6-r1.ebuild
new file mode 100644
index 000000000000..d29b47c34ec5
--- /dev/null
+++ b/media-sound/fluidsynth/fluidsynth-1.1.6-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-multilib flag-o-matic
+
+DESCRIPTION="Fluidsynth is a software real-time synthesizer based on the Soundfont 2 specifications"
+HOMEPAGE="http://www.fluidsynth.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE="alsa dbus debug examples jack ladspa lash portaudio pulseaudio readline sndfile"
+
+RDEPEND=">=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+ alsa? ( >=media-libs/alsa-lib-1.0.27.2[${MULTILIB_USEDEP}]
+ lash? ( >=media-sound/lash-0.5.4-r2[${MULTILIB_USEDEP}] ) )
+ dbus? ( >=sys-apps/dbus-1.6.18-r1[${MULTILIB_USEDEP}] )
+ jack? ( >=media-sound/jack-audio-connection-kit-0.121.3-r1[${MULTILIB_USEDEP}] )
+ ladspa? ( >=media-libs/ladspa-sdk-1.13-r2[${MULTILIB_USEDEP}]
+ >=media-libs/ladspa-cmt-1.16-r3[${MULTILIB_USEDEP}] )
+ pulseaudio? ( >=media-sound/pulseaudio-2.1-r1[${MULTILIB_USEDEP}] )
+ portaudio? ( >=media-libs/portaudio-19_pre20111121-r1[${MULTILIB_USEDEP}] )
+ readline? ( >=sys-libs/readline-6.2_p5-r1[${MULTILIB_USEDEP}] )
+ sndfile? ( >=media-libs/libsndfile-1.0.25[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]"
+
+src_configure() {
+ # autotools based build system has AC_CHECK_LIB(pthread, pthread_create) wrt
+ # bug #436762
+ append-flags -pthread
+
+ mycmakeargs=(
+ $(cmake-utils_use alsa enable-alsa)
+ $(cmake-utils_use dbus enable-dbus)
+ $(cmake-utils_use debug enable-debug)
+ $(cmake-utils_use jack enable-jack)
+ -Denable-ladcca=OFF
+ $(cmake-utils_use ladspa enable-ladspa)
+ $(cmake-utils_use sndfile enable-libsndfile)
+ $(cmake-utils_use portaudio enable-portaudio)
+ $(cmake-utils_use pulseaudio enable-pulseaudio)
+ $(cmake-utils_use readline enable-readline)
+ )
+
+ if use alsa; then
+ mycmakeargs+=( $(cmake-utils_use lash enable-lash) )
+ else
+ mycmakeargs+=( -Denable-lash=OFF )
+ fi
+
+ cmake-multilib_src_configure
+}
+
+src_install() {
+ cmake-multilib_src_install
+
+ dodoc AUTHORS NEWS README THANKS TODO doc/*.txt
+
+ docinto pdf
+ dodoc doc/*.pdf
+
+ if use examples; then
+ docinto examples
+ dodoc doc/*.c
+ fi
+}
diff --git a/media-sound/fluidsynth/fluidsynth-1.1.6.ebuild b/media-sound/fluidsynth/fluidsynth-1.1.6.ebuild
new file mode 100644
index 000000000000..fc8bb6a05295
--- /dev/null
+++ b/media-sound/fluidsynth/fluidsynth-1.1.6.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit cmake-utils flag-o-matic
+
+DESCRIPTION="Fluidsynth is a software real-time synthesizer based on the Soundfont 2 specifications"
+HOMEPAGE="http://www.fluidsynth.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE="alsa dbus debug examples jack ladspa lash portaudio pulseaudio readline sndfile"
+
+RDEPEND=">=dev-libs/glib-2.6.5:2
+ alsa? ( media-libs/alsa-lib
+ lash? ( >=media-sound/lash-0.5 ) )
+ dbus? ( >=sys-apps/dbus-1.0.0 )
+ jack? ( media-sound/jack-audio-connection-kit )
+ ladspa? ( >=media-libs/ladspa-sdk-1.12
+ >=media-libs/ladspa-cmt-1.15 )
+ pulseaudio? ( >=media-sound/pulseaudio-0.9.8 )
+ portaudio? ( >=media-libs/portaudio-19_pre )
+ readline? ( sys-libs/readline )
+ sndfile? ( >=media-libs/libsndfile-1.0.18 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ # autotools based build system has AC_CHECK_LIB(pthread, pthread_create) wrt
+ # bug #436762
+ append-flags -pthread
+
+ mycmakeargs=(
+ $(cmake-utils_use alsa enable-alsa)
+ $(cmake-utils_use dbus enable-dbus)
+ $(cmake-utils_use debug enable-debug)
+ $(cmake-utils_use jack enable-jack)
+ -Denable-ladcca=OFF
+ $(cmake-utils_use ladspa enable-ladspa)
+ $(cmake-utils_use sndfile enable-libsndfile)
+ $(cmake-utils_use portaudio enable-portaudio)
+ $(cmake-utils_use pulseaudio enable-pulseaudio)
+ $(cmake-utils_use readline enable-readline)
+ )
+
+ if use alsa; then
+ mycmakeargs+=( $(cmake-utils_use lash enable-lash) )
+ else
+ mycmakeargs+=( -Denable-lash=OFF )
+ fi
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ dodoc AUTHORS NEWS README THANKS TODO doc/*.txt
+
+ insinto /usr/share/doc/${PF}/pdf
+ doins doc/*.pdf
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins doc/*.c
+ fi
+}
diff --git a/media-sound/fluidsynth/metadata.xml b/media-sound/fluidsynth/metadata.xml
new file mode 100644
index 000000000000..5ff04da9d27e
--- /dev/null
+++ b/media-sound/fluidsynth/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <upstream>
+ <remote-id type="sourceforge">fluidsynth</remote-id>
+ </upstream>
+</pkgmetadata>