summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-11-06 08:08:59 +0100
committerAlexis Ballier <aballier@gentoo.org>2015-11-06 08:09:07 +0100
commit71641b70c6c22d1985d59caaec63c98914864ce6 (patch)
tree8768eab5476f29eca707aa337ae8679189b6c368 /media-sound/lmms
parentmedia-sound/ncmpcpp: Set sub-SLOT dependency on sys-libs/ncurses (diff)
downloadgentoo-71641b70c6c22d1985d59caaec63c98914864ce6.tar.gz
gentoo-71641b70c6c22d1985d59caaec63c98914864ce6.tar.bz2
gentoo-71641b70c6c22d1985d59caaec63c98914864ce6.zip
media-sound/lmms: fix build with gcc 5.2
Package-Manager: portage-2.2.24 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'media-sound/lmms')
-rw-r--r--media-sound/lmms/files/gcc52.patch25
-rw-r--r--media-sound/lmms/lmms-1.1.3.ebuild2
2 files changed, 27 insertions, 0 deletions
diff --git a/media-sound/lmms/files/gcc52.patch b/media-sound/lmms/files/gcc52.patch
new file mode 100644
index 000000000000..60892a717eba
--- /dev/null
+++ b/media-sound/lmms/files/gcc52.patch
@@ -0,0 +1,25 @@
+commit 317b2f02a829f694a66c760fc6de7df1db99b006
+Author: Tobias Doerffel <tobias.doerffel@gmail.com>
+Date: Mon Feb 16 18:22:49 2015 +0100
+
+ AutomatableModel: fix wrong comparison logic
+
+ We must not negate the float but instead test for inequality in order to
+ determine whether the linked model has to be updated.
+
+ Closes #1761.
+
+diff --git a/src/core/AutomatableModel.cpp b/src/core/AutomatableModel.cpp
+index 6c7501c..bf56285 100644
+--- a/src/core/AutomatableModel.cpp
++++ b/src/core/AutomatableModel.cpp
+@@ -318,8 +318,7 @@ void AutomatableModel::setAutomatedValue( const float value )
+ it != m_linkedModels.end(); ++it )
+ {
+ if( (*it)->m_setValueDepth < 1 &&
+- !(*it)->fittedValue( m_value ) !=
+- (*it)->m_value )
++ (*it)->fittedValue( m_value ) != (*it)->m_value )
+ {
+ (*it)->setAutomatedValue( value );
+ }
diff --git a/media-sound/lmms/lmms-1.1.3.ebuild b/media-sound/lmms/lmms-1.1.3.ebuild
index db9a5060802a..8167c4c26bf1 100644
--- a/media-sound/lmms/lmms-1.1.3.ebuild
+++ b/media-sound/lmms/lmms-1.1.3.ebuild
@@ -44,6 +44,8 @@ RDEPEND="${RDEPEND}
DOCS="README AUTHORS TODO"
+PATCHES=( "${FILESDIR}/gcc52.patch" )
+
src_configure() {
mycmakeargs="${mycmakeargs}
-DWANT_SYSTEM_SR=TRUE