summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/muse
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/muse')
-rw-r--r--media-sound/muse/Manifest1
-rw-r--r--media-sound/muse/files/muse-0.9.2-asneeded.patch12
-rw-r--r--media-sound/muse/files/muse-0.9.2-gcc43.patch16
-rw-r--r--media-sound/muse/metadata.xml5
-rw-r--r--media-sound/muse/muse-0.9.2.ebuild50
5 files changed, 84 insertions, 0 deletions
diff --git a/media-sound/muse/Manifest b/media-sound/muse/Manifest
new file mode 100644
index 000000000000..bd19ced76f4d
--- /dev/null
+++ b/media-sound/muse/Manifest
@@ -0,0 +1 @@
+DIST MuSE-0.9.2.tar.gz 1420411 RMD160 05e156c44abbf48f26b30f6204c4524a760606d2 SHA1 b953f19a29ead39cc1723d07b5bf10ad1453afb2 SHA256 270f95b3a4f9d11bea04d5db4b3868aee1fa78177da0b5d9a74f26c4cfa5e197
diff --git a/media-sound/muse/files/muse-0.9.2-asneeded.patch b/media-sound/muse/files/muse-0.9.2-asneeded.patch
new file mode 100644
index 000000000000..70674bbb0c27
--- /dev/null
+++ b/media-sound/muse/files/muse-0.9.2-asneeded.patch
@@ -0,0 +1,12 @@
+--- MuSE-0.9.2/src/Makefile.in.old 2006-11-12 20:22:22.000000000 +0100
++++ MuSE-0.9.2/src/Makefile.in 2006-11-12 20:22:36.000000000 +0100
+@@ -274,7 +274,8 @@
+ @OGG_LIBS@ \
+ @VORBIS_LIBS@ \
+ @GUI_LIBS@ \
+- @SNDFILE_LIBS@
++ @SNDFILE_LIBS@ \
++ @GTK2_LIBS@
+
+ all: all-recursive
+
diff --git a/media-sound/muse/files/muse-0.9.2-gcc43.patch b/media-sound/muse/files/muse-0.9.2-gcc43.patch
new file mode 100644
index 000000000000..ec58eac62015
--- /dev/null
+++ b/media-sound/muse/files/muse-0.9.2-gcc43.patch
@@ -0,0 +1,16 @@
+diff -NrU5 MuSE-0.9.2.orig/src/libmpeg/mpegtoraw.cc MuSE-0.9.2/src/libmpeg/mpegtoraw.cc
+--- MuSE-0.9.2.orig/src/libmpeg/mpegtoraw.cc 2008-04-22 20:39:47.000000000 +0200
++++ MuSE-0.9.2/src/libmpeg/mpegtoraw.cc 2008-04-22 20:53:44.000000000 +0200
+@@ -417,11 +417,11 @@
+ if(loader->eof())return seterrorcode(SOUND_ERROR_FINISH);
+
+ return true;
+ }
+
+-#include <iostream.h>
++#include <iostream>
+ // Convert mpeg to raw
+ bool Mpegtoraw::run(int frames) {
+ clearrawdata();
+ if(frames<0)lastfrequency=0;
+
diff --git a/media-sound/muse/metadata.xml b/media-sound/muse/metadata.xml
new file mode 100644
index 000000000000..e1774e3d9ad7
--- /dev/null
+++ b/media-sound/muse/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+</pkgmetadata>
diff --git a/media-sound/muse/muse-0.9.2.ebuild b/media-sound/muse/muse-0.9.2.ebuild
new file mode 100644
index 000000000000..09fb0f8d6436
--- /dev/null
+++ b/media-sound/muse/muse-0.9.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit eutils
+
+MY_P=${P/muse/MuSE}
+
+DESCRIPTION="Multiple Streaming Engine, an icecast source streamer"
+HOMEPAGE="http://muse.dyne.org"
+SRC_URI="ftp://ftp.dyne.org/muse/releases/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~sparc x86"
+IUSE="debug gtk"
+
+RDEPEND="media-sound/lame
+ media-libs/libvorbis
+ media-libs/libsndfile
+ media-libs/libogg
+ gtk? ( x11-libs/gtk+:2 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-asneeded.patch \
+ "${FILESDIR}"/${P}-gcc43.patch
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable gtk gtk2)
+}
+
+src_compile() {
+ emake CXXFLAGS="${CXXFLAGS} -fpermissive" CFLAGS="${CFLAGS}" \
+ || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" docsdir="/usr/share/doc/${PF}" \
+ install || die "emake install failed."
+ prepalldocs
+}