summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/patchage/patchage-1.0.0.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/patchage/patchage-1.0.0.ebuild')
-rw-r--r--media-sound/patchage/patchage-1.0.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-sound/patchage/patchage-1.0.0.ebuild b/media-sound/patchage/patchage-1.0.0.ebuild
new file mode 100644
index 000000000000..ed552826f36e
--- /dev/null
+++ b/media-sound/patchage/patchage-1.0.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE='threads(+)'
+inherit waf-utils python-any-r1
+
+DESCRIPTION="Modular patch bay for JACK-based audio and MIDI systems"
+HOMEPAGE="http://drobilla.net/software/patchage"
+SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa debug jack-dbus session"
+
+RDEPEND=">=dev-cpp/glibmm-2.14:2
+ >=dev-cpp/gtkmm-2.11.12:2.4
+ >=dev-cpp/libglademm-2.6.0:2.4
+ dev-cpp/libgnomecanvasmm:2.6
+ >=media-libs/ganv-1.4.0
+ >=media-sound/jack-audio-connection-kit-0.120.0
+ alsa? ( media-libs/alsa-lib )
+ jack-dbus? ( dev-libs/dbus-glib
+ sys-apps/dbus )"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ dev-libs/boost
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS NEWS README )
+
+src_configure() {
+ waf-utils_src_configure \
+ $(use debug && echo "--debug") \
+ $(use alsa || echo "--no-alsa") \
+ $(use jack-dbus && echo "--jack-dbus") \
+ $(use session && echo "--jack-session-manage")
+}