summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-16 18:51:38 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-16 18:51:38 +0200
commitcbea35422e5d18cd944849ee040d35c1d410625a (patch)
treee210e38262eda3d05e4b4165dd9256e107356e4c /media-sound/potamus/potamus-16.ebuild
parentmedia-libs/aubio: fix build with ffmpeg git master. (diff)
downloadgentoo-cbea35422e5d18cd944849ee040d35c1d410625a.tar.gz
gentoo-cbea35422e5d18cd944849ee040d35c1d410625a.tar.bz2
gentoo-cbea35422e5d18cd944849ee040d35c1d410625a.zip
media-sound/potamus: fix build with ffmpeg git master.
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'media-sound/potamus/potamus-16.ebuild')
-rw-r--r--media-sound/potamus/potamus-16.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/media-sound/potamus/potamus-16.ebuild b/media-sound/potamus/potamus-16.ebuild
index 5c3006b41a77..aa6e6654887e 100644
--- a/media-sound/potamus/potamus-16.ebuild
+++ b/media-sound/potamus/potamus-16.ebuild
@@ -4,7 +4,7 @@
EAPI=4
-inherit gnome2
+inherit gnome2 eutils
DESCRIPTION="a lightweight audio player with a simple interface and an emphasis on high audio quality"
HOMEPAGE="http://offog.org/code/potamus.html"
@@ -30,6 +30,11 @@ RDEPEND="x11-libs/gtk+:2
DEPEND="${RDEPEND}
virtual/pkgconfig"
+src_prepare() {
+ gnome2_src_prepare
+ has_version '>=media-video/ffmpeg-2.8' && epatch "${FILESDIR}/ffmpeg29.patch"
+}
+
src_configure() {
econf \
$(use_enable audiofile input-audiofile) \