summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/splay
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/splay')
-rw-r--r--media-sound/splay/Manifest1
-rw-r--r--media-sound/splay/files/splay-0.9.5.2-external-id3lib.diff17
-rw-r--r--media-sound/splay/files/splay-0.9.5.2-gcc43-2.patch42
-rw-r--r--media-sound/splay/files/splay-0.9.5.2-gcc43.patch113
-rw-r--r--media-sound/splay/metadata.xml5
-rw-r--r--media-sound/splay/splay-0.9.5.2.ebuild37
6 files changed, 215 insertions, 0 deletions
diff --git a/media-sound/splay/Manifest b/media-sound/splay/Manifest
new file mode 100644
index 000000000000..20cec47acf29
--- /dev/null
+++ b/media-sound/splay/Manifest
@@ -0,0 +1 @@
+DIST splay-0.9.5.2.tar.gz 105510 RMD160 a79d0b429b3e73793c51ad071804e6d6362a6ad4 SHA1 a0638c96b8c9a38da026c957979fe3ec3c560f14 SHA256 38266b7620e8dde9ca39ace245ded4d9fadc3ea9e35772190fcfe90efe8d39bd
diff --git a/media-sound/splay/files/splay-0.9.5.2-external-id3lib.diff b/media-sound/splay/files/splay-0.9.5.2-external-id3lib.diff
new file mode 100644
index 000000000000..603901868e6f
--- /dev/null
+++ b/media-sound/splay/files/splay-0.9.5.2-external-id3lib.diff
@@ -0,0 +1,17 @@
+--- splay.cc~ 2005-04-03 19:56:37.000000000 -0300
++++ splay.cc 2005-04-03 19:58:24.000000000 -0300
+@@ -184,9 +184,11 @@
+ delete mytag;
+
+ }
+- catch(ID3_Error &err){
+- cout << err.GetErrorFile() << " (" << err.GetErrorLine() << "): "
+- << err.GetErrorType() << ": " << err.GetErrorDesc() << endl;
++// catch(ID3_Error &err){
++ catch(...){
++ cout << "Error found (GetError functions disabled)" << endl;
++// cout << err.GetErrorFile() << " (" << err.GetErrorLine() << "): "
++// << err.GetErrorType() << ": " << err.GetErrorDesc() << endl;
+ }
+ #endif /* HAVE_LIBID3 */
+ }
diff --git a/media-sound/splay/files/splay-0.9.5.2-gcc43-2.patch b/media-sound/splay/files/splay-0.9.5.2-gcc43-2.patch
new file mode 100644
index 000000000000..d07090743b5a
--- /dev/null
+++ b/media-sound/splay/files/splay-0.9.5.2-gcc43-2.patch
@@ -0,0 +1,42 @@
+diff -Nurpa splay-0.9.5.2.orig/apps/splay.cc splay-0.9.5.2/apps/splay.cc
+--- splay-0.9.5.2.orig/apps/splay.cc 2008-12-17 03:37:47.000000000 +0300
++++ splay-0.9.5.2/apps/splay.cc 2008-12-17 03:39:34.000000000 +0300
+@@ -150,16 +150,16 @@ ostream& operator<<(ostream& s, const ID
+ // Print just what we want...
+ s.setf(ios::left); // The filled fields get the text to the left
+ s <<
+- "Title : " << nn(ID3_GetTitle(tag)) << endl;
++ "Title : " << nn(ID3_GetTitle(tag)) << std::endl;
+ s <<
+- "Artist: " << setw(30) << nn(ID3_GetArtist(tag)) <<
++ "Artist: " << std::setw(30) << nn(ID3_GetArtist(tag)) <<
+ "Album: " << nn(ID3_GetAlbum(tag)) <<
+- endl ;
++ std::endl ;
+
+ s <<
+- "Genre : " << setw(18) << nn(ID3_gen_list[ID3_GetGenreNum(tag)]) <<
+- "Track: " << setw(5) << ID3_GetTrackNum(tag) <<
+- "Year: " << setw(6) << nn(ID3_GetYear(tag));
++ "Genre : " << std::setw(18) << nn(ID3_gen_list[ID3_GetGenreNum(tag)]) <<
++ "Track: " << std::setw(5) << ID3_GetTrackNum(tag) <<
++ "Year: " << std::setw(6) << nn(ID3_GetYear(tag));
+ // if ( ID3_GetComment(tag) ){
+ // s << endl << "Comment:" << nn(ID3_GetComment(tag)) <<
+ // nn(ID3_GetLyricist(tag)) << nn(ID3_GetLyrics(tag));
+@@ -180,13 +180,13 @@ static void play(char *filename)
+ try {
+ const ID3_Tag* mytag = new ID3_Tag(filename);
+ if ( mytag->HasV1Tag() || mytag->HasV2Tag() )
+- cout << mytag << endl;
++ std::cout << mytag << std::endl;
+ delete mytag;
+
+ }
+ // catch(ID3_Error &err){
+ catch(...){
+- cout << "Error found (GetError functions disabled)" << endl;
++ std::cout << "Error found (GetError functions disabled)" << std::endl;
+ // cout << err.GetErrorFile() << " (" << err.GetErrorLine() << "): "
+ // << err.GetErrorType() << ": " << err.GetErrorDesc() << endl;
+ }
diff --git a/media-sound/splay/files/splay-0.9.5.2-gcc43.patch b/media-sound/splay/files/splay-0.9.5.2-gcc43.patch
new file mode 100644
index 000000000000..70b91137fd75
--- /dev/null
+++ b/media-sound/splay/files/splay-0.9.5.2-gcc43.patch
@@ -0,0 +1,113 @@
+Index: splay-0.9.5.2/apps/splay.cc
+===================================================================
+--- splay-0.9.5.2.orig/apps/splay.cc
++++ splay-0.9.5.2/apps/splay.cc
+@@ -16,14 +16,14 @@
+
+ #include <sys/types.h>
+ #include <sys/wait.h>
+-#include <iostream.h>
++#include <iostream>
+
+ #ifdef HAVE_LIBID3
+ #include <id3/tag.h>
+ #include <id3/misc_support.h>
+ #endif /* HAVE_LIBID3 */
+
+-#include <iomanip.h>
++#include <iomanip>
+
+ #include "mpegsound.h"
+
+@@ -172,7 +172,7 @@ ostream& operator<<(ostream& s, const ID
+ static void play(char *filename)
+ {
+ if( splay_verbose-- )
+- cout << filename << ":" << endl;
++ std::cout << filename << ":" << std::endl;
+ if( splay_verbose>0 )
+ {
+ // cerr << getpid() << endl;
+Index: splay-0.9.5.2/libs/fileplayer.cc
+===================================================================
+--- splay-0.9.5.2.orig/libs/fileplayer.cc
++++ splay-0.9.5.2/libs/fileplayer.cc
+@@ -10,7 +10,7 @@
+ #endif
+
+ #include <string.h>
+-#include <iostream.h>
++#include <iostream>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
+@@ -55,7 +55,7 @@ bool Mpegfileplayer::openfile(char *file
+ fd=open(device, O_WRONLY|O_NDELAY);
+ }
+ if ( fd == -1 ) {
+- cerr << "Cannot open /dev/dsp or /dev/sound/dsp!" << endl;
++ std::cerr << "Cannot open /dev/dsp or /dev/sound/dsp!" << std::endl;
+ return seterrorcode(SOUND_ERROR_DEVOPENFAIL);
+ }
+ close(fd);
+@@ -121,8 +121,8 @@ bool Mpegfileplayer::playing(int verbose
+ int totframes=server->gettotalframe();
+ double tottime=1.0*totframes*pcmperframe/frequency;
+ if(frameinfo) {
+- cout << "Totalframes " << totframes;
+- cout << "; Totaltime " << tominsec(tottime) << endl;
++ std::cout << "Totalframes " << totframes;
++ std::cout << "; Totaltime " << tominsec(tottime) << std::endl;
+ }
+
+ // Playing
+@@ -132,9 +132,9 @@ bool Mpegfileplayer::playing(int verbose
+ if(frameinfo) {
+ int currframe=server-> getcurrentframe();
+ double currtime=1.0*currframe*pcmperframe/frequency;
+- cout << "Frame " << currframe << " [" << totframes-currframe << "]; ";
+- cout << "Time " << tominsec(currtime) << " [" ;
+- cout << tominsec(tottime-currtime) << "]" << endl ;
++ std::cout << "Frame " << currframe << " [" << totframes-currframe << "]; ";
++ std::cout << "Time " << tominsec(currtime) << " [" ;
++ std::cout << tominsec(tottime-currtime) << "]" << std::endl ;
+ }
+ }
+
+@@ -161,8 +161,8 @@ bool Mpegfileplayer::playingwiththread(i
+ int totframes=server->gettotalframe();
+ double tottime=1.0*totframes*pcmperframe/frequency;
+ if(frameinfo) {
+- cout << "Totalframes " << totframes;
+- cout << "; Totaltime " << tominsec(tottime) << endl;
++ std::cout << "Totalframes " << totframes;
++ std::cout << "; Totaltime " << tominsec(tottime) << std::endl;
+ }
+
+ // Playing
+@@ -172,9 +172,9 @@ bool Mpegfileplayer::playingwiththread(i
+ if(frameinfo) {
+ int currframe=server-> getcurrentframe();
+ double currtime=1.0*currframe*pcmperframe/frequency;
+- cout << "Frame " << currframe << " [" << totframes-currframe << "]; ";
+- cout << "Time " << tominsec(currtime) << " [" ;
+- cout << tominsec(tottime-currtime) << "]" << endl ;
++ std::cout << "Frame " << currframe << " [" << totframes-currframe << "]; ";
++ std::cout << "Time " << tominsec(currtime) << " [" ;
++ std::cout << tominsec(tottime-currtime) << "]" << std::endl ;
+ }
+ }
+
+Index: splay-0.9.5.2/libs/mpegtoraw.cc
+===================================================================
+--- splay-0.9.5.2.orig/libs/mpegtoraw.cc
++++ splay-0.9.5.2/libs/mpegtoraw.cc
+@@ -552,7 +552,7 @@ int Mpegtoraw::getframesaved(void)
+ #endif
+
+
+-#include <iostream.h>
++#include <iostream>
+ // Convert mpeg to raw
+ bool Mpegtoraw::run(int frames)
+ {
diff --git a/media-sound/splay/metadata.xml b/media-sound/splay/metadata.xml
new file mode 100644
index 000000000000..e1774e3d9ad7
--- /dev/null
+++ b/media-sound/splay/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+</pkgmetadata>
diff --git a/media-sound/splay/splay-0.9.5.2.ebuild b/media-sound/splay/splay-0.9.5.2.ebuild
new file mode 100644
index 000000000000..23eed982ac70
--- /dev/null
+++ b/media-sound/splay/splay-0.9.5.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+IUSE=""
+
+DESCRIPTION="an audio player, primarily for the console"
+HOMEPAGE="http://splay.sourceforge.net/"
+SRC_URI="http://splay.sourceforge.net/tgz/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}/${P}-gcc43.patch"
+ cd "${S}/apps"
+ epatch "${FILESDIR}/${P}-external-id3lib.diff"
+ epatch "${FILESDIR}/${P}-gcc43-2.patch"
+}
+
+src_compile() {
+ # Force compilation to omit X support according to BUG #5856
+ # even when qt is present on the system.
+ export ac_cv_lib_qt_main=no
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ # Specify man-page to prevent xsplay.1 from being installed
+ einstall man_MANS=splay.1 || die "einstall failed"
+ dodoc AUTHORS ChangeLog README README.LIB NEWS
+}