summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/synaesthesia
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/synaesthesia')
-rw-r--r--media-sound/synaesthesia/Manifest1
-rw-r--r--media-sound/synaesthesia/metadata.xml5
-rw-r--r--media-sound/synaesthesia/synaesthesia-2.4.ebuild32
3 files changed, 38 insertions, 0 deletions
diff --git a/media-sound/synaesthesia/Manifest b/media-sound/synaesthesia/Manifest
new file mode 100644
index 000000000000..88ad5a75d039
--- /dev/null
+++ b/media-sound/synaesthesia/Manifest
@@ -0,0 +1 @@
+DIST synaesthesia-2.4.tar.gz 259531 RMD160 494837836ccfaca94a58c68095ebf27e080baa60 SHA1 f268387aad92e01dc5fe86f497404df7bab9db27 SHA256 48505975e809ebadf416dc3e35a528ef87f01b117f2f1c5498d728ead8786493
diff --git a/media-sound/synaesthesia/metadata.xml b/media-sound/synaesthesia/metadata.xml
new file mode 100644
index 000000000000..e1774e3d9ad7
--- /dev/null
+++ b/media-sound/synaesthesia/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+</pkgmetadata>
diff --git a/media-sound/synaesthesia/synaesthesia-2.4.ebuild b/media-sound/synaesthesia/synaesthesia-2.4.ebuild
new file mode 100644
index 000000000000..22a2ac123756
--- /dev/null
+++ b/media-sound/synaesthesia/synaesthesia-2.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+DESCRIPTION="a nice graphical accompaniment to music"
+HOMEPAGE="http://www.logarithmic.net/pfh/synaesthesia"
+SRC_URI="http://www.logarithmic.net/pfh-files/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="sdl svga"
+
+RDEPEND="x11-libs/libXext
+ x11-libs/libSM
+ sdl? ( >=media-libs/libsdl-1.2 )
+ svga? ( >=media-libs/svgalib-1.4.3 )"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto"
+
+src_prepare() {
+ sed -e '/CFLAGS=/s:-O4:${CFLAGS}:' \
+ -e '/CXXFLAGS=/s:-O4:${CXXFLAGS}:' -i configure || die "sed failed"
+ sed -e 's:void inline:inline void:' -i syna.h || die "sed failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README
+}