summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/toolame
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/toolame')
-rw-r--r--media-sound/toolame/Manifest1
-rw-r--r--media-sound/toolame/files/toolame-02l-gentoo.diff69
-rw-r--r--media-sound/toolame/files/toolame-02l-uint.patch27
-rw-r--r--media-sound/toolame/files/toolame-02l-uint32_t.patch18
-rw-r--r--media-sound/toolame/metadata.xml8
-rw-r--r--media-sound/toolame/toolame-02l-r3.ebuild33
6 files changed, 156 insertions, 0 deletions
diff --git a/media-sound/toolame/Manifest b/media-sound/toolame/Manifest
new file mode 100644
index 000000000000..ce23c7bbaa8c
--- /dev/null
+++ b/media-sound/toolame/Manifest
@@ -0,0 +1 @@
+DIST toolame-02l.tgz 127493 SHA256 3b95cd2504bceac4aab2fca03bb3b5974d1d44b5afdd8eb4cc0f0899521bffc4
diff --git a/media-sound/toolame/files/toolame-02l-gentoo.diff b/media-sound/toolame/files/toolame-02l-gentoo.diff
new file mode 100644
index 000000000000..1b011600e7ef
--- /dev/null
+++ b/media-sound/toolame/files/toolame-02l-gentoo.diff
@@ -0,0 +1,69 @@
+--- Makefile 2003-03-02 08:07:02.000000000 +0100
++++ Makefile.new 2003-04-14 14:00:10.000000000 +0200
+@@ -1,6 +1,3 @@
+-
+-CC = gcc
+-
+ c_sources = \
+ common.c \
+ encode.c \
+@@ -26,37 +23,16 @@
+
+ OBJ = $(c_sources:.c=.o)
+
+-#Uncomment this if you want to do some profiling/debugging
+-#PG = -g -pg
+-PG = -fomit-frame-pointer
+-
+-# Optimize flag. 3 is about as high as you can sanely go with GCC3.2.
+-OPTIM = -O3
+-
+ # These flags are pretty much mandatory
+ REQUIRED = -DNDEBUG -DINLINE=inline
+
+-#pick your architecture
+-ARCH = -march=pentium
+-#Possible x86 architectures
+-#gcc3.2 => i386, i486, i586, i686, pentium, pentium-mmx
+-# pentiumpro, pentium2, pentium3, pentium4, k6, k6-2, k6-3,
+-# athlon, athlon-tbird, athlon-4, athlon-xp and athlon-mp.
+-
+-#TWEAK the hell out of the compile. Some of these are real dodgy
+-# and will cause program instability
+-#TWEAKS = -finline-functions -fexpensive-optimizations -ffast-math \
+-# -malign-double \
+-# -mfancy-math-387 -funroll-loops -funroll-all-loops -pipe \
+-# -fschedule-insns2 -fno-strength-reduce
+-
+ #Set a stack of warnings to overcome my atrocious coding style . MFC.
+ WARNINGS = -Wall
+ WARNINGS2 = -Wstrict-prototypes -Wmissing-prototypes -Wunused -Wunused-function -Wunused-label -Wunused-parameter -Wunused-variable -Wunused-value -Wredundant-decls
+
+ NEW_02L_FIXES = -DNEWENCODE -DNEWATAN
+
+-CC_SWITCHES = $(OPTIM) $(REQUIRED) $(ARCH) $(PG) $(TWEAKS) $(WARNINGS) $(NEW_02L_FIXES)
++CC_SWITCHES = $(CFLAGS) $(REQUIRED) $(WARNINGS) $(NEW_02L_FIXES)
+
+ PGM = toolame
+
+@@ -75,16 +51,16 @@
+ $(CC) $(CC_SWITCHES) -c $< -o $@
+
+ $(PGM): $(OBJ) Makefile
+- $(CC) $(PG) -o $(PGM) $(OBJ) $(LIBS)
++ $(CC) $(LDFLAGS) -o $(PGM) $(OBJ) $(LIBS)
+
+ clean:
+- -rm $(OBJ) $(DEP)
++ -rm $(OBJ) $(DEP) 2>/dev/null
+
+ megaclean:
+- -rm $(OBJ) $(DEP) $(PGM) \#*\# *~
++ -rm $(OBJ) $(DEP) $(PGM) \#*\# *~ 2>/dev/null
+
+ distclean:
+- -rm $(OBJ) $(DEP) $(PGM) \#* *~ gmon.out gprof* core *shit* *.wav *.mp2 *.c.* *.mp2.* *.da *.h.* *.d *.mp3 *.pcm *.wav logfile
++ -rm $(OBJ) $(DEP) $(PGM) \#* *~ gmon.out gprof* core *shit* *.wav *.mp2 *.c.* *.mp2.* *.da *.h.* *.d *.mp3 *.pcm *.wav logfile 2>/dev/null
+
+ tags: TAGS
+
diff --git a/media-sound/toolame/files/toolame-02l-uint.patch b/media-sound/toolame/files/toolame-02l-uint.patch
new file mode 100644
index 000000000000..619c98bb4547
--- /dev/null
+++ b/media-sound/toolame/files/toolame-02l-uint.patch
@@ -0,0 +1,27 @@
+diff -aur toolame-02l/audio_read.c toolame-02l-fixed/audio_read.c
+--- toolame-02l/audio_read.c 2003-03-01 17:18:30.000000000 -0800
++++ toolame-02l-fixed/audio_read.c 2005-04-19 22:32:41.288998770 -0700
+@@ -436,7 +436,7 @@
+
+ if (pcm_aiff_data->sampleSize != sizeof (short) * BITS_IN_A_BYTE) {
+ fprintf (stderr, "Sound data is not %d bits in \"%s\".\n",
+- sizeof (short) * BITS_IN_A_BYTE, file_name);
++ (int)(sizeof (short) * BITS_IN_A_BYTE), file_name);
+ exit (1);
+ }
+
+diff -aur toolame-02l/fft.c toolame-02l-fixed/fft.c
+--- toolame-02l/fft.c 2003-03-01 23:14:45.000000000 -0800
++++ toolame-02l-fixed/fft.c 2005-04-19 22:47:49.019986989 -0700
+@@ -1190,9 +1190,9 @@
+ static FLOAT atan_t[ATANSIZE];
+
+ INLINE FLOAT atan_table(FLOAT y, FLOAT x) {
+- int index;
++ unsigned int index;
+
+- index = (int)(ATANSCALE * fabs(y/x));
++ index = (unsigned int)(ATANSCALE * fabs(y/x));
+ if (index>=ATANSIZE)
+ index = ATANSIZE-1;
+
diff --git a/media-sound/toolame/files/toolame-02l-uint32_t.patch b/media-sound/toolame/files/toolame-02l-uint32_t.patch
new file mode 100644
index 000000000000..624c342781d4
--- /dev/null
+++ b/media-sound/toolame/files/toolame-02l-uint32_t.patch
@@ -0,0 +1,18 @@
+diff -ur toolame-02l.orig/audio_read.c toolame-02l/audio_read.c
+--- toolame-02l.orig/audio_read.c 2003-03-02 03:18:30.000000000 +0200
++++ toolame-02l/audio_read.c 2009-05-30 15:24:41.000000000 +0300
+@@ -1,4 +1,5 @@
+ #include <stdio.h>
++#include <stdint.h>
+ #include <stdlib.h>
+ #include <string.h>
+ #include "common.h"
+@@ -329,7 +330,7 @@
+ }
+ }
+ if (NativeByteOrder == order_littleEndian) {
+- samplerate = *(unsigned long *) (&wave_header_buffer[24]);
++ samplerate = *(uint32_t *)(&wave_header_buffer[24]);
+ } else {
+ samplerate = wave_header_buffer[27] +
+ (wave_header_buffer[26] << 8) +
diff --git a/media-sound/toolame/metadata.xml b/media-sound/toolame/metadata.xml
new file mode 100644
index 000000000000..606e35ac166d
--- /dev/null
+++ b/media-sound/toolame/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <upstream>
+ <remote-id type="sourceforge">toolame</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-sound/toolame/toolame-02l-r3.ebuild b/media-sound/toolame/toolame-02l-r3.ebuild
new file mode 100644
index 000000000000..49497728423e
--- /dev/null
+++ b/media-sound/toolame/toolame-02l-r3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="tooLAME - an optimized mpeg 1/2 layer 2 audio encoder"
+HOMEPAGE="http://www.planckenergy.com"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gentoo.diff \
+ "${FILESDIR}"/${P}-uint.patch \
+ "${FILESDIR}"/${P}-uint32_t.patch
+}
+
+src_compile() {
+ append-lfs-flags
+ tc-export CC
+ emake
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc README HISTORY FUTURE html/* text/*
+}