summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/twolame
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/twolame')
-rw-r--r--media-sound/twolame/Manifest1
-rw-r--r--media-sound/twolame/metadata.xml8
-rw-r--r--media-sound/twolame/twolame-0.3.13-r1.ebuild44
3 files changed, 53 insertions, 0 deletions
diff --git a/media-sound/twolame/Manifest b/media-sound/twolame/Manifest
new file mode 100644
index 000000000000..a99a6ad71045
--- /dev/null
+++ b/media-sound/twolame/Manifest
@@ -0,0 +1 @@
+DIST twolame-0.3.13.tar.gz 660415 SHA256 98f332f48951f47f23f70fd0379463aff7d7fb26f07e1e24e42ddef22cc6112a SHA512 241ae5faebf05cb919959bb0545cb89e9b71cfb07f92a7118d864499ea4f0065ddaa646ab1482ffbcbca427d52c2436764074bd67fd19a1eb9979987f23163f7 WHIRLPOOL 489943692b60fbb5b63c9c4b95730ce854dcaab278023bb9fb472e0b84755bcfe7d71097bcbb4555a1181b3c27a6e8f2cf0cff2eddd5d515b4a0fa8a19c9a532
diff --git a/media-sound/twolame/metadata.xml b/media-sound/twolame/metadata.xml
new file mode 100644
index 000000000000..9d29a9e027ca
--- /dev/null
+++ b/media-sound/twolame/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <upstream>
+ <remote-id type="sourceforge">twolame</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-sound/twolame/twolame-0.3.13-r1.ebuild b/media-sound/twolame/twolame-0.3.13-r1.ebuild
new file mode 100644
index 000000000000..1b1aac1f47d3
--- /dev/null
+++ b/media-sound/twolame/twolame-0.3.13-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
+inherit autotools-multilib
+
+DESCRIPTION="An optimised MPEG Audio Layer 2 (MP2) encoder"
+HOMEPAGE="http://www.twolame.org"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="static-libs"
+
+RDEPEND=">=media-libs/libsndfile-1.0.25[${MULTILIB_USEDEP}]
+ abi_x86_32? ( !<=app-emulation/emul-linux-x86-soundlibs-20130224-r6
+ !app-emulation/emul-linux-x86-soundlibs[-abi_x86_32(-)] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog README TODO )
+
+src_prepare() {
+ sed -i -e '/CFLAGS/s:-O3::' configure || die
+
+ if [[ ${CHOST} == *solaris* ]]; then
+ # libsndfile doesn't like -std=c99 on Solaris
+ sed -i -e '/CFLAGS/s:-std=c99::' configure || die
+ # configure isn't really bourne shell (comment 0) or dash (comment 6)
+ # compatible, bug #388885
+ export CONFIG_SHELL=${BASH}
+ fi
+
+ autotools-multilib_src_prepare
+}
+
+src_install() {
+ autotools-multilib_src_install \
+ pkgdocdir="${EPREFIX}/usr/share/doc/${PF}"
+}