summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Strogin <stefan.strogin@gmail.com>2019-02-10 18:03:39 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-16 00:07:33 +0100
commit4b67f7e3d266afb5df9af44e56c974189eefefc3 (patch)
treee634dcb95666fd70bf92da3624d6dab0fd6afd40 /media-sound/vimpc/vimpc-0.09.2.ebuild
parentmedia-sound/vimpc: add myself as co-maintainer (diff)
downloadgentoo-4b67f7e3d266afb5df9af44e56c974189eefefc3.tar.gz
gentoo-4b67f7e3d266afb5df9af44e56c974189eefefc3.tar.bz2
gentoo-4b67f7e3d266afb5df9af44e56c974189eefefc3.zip
media-sound/vimpc: version bump to 0.09.2
Closes: https://bugs.gentoo.org/677664 Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Stefan Strogin <stefan.strogin@gmail.com> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-sound/vimpc/vimpc-0.09.2.ebuild')
-rw-r--r--media-sound/vimpc/vimpc-0.09.2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/media-sound/vimpc/vimpc-0.09.2.ebuild b/media-sound/vimpc/vimpc-0.09.2.ebuild
new file mode 100644
index 000000000000..04c0f9dd2743
--- /dev/null
+++ b/media-sound/vimpc/vimpc-0.09.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="An ncurses based mpd client with vi-like key bindings"
+HOMEPAGE="https://github.com/boysetsfrog/vimpc"
+SRC_URI="https://github.com/boysetsfrog/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="boost taglib"
+
+RDEPEND="dev-libs/libpcre
+ media-libs/libmpdclient
+ boost? ( dev-libs/boost:= )
+ taglib? ( media-libs/taglib )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( AUTHORS README.md doc/vimpcrc.example )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable boost) \
+ $(use_enable taglib) \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+}
+
+src_install() {
+ default
+
+ # vimpc will look for help.txt
+ docompress -x /usr/share/doc/${PF}/help.txt
+}