summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-03-11 21:27:46 +0100
committerDavid Seifert <soap@gentoo.org>2017-03-11 21:47:04 +0100
commit69f8cd1455f9210a49e70e199d082585a2c2fd2b (patch)
treea51a16711b72395dddcacd21d06fbf7476e3d715 /media-sound/vorbisgain
parentmedia-sound/alac_decoder: Remove old (diff)
downloadgentoo-69f8cd1455f9210a49e70e199d082585a2c2fd2b.tar.gz
gentoo-69f8cd1455f9210a49e70e199d082585a2c2fd2b.tar.bz2
gentoo-69f8cd1455f9210a49e70e199d082585a2c2fd2b.zip
media-sound/vorbisgain: Modernise to EAPI 6
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'media-sound/vorbisgain')
-rw-r--r--media-sound/vorbisgain/vorbisgain-0.37-r1.ebuild33
-rw-r--r--media-sound/vorbisgain/vorbisgain-0.37-r2.ebuild28
2 files changed, 28 insertions, 33 deletions
diff --git a/media-sound/vorbisgain/vorbisgain-0.37-r1.ebuild b/media-sound/vorbisgain/vorbisgain-0.37-r1.ebuild
deleted file mode 100644
index 0da7f222a556..000000000000
--- a/media-sound/vorbisgain/vorbisgain-0.37-r1.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-inherit eutils
-
-DESCRIPTION="Calculator of perceived sound level for Ogg Vorbis files"
-HOMEPAGE="http://sjeng.org/vorbisgain.html"
-SRC_URI="http://sjeng.org/ftp/vorbis/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 sparc x86"
-IUSE=""
-
-RDEPEND=">=media-libs/libvorbis-1
- media-libs/libogg"
-DEPEND="${RDEPEND}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-fix-errno-and-warnings.patch # bug 200931
-}
-
-src_compile() {
- econf --enable-recursive
- emake || die "emake failed."
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed."
- dodoc NEWS README *.txt
-}
diff --git a/media-sound/vorbisgain/vorbisgain-0.37-r2.ebuild b/media-sound/vorbisgain/vorbisgain-0.37-r2.ebuild
new file mode 100644
index 000000000000..10a011e6ace6
--- /dev/null
+++ b/media-sound/vorbisgain/vorbisgain-0.37-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Calculator of perceived sound level for Ogg Vorbis files"
+HOMEPAGE="http://sjeng.org/vorbisgain.html"
+SRC_URI="http://sjeng.org/ftp/vorbis/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 sparc x86"
+IUSE=""
+
+RDEPEND="
+ media-libs/libogg
+ media-libs/libvorbis"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ # bug 200931
+ "${FILESDIR}"/${P}-fix-errno-and-warnings.patch
+)
+DOCS=( NEWS README vorbisgain.txt )
+
+src_configure() {
+ econf --enable-recursive
+}