summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon van der Veldt <simon.vanderveldt@gmail.com>2018-01-07 13:17:16 +0100
committerAlexis Ballier <aballier@gentoo.org>2018-01-07 19:14:57 +0100
commit223bbb7dea968fef915ed6069cbeb5588edbf01d (patch)
tree677d8aa515e39517d737b7829ce6eb4e2b25f5c9 /media-sound/zynaddsubfx
parentapp-crypt/gpgme: skip tests when WORKDIR is too long (diff)
downloadgentoo-223bbb7dea968fef915ed6069cbeb5588edbf01d.tar.gz
gentoo-223bbb7dea968fef915ed6069cbeb5588edbf01d.tar.bz2
gentoo-223bbb7dea968fef915ed6069cbeb5588edbf01d.zip
media-sound/zynaddsubfx bump to 3.0.3
Diffstat (limited to 'media-sound/zynaddsubfx')
-rw-r--r--media-sound/zynaddsubfx/Manifest1
-rw-r--r--media-sound/zynaddsubfx/files/zynaddsubfx-3.0.3-docs.patch14
-rw-r--r--media-sound/zynaddsubfx/zynaddsubfx-3.0.3.ebuild55
3 files changed, 70 insertions, 0 deletions
diff --git a/media-sound/zynaddsubfx/Manifest b/media-sound/zynaddsubfx/Manifest
index fbefddbd1b48..47de38d02ba4 100644
--- a/media-sound/zynaddsubfx/Manifest
+++ b/media-sound/zynaddsubfx/Manifest
@@ -1,2 +1,3 @@
DIST zynaddsubfx-3.0.1.tar.bz2 6811606 BLAKE2B 4dc400b97381f03c4bc6ff749f1bcb6e4bb41c796a97b0ccf2cf3c8dd0b98235dec40f726e838934923719b8d3378be92a5e70b6a613ee8b9922632c22b0b691 SHA512 49592e46872ae966461dfc5f7cbd2ebcf3f3a6d43139f6cd0eba65e098fb33370840c0e1f4f224a18adfc97eae9fa5583eca6a48f43b9200d5522cc413b0ce43
DIST zynaddsubfx-3.0.2.tar.bz2 7979193 BLAKE2B 9c77ef24de20a694477bf2d433fc2ee4ca3ad9d34c33e24ebabd91c4449fbabeae9d146645ce95d25355e9e8c277dd677f4c30032e65a22e6c8a336cd344fb50 SHA512 96d1df903a6afbaee991221ca30b21a20d97bc6d1cbe5c9fef94f2d1c3fb88e0294c263aec282559885d6e2f5841ad2c80d863af9f58f161791a33a9c0c08f57
+DIST zynaddsubfx-3.0.3.tar.bz2 7989258 BLAKE2B 7b71dc358ed3d0248eafb1c4638b05cc7ea8dbb05fd36c40643bb8f9160ee462c229d1604a52e795b6787d9131cea92512ad783c137c9cbe17cf8d56461a581f SHA512 e60e22656388d444114959859c12014ec79d7ba555b0d217ad98ad06e273916eea0eee521bb9dbfdef5be34205280d355b44a8f15760eeff06b16410d560b5d7
diff --git a/media-sound/zynaddsubfx/files/zynaddsubfx-3.0.3-docs.patch b/media-sound/zynaddsubfx/files/zynaddsubfx-3.0.3-docs.patch
new file mode 100644
index 000000000000..b094986ea86a
--- /dev/null
+++ b/media-sound/zynaddsubfx/files/zynaddsubfx-3.0.3-docs.patch
@@ -0,0 +1,14 @@
+Index: zynaddsubfx-2.5.2/CMakeLists.txt
+===================================================================
+--- zynaddsubfx-2.5.2.orig/CMakeLists.txt
++++ zynaddsubfx-2.5.2/CMakeLists.txt
+@@ -28,9 +28,6 @@ include(CTestConfig.cmake)
+ #Currently the only directory that uses cmake
+ add_subdirectory(src)
+
+-install(FILES AUTHORS.txt COPYING HISTORY.txt README.adoc
+- DESTINATION share/doc/zynaddsubfx
+- )
+ install(FILES zynaddsubfx-jack.desktop zynaddsubfx-alsa.desktop zynaddsubfx-oss.desktop
+ DESTINATION share/applications)
+ install(FILES zynaddsubfx.svg
diff --git a/media-sound/zynaddsubfx/zynaddsubfx-3.0.3.ebuild b/media-sound/zynaddsubfx/zynaddsubfx-3.0.3.ebuild
new file mode 100644
index 000000000000..a2778f8b90eb
--- /dev/null
+++ b/media-sound/zynaddsubfx/zynaddsubfx-3.0.3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils cmake-utils flag-o-matic multilib
+
+DESCRIPTION="ZynAddSubFX is an opensource software synthesizer"
+HOMEPAGE="http://zynaddsubfx.sourceforge.net/"
+SRC_URI="mirror://sourceforge/zynaddsubfx/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alsa +fltk jack lash"
+
+RDEPEND=">=dev-libs/mini-xml-2.2.1
+ sci-libs/fftw:3.0
+ media-libs/liblo
+ alsa? ( media-libs/alsa-lib )
+ fltk? ( >=x11-libs/fltk-1.3:1 )
+ jack? ( virtual/jack )
+ lash? ( media-sound/lash )"
+# portaudio? ( media-libs/portaudio )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+# Upstream uses the following preferences: alsa > jack > portaudio
+# At least one of them must be enabled
+# We do not support portaudio, so if alsa is disabled force jack.
+REQUIRED_USE="!alsa? ( jack )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-${PV}-docs.patch
+)
+
+DOCS=( ChangeLog HISTORY.txt README.adoc )
+
+src_configure() {
+ append-cxxflags "-std=c++11"
+ use lash || sed -i -e 's/lash-1.0/lash_disabled/' "${S}"/src/CMakeLists.txt
+ mycmakeargs=(
+ `use fltk && echo "-DGuiModule=fltk" || echo "-DGuiModule=off"`
+ `use alsa && echo "-DOutputModule=alsa" || echo "-DOutputModule=jack"`
+ `use alsa && echo "-DAlsaMidiOutput=TRUE" || echo "-DAlsaMidiOutput=FALSE"`
+ `use jack && echo "-DJackOutput=TRUE" || echo "-DJackOutput=FALSE"`
+ -DPluginLibDir=$(get_libdir)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ insinto /usr/share/${PN}
+ doins -r "${S}"/instruments/*
+}