summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2019-09-01 09:24:11 +0200
committerJohannes Huber <johu@gentoo.org>2019-09-01 09:24:11 +0200
commit5fd532cc1622e29ccd714d3481bc9245e4ffa67d (patch)
treefd755b72970701add1b1cd0045184d2cd3454351 /media-sound
parentpackage.mask: Last rite dev-embedded/jtag (diff)
downloadgentoo-5fd532cc1622e29ccd714d3481bc9245e4ffa67d.tar.gz
gentoo-5fd532cc1622e29ccd714d3481bc9245e4ffa67d.tar.bz2
gentoo-5fd532cc1622e29ccd714d3481bc9245e4ffa67d.zip
media-sound/lollypop: Version bump 1.1.4.15
Package-Manager: Portage-2.3.73, Repoman-2.3.17 Signed-off-by: Johannes Huber <johu@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/lollypop/Manifest1
-rw-r--r--media-sound/lollypop/lollypop-1.1.4.15.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/media-sound/lollypop/Manifest b/media-sound/lollypop/Manifest
index f7dab3bf104f..1ef41622df73 100644
--- a/media-sound/lollypop/Manifest
+++ b/media-sound/lollypop/Manifest
@@ -1,2 +1,3 @@
DIST lollypop-1.0.12.tar.xz 448864 BLAKE2B 65681bc29f8256ad8f9d6dadac7a6d147150a8f779e25c85744a39428176c6887e3a9f90f0af81f432db771806351301712ec2431c3a79bcb230c8c0e6fb055b SHA512 d6ad6fb638ac994c2c0367234c8ab35b79d619b3669c46f27bc1df221e41410f464a0a157faccf0ed1b2b5fbdb9f1ecad10ec7466bdff03231e4724948c8c3a2
DIST lollypop-1.1.4.14.tar.xz 455404 BLAKE2B f7b3f781af5b5a5a070b1fabf288056209a02cfbeafd1b07fdd54a74a28c77d716907eabd90ba1dd7c3571c7eee82aaeac5a9f6d151b30e1c0ae7d5c9bb40ca5 SHA512 868a1183b030b207f3ffadd8788d4dec97ff16a758b0752b9d366e2d04138f5782d682ee7794d263a4412e276f1eaccb13e821546b8b35fc9900c66c40219662
+DIST lollypop-1.1.4.15.tar.xz 455360 BLAKE2B 7bce337740d1f02c0b25e156a82a876726df2199c8dd1f751b58addd2fabd07674f883588ba9a26591777cc088566d38d904aed5bbc6ffaaf1e9c134e01ed5f0 SHA512 a4841006a9ebb2c385f52c91cdff0897f139035ab3d58727fb3dc91248d879f8ca99e67d025b84ad50ef3f2f8bd69ef9785d337856788b0328b0180c0e683b84
diff --git a/media-sound/lollypop/lollypop-1.1.4.15.ebuild b/media-sound/lollypop/lollypop-1.1.4.15.ebuild
new file mode 100644
index 000000000000..fa4f2737c6a6
--- /dev/null
+++ b/media-sound/lollypop/lollypop-1.1.4.15.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 )
+PYTHON_REQ_USE="sqlite"
+HASH="93fcc0dd47b06c2f4f54f88c0e67e993"
+inherit python-r1 gnome2-utils meson xdg-utils
+
+DESCRIPTION="Modern music player for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Lollypop"
+SRC_URI="https://gitlab.gnome.org/World/${PN}/uploads/${HASH}/${P}.tar.xz"
+KEYWORDS="~amd64"
+
+LICENSE="GPL-3"
+SLOT="0"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+DEPEND="${PYTHON_DEPS}
+ dev-libs/appstream-glib[introspection]
+ dev-libs/glib:2
+ dev-libs/gobject-introspection[cairo]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ gnome-base/gnome-common
+ x11-libs/gtk+:3
+"
+BDEPEND="${DEPEND}
+ dev-python/pkgconfig[${PYTHON_USEDEP}]
+ dev-util/desktop-file-utils
+ dev-util/itstool
+ dev-util/intltool
+"
+RDEPEND="${DEPEND}
+ app-crypt/libsecret[introspection]
+ dev-libs/totem-pl-parser
+ dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/dbus-python
+ dev-python/pillow[${PYTHON_USEDEP}]
+ >=dev-python/pylast-1.0.0[${PYTHON_USEDEP}]
+ media-libs/gst-plugins-base:1.0[introspection]
+"
+
+RESTRICT="test"
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_gconf_install
+ gnome2_schemas_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_gconf_uninstall
+ gnome2_schemas_update
+ xdg_desktop_database_update
+}