summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-08-22 10:39:44 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-08-22 10:40:22 +0200
commitcccfc04070a228f8833e2070e42449abf4279001 (patch)
tree4ab36eacf74c31380c0b3d6a3222a8dfd31339e0 /media-sound
parentdev-cpp/tclap: version bump to 1.2.2. (diff)
downloadgentoo-cccfc04070a228f8833e2070e42449abf4279001.tar.gz
gentoo-cccfc04070a228f8833e2070e42449abf4279001.tar.bz2
gentoo-cccfc04070a228f8833e2070e42449abf4279001.zip
media-sound/schismtracker: 20180810 version bump
Closes: https://bugs.gentoo.org/595840 Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/schismtracker/Manifest1
-rw-r--r--media-sound/schismtracker/schismtracker-20180810.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/media-sound/schismtracker/Manifest b/media-sound/schismtracker/Manifest
index cfb91b101b90..a427ef34c230 100644
--- a/media-sound/schismtracker/Manifest
+++ b/media-sound/schismtracker/Manifest
@@ -1 +1,2 @@
DIST schismtracker-20120105.tar.bz2 1097124 BLAKE2B 978e4b3e81b5c9ed93132aeb12febc2add281060f41d74a52da25799d7ae291d2cbc2401619fd01bc7bba342049d4aef6ac0fbf326443b790c4704301a78a511 SHA512 5b92603af3b6add0e8bd6d0b140b0ddedbaf8e2b434f651ab887e3211ccc8bcfa94be281aabc3b28dbd84e3d91f539eb0939d6d4e0596529133db7ce10aeafd8
+DIST schismtracker-20180810.tar.gz 1064821 BLAKE2B d8016437db7cf6e0087150755090621ba15661753ebcfb8081f0c137a93389d04aa7a5e1ac09fb1366d1d3b3f76c22cb497171a74fb226347eb194c58c1f0f18 SHA512 d131cec7e4749941f0e5806bff14e0782a01f14f8a68605270d09ff40af1d20fffd4c7caf2926c5a63d3e0c0bb1ed24ce4a5e4cccc280ac045a22cfb8544c498
diff --git a/media-sound/schismtracker/schismtracker-20180810.ebuild b/media-sound/schismtracker/schismtracker-20180810.ebuild
new file mode 100644
index 000000000000..55398fb6ab34
--- /dev/null
+++ b/media-sound/schismtracker/schismtracker-20180810.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools desktop xdg-utils
+
+DESCRIPTION="Free implementation of Impulse Tracker, a tool used to create high quality music"
+HOMEPAGE="http://schismtracker.org/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2 public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ media-libs/alsa-lib
+ >=media-libs/libsdl-1.2[X]
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXv
+ x11-libs/libXxf86misc
+"
+DEPEND="${RDEPEND}
+ virtual/os-headers
+ x11-base/xorg-proto
+"
+
+src_prepare() {
+ default
+ eautoreconf
+
+ sed -e "/^Categories/ s/Audio/AudioVideo;Audio/" -i sys/fd.org/schism.desktop || die
+
+ # workaround for temporary files (missing directory). Fixes:
+ # sh ./scripts/build-font.sh . font/default-lower.fnt font/default-upper-alt.fnt font/default-upper-itf.fnt font/half-width.fnt >auto/default-font.c
+ # /bin/sh: auto/default-font.c: No such file or directory
+ mkdir auto
+
+ # sys-devel/binutils[multitarget] provides ${CHOST}-windres
+ # wine provides /usr/bin/windres
+ # and schismtracker fails to use it properly:
+ # sys/win32/schismres.rc:2:20: fatal error: winver.h: No such file or directory
+ [[ ${CHOST} = *mingw32* ]] || export WINDRES= ac_cv_prog_WINDRES= ac_cv_prog_ac_ct_WINDRES=
+}
+
+src_install() {
+ default
+
+ domenu sys/fd.org/*.desktop
+ doicon icons/schism{,-itf}-icon-128.png
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}