summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-06-28 19:03:40 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-06-30 19:26:22 +0200
commitdd5fdb08a31661779afbe0c6ad3ddf99c026c332 (patch)
tree872cb524ad7eca77b736acbf275dfaac9724d92c /media-sound
parentsys-libs/binutils-libs: add texinfo to DEPEND (bug 622652) (diff)
downloadgentoo-dd5fdb08a31661779afbe0c6ad3ddf99c026c332.tar.gz
gentoo-dd5fdb08a31661779afbe0c6ad3ddf99c026c332.tar.bz2
gentoo-dd5fdb08a31661779afbe0c6ad3ddf99c026c332.zip
media-sound/amarok: Drop old
Gentoo-bug: 622684 Package-Manager: Portage-2.3.6, Repoman-2.3.1 RepoMan-Options: --force
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/amarok/Manifest1
-rw-r--r--media-sound/amarok/amarok-2.8.0-r3.ebuild138
-rw-r--r--media-sound/amarok/amarok-2.8.90-r2.ebuild135
3 files changed, 0 insertions, 274 deletions
diff --git a/media-sound/amarok/Manifest b/media-sound/amarok/Manifest
index 164d0d3c5cba..81273e9657d3 100644
--- a/media-sound/amarok/Manifest
+++ b/media-sound/amarok/Manifest
@@ -1,2 +1 @@
-DIST amarok-2.8.0.tar.bz2 39950028 SHA256 f4b89b28f217a6d947e55fb0890de22fad8c404794c6beeb2dcaf2711b4f8ec6 SHA512 09f7f675f1223d36fb9df2f8c88923c6616524e022ad83b12bcb770dfbf60cb6b191e4035633f2ea2eee5fb7b38e6d5092cf69fe222ef9c3f3c46ba8f157a62d WHIRLPOOL 108cfd95d65e74f28f85a846f605bc349e5b2962b7f9a357415225f3e48ff87148d7f50a642665cc3c809bb2cb4c22f339ad049cdeb4659bb7c0a48e798833ad
DIST amarok-2.8.90.tar.xz 48890580 SHA256 b057369ab70d192b669ee6c2c11e9e7d4140663f6a60d6175ef0bb56b4bef9a7 SHA512 1ff5f43100dbe027c8676946a4e82e914927b03ac0bb9e95bfc7e9e03fcc1cad81d9ea2a343bc4f644a025242e224ea9ae3cae7423d68b0b3c68f346922537fc WHIRLPOOL 22da35ea61dcda04d882f4c0da7327cab10edf50140b3ae891738d10e1b9e5062eb541e35e817fd04a7f0284eb085b5ccf3edfa20438b764a9ce3615de35ca8c
diff --git a/media-sound/amarok/amarok-2.8.0-r3.ebuild b/media-sound/amarok/amarok-2.8.0-r3.ebuild
deleted file mode 100644
index 0a5d5cef805d..000000000000
--- a/media-sound/amarok/amarok-2.8.0-r3.ebuild
+++ /dev/null
@@ -1,138 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-KDE_LINGUAS="bs ca ca@valencia cs da de el en_GB es et eu fi fr ga gl hu it ja
-lt lv nb nl pa pl pt pt_BR ro ru sl sr sr@ijekavian sr@ijekavianlatin sr@latin
-sv tr uk zh_CN zh_TW"
-KDE_REQUIRED="never"
-KDE_HANDBOOK="optional"
-KDE_MINIMAL="4.13.1"
-VIRTUALX_REQUIRED="test"
-VIRTUALDBUS_TEST="true"
-WEBKIT_REQUIRED="always"
-inherit flag-o-matic kde4-base pax-utils
-
-DESCRIPTION="Advanced audio player based on KDE framework"
-HOMEPAGE="https://amarok.kde.org/"
-if [[ ${PV} != *9999* ]]; then
- if [[ $PV == *[6-9][0-9]* ]]; then
- SRC_URI="mirror://kde/unstable/${PN}/${PV}/src/${P}.tar.bz2"
- else
- SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.bz2"
- fi
- KEYWORDS="amd64 x86"
-else
- KEYWORDS=""
-fi
-
-LICENSE="GPL-2"
-SLOT="4"
-IUSE="cdda debug +embedded ipod lastfm mp3tunes mtp ofa opengl test +utils"
-
-if [[ ${KDE_BUILD_TYPE} == live ]]; then
- RESTRICT="test"
-fi
-
-# ipod requires gdk enabled and also gtk compiled in libgpod
-COMMONDEPEND="
- app-crypt/qca:2[qt4(+)]
- kde-frameworks/kdelibs:4[opengl?]
- $(add_kdeapps_dep kdebase-kioslaves)
- >=media-libs/taglib-1.7[asf(+),mp4(+)]
- >=media-libs/taglib-extras-1.0.1
- sys-libs/zlib
- >=virtual/mysql-5.1[embedded?]
- >=dev-qt/qtcore-4.8:4
- >=dev-qt/qtdbus-4.8:4
- >=dev-qt/qtscript-4.8:4
- >=x11-libs/qtscriptgenerator-0.1.0
- cdda? (
- $(add_kdeapps_dep libkcddb)
- $(add_kdeapps_dep libkcompactdisc)
- $(add_kdeapps_dep audiocd-kio)
- )
- ipod? ( >=media-libs/libgpod-0.7.0[gtk] )
- lastfm? ( >=media-libs/liblastfm-1.0.3[qt4(+)] )
- mp3tunes? (
- dev-libs/glib:2
- dev-libs/libxml2
- dev-libs/openssl:0
- net-libs/loudmouth
- net-misc/curl
- >=dev-qt/qtcore-4.8.4:4[glib]
- )
- mtp? ( >=media-libs/libmtp-1.0.0 )
- ofa? ( >=media-libs/libofa-0.9.0 )
- opengl? ( virtual/opengl )
-"
-DEPEND="${COMMONDEPEND}
- dev-util/automoc
- virtual/pkgconfig
- test? ( dev-cpp/gmock )
-"
-RDEPEND="${COMMONDEPEND}
- !media-sound/amarok-utils
- || ( kde-apps/phonon-kde:4
- $(add_kdeapps_dep phonon-kde) )
-"
-
-PATCHES=(
- "${FILESDIR}/${P}-gmock-1.7.patch"
- "${FILESDIR}/${P}-mysqld-rpath.patch"
- "${FILESDIR}/${P}-taglib110.patch"
-)
-
-src_configure() {
- # Append minimal-toc cflag for ppc64, see bug 280552 and 292707
- use ppc64 && append-flags -mminimal-toc
-
- local mycmakeargs=(
- -DWITH_PLAYER=ON
- -DWITH_Libgcrypt=OFF
- -DWITH_SPECTRUM_ANALYZER=OFF
- -DWITH_NepomukCore=OFF
- -DWITH_Soprano=OFF
- $(cmake-utils_use embedded WITH_MYSQL_EMBEDDED)
- $(cmake-utils_use_with ipod)
- $(cmake-utils_use_with ipod Gdk)
- $(cmake-utils_use_with lastfm LibLastFm)
- $(cmake-utils_use_with mtp)
- $(cmake-utils_use_with mp3tunes MP3Tunes)
- $(cmake-utils_use_with ofa LibOFA)
- $(cmake-utils_use_with utils UTILITIES)
- )
-
- # Add libmysqld location for rpath patch; bug 508824
- use embedded && mycmakeargs+=(-DMYSQLD_DIR="${EPREFIX}/usr/$(get_libdir)/mysql")
-
- kde4-base_src_configure
-}
-
-src_install() {
- kde4-base_src_install
-
- # bug 481592
- pax-mark m "${ED}"/usr/bin/amarok
-}
-
-pkg_postinst() {
- kde4-base_pkg_postinst
-
- if ! use embedded; then
- echo
- elog "You've disabled the amarok support for embedded mysql DBs."
- elog "You'll have to configure amarok to use an external db server."
- echo
- elog "Please read https://amarok.kde.org/wiki/MySQL_Server for details on how"
- elog "to configure the external db and migrate your data from the embedded database."
- echo
-
- if has_version "virtual/mysql[minimal]"; then
- elog "You built mysql with the minimal use flag, so it doesn't include the server."
- elog "You won't be able to use the local mysql installation to store your amarok collection."
- echo
- fi
- fi
-}
diff --git a/media-sound/amarok/amarok-2.8.90-r2.ebuild b/media-sound/amarok/amarok-2.8.90-r2.ebuild
deleted file mode 100644
index baae7f4d2f0c..000000000000
--- a/media-sound/amarok/amarok-2.8.90-r2.ebuild
+++ /dev/null
@@ -1,135 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-KDE_LINGUAS="bs ca ca@valencia cs da de el en_GB es et eu fi fr ga gl hu it ja
-lt lv nb nl pa pl pt pt_BR ro ru sl sr sr@ijekavian sr@ijekavianlatin sr@latin
-sv tr uk zh_CN zh_TW"
-KDE_REQUIRED="never"
-KDE_HANDBOOK="optional"
-VIRTUALX_REQUIRED="test"
-VIRTUALDBUS_TEST="true"
-WEBKIT_REQUIRED="always"
-inherit flag-o-matic kde4-base pax-utils
-
-DESCRIPTION="Advanced audio player based on KDE framework"
-HOMEPAGE="http://amarok.kde.org/"
-if [[ ${PV} != *9999* ]]; then
- SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
- KEYWORDS="amd64 x86"
-else
- KEYWORDS="amd64 x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="4"
-IUSE="cdda debug +embedded ipod lastfm mp3tunes mtp ofa opengl test +utils"
-
-if [[ ${KDE_BUILD_TYPE} == live ]]; then
- RESTRICT="test"
-fi
-
-# ipod requires gdk enabled and also gtk compiled in libgpod
-COMMONDEPEND="
- app-crypt/qca:2[qt4(+)]
- kde-frameworks/kdelibs:4[opengl?]
- $(add_kdeapps_dep kdebase-kioslaves)
- >=media-libs/taglib-1.7[asf(+),mp4(+)]
- >=media-libs/taglib-extras-1.0.1
- sys-libs/zlib
- >=virtual/mysql-5.1[embedded?]
- >=dev-qt/qtcore-4.8:4
- >=dev-qt/qtdbus-4.8:4
- >=dev-qt/qtscript-4.8:4
- >=x11-libs/qtscriptgenerator-0.1.0
- cdda? (
- $(add_kdeapps_dep libkcddb)
- $(add_kdeapps_dep libkcompactdisc)
- $(add_kdeapps_dep audiocd-kio)
- )
- ipod? ( >=media-libs/libgpod-0.7.0[gtk] )
- lastfm? ( >=media-libs/liblastfm-1.0.3[qt4(+)] )
- mp3tunes? (
- dev-libs/glib:2
- dev-libs/libxml2
- dev-libs/openssl:0
- net-libs/loudmouth
- net-misc/curl
- >=dev-qt/qtcore-4.8.4:4[glib]
- )
- mtp? ( >=media-libs/libmtp-1.0.0 )
- ofa? ( >=media-libs/libofa-0.9.0 )
- opengl? ( virtual/opengl )
-"
-DEPEND="${COMMONDEPEND}
- dev-util/automoc
- virtual/pkgconfig
- test? ( dev-cpp/gmock )
-"
-RDEPEND="${COMMONDEPEND}
- !media-sound/amarok-utils
- $(add_kdeapps_dep phonon-kde)
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-2.8.0-taglib110.patch"
- "${FILESDIR}/${P}-mysql-embedded.patch"
- "${FILESDIR}/${P}-mysqld-rpath.patch"
- "${FILESDIR}/${P}-scriptconsole.patch"
- "${FILESDIR}/${P}-gcc6.patch"
- "${FILESDIR}/${P}-ffmpeg3.patch"
-)
-
-src_configure() {
- # Append minimal-toc cflag for ppc64, see bug 280552 and 292707
- use ppc64 && append-flags -mminimal-toc
-
- local mycmakeargs=(
- -DWITH_PLAYER=ON
- -DWITH_Libgcrypt=OFF
- -DWITH_SPECTRUM_ANALYZER=OFF
- -DWITH_NepomukCore=OFF
- -DWITH_Soprano=OFF
- -DWITH_MYSQL_EMBEDDED=$(usex embedded)
- -DWITH_IPOD=$(usex ipod)
- -DWITH_GDKPixBuf=$(usex ipod)
- -DWITH_LibLastFm=$(usex lastfm)
- -DWITH_MP3Tunes=$(usex mp3tunes)
- -DWITH_Mtp=$(usex mtp)
- -DWITH_LibOFA=$(usex ofa)
- -DWITH_UTILITIES=$(usex utils)
- )
-
- # bug 581554: add libmysqld location for rpath patch
- use embedded && mycmakeargs+=( -DMYSQLD_DIR="${EPREFIX}/usr/$(get_libdir)/mysql" )
-
- kde4-base_src_configure
-}
-
-src_install() {
- kde4-base_src_install
-
- # bug 481592
- pax-mark m "${ED}"/usr/bin/amarok
-}
-
-pkg_postinst() {
- kde4-base_pkg_postinst
-
- if ! use embedded; then
- echo
- elog "You've disabled the amarok support for embedded mysql DBs."
- elog "You'll have to configure amarok to use an external db server."
- echo
- elog "Please read http://amarok.kde.org/wiki/MySQL_Server for details on how"
- elog "to configure the external db and migrate your data from the embedded database."
- echo
-
- if has_version "virtual/mysql[minimal]"; then
- elog "You built mysql with the minimal use flag, so it doesn't include the server."
- elog "You won't be able to use the local mysql installation to store your amarok collection."
- echo
- fi
- fi
-}