summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-tv/dvbtune
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-tv/dvbtune')
-rw-r--r--media-tv/dvbtune/Manifest1
-rw-r--r--media-tv/dvbtune/dvbtune-0.5-r1.ebuild38
-rw-r--r--media-tv/dvbtune/files/dvbtune-0.5-gentoo.diff10
-rw-r--r--media-tv/dvbtune/files/dvbtune-0.5-r1-gentoo.diff20
-rw-r--r--media-tv/dvbtune/metadata.xml8
5 files changed, 77 insertions, 0 deletions
diff --git a/media-tv/dvbtune/Manifest b/media-tv/dvbtune/Manifest
new file mode 100644
index 000000000000..c4fab52dec67
--- /dev/null
+++ b/media-tv/dvbtune/Manifest
@@ -0,0 +1 @@
+DIST dvbtune-0.5.tar.gz 20601 SHA256 e6113080ca8a07202584edea0ac15d5a0948fc30361b7002d39bcb439ef79378 SHA512 0c6e8b8b4185b1b63638f0eff3e07b2c5e4b3bb9d95debb1625973cec2293315754487702ba9f7ed6bd6a0a518b09c8333d9ac4cd40b61f56c311c3d624fd365 WHIRLPOOL 26308845c14a3b25830a98673bc827d11704dccaa570738dd99a47e234ab767cb47f7d225d63f5f9abab6f6db01335f11bb9bb6aa47708c726de9e335d40e0f5
diff --git a/media-tv/dvbtune/dvbtune-0.5-r1.ebuild b/media-tv/dvbtune/dvbtune-0.5-r1.ebuild
new file mode 100644
index 000000000000..01321127dbfa
--- /dev/null
+++ b/media-tv/dvbtune/dvbtune-0.5-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="simple tuning app for DVB cards"
+HOMEPAGE="http://sourceforge.net/projects/dvbtools"
+SRC_URI="mirror://sourceforge/dvbtools/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="xml"
+
+RDEPEND="xml? ( dev-libs/libxml2 )"
+DEPEND="${RDEPEND}
+ virtual/linuxtv-dvb-headers"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PF}-gentoo.diff
+}
+
+src_compile() {
+ emake dvbtune
+
+ use xml && emake xml2vdr
+}
+
+src_install() {
+ dobin dvbtune
+
+ use xml && dobin xml2vdr
+
+ dodoc README scripts/*
+}
diff --git a/media-tv/dvbtune/files/dvbtune-0.5-gentoo.diff b/media-tv/dvbtune/files/dvbtune-0.5-gentoo.diff
new file mode 100644
index 000000000000..d9b60b158522
--- /dev/null
+++ b/media-tv/dvbtune/files/dvbtune-0.5-gentoo.diff
@@ -0,0 +1,10 @@
+--- dvbtune-0.5/Makefile.orig 2006-01-06 13:01:11.973196250 +0100
++++ dvbtune-0.5/Makefile 2006-01-06 13:01:46.667364500 +0100
+@@ -1,5 +1,6 @@
+ INCS=-I /usr/include/libxml2
+-CFLAGS= -Wall $(INCS)
++CFLAGS ?= -Wall
++CFLAGS += $(INCS)
+ CC=gcc
+ all: dvbtune
+
diff --git a/media-tv/dvbtune/files/dvbtune-0.5-r1-gentoo.diff b/media-tv/dvbtune/files/dvbtune-0.5-r1-gentoo.diff
new file mode 100644
index 000000000000..a615317eb1de
--- /dev/null
+++ b/media-tv/dvbtune/files/dvbtune-0.5-r1-gentoo.diff
@@ -0,0 +1,20 @@
+--- dvbtune-0.5/Makefile.orig 2006-01-06 13:01:11.973196250 +0100
++++ dvbtune-0.5/Makefile 2006-01-06 13:01:46.667364500 +0100
+@@ -1,5 +1,6 @@
+ INCS=-I /usr/include/libxml2
+-CFLAGS= -Wall $(INCS)
++CFLAGS ?= -Wall
++CFLAGS += $(INCS)
+ CC=gcc
+ all: dvbtune
+
+@@ -33,7 +33,7 @@
+ dvbtune: dvbtune.c tune.o
+
+ xml2vdr: xml2vdr.c
+- $(CC) $(CFLAGS) -o xml2vdr xml2vdr.c -lxml2
++ $(CC) $(CFLAGS) -o xml2vdr xml2vdr.c -lxml2 $(LDFLAGS)
+
+ clean:
+ rm -f *.o *~ dvbtune xml2vdr
+
diff --git a/media-tv/dvbtune/metadata.xml b/media-tv/dvbtune/metadata.xml
new file mode 100644
index 000000000000..d95d55ae0fab
--- /dev/null
+++ b/media-tv/dvbtune/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>media-tv</herd>
+ <upstream>
+ <remote-id type="sourceforge">dvbtools</remote-id>
+ </upstream>
+</pkgmetadata>