summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2018-06-02 12:33:39 +0300
committerMikle Kolyada <zlogene@gentoo.org>2018-06-02 12:34:29 +0300
commit2350682022667c35bc3ebcb566894f35439fa2bb (patch)
tree74978ce6affbb3cb7d022856393b717febbba593 /media-tv
parentxfce-extra/thunar-vcs-plugin: Bump to 0.1.90 (GTK+3 port) (diff)
downloadgentoo-2350682022667c35bc3ebcb566894f35439fa2bb.tar.gz
gentoo-2350682022667c35bc3ebcb566894f35439fa2bb.tar.bz2
gentoo-2350682022667c35bc3ebcb566894f35439fa2bb.zip
media-tv/ivtvplayer: EAPI bump
Package-Manager: Portage-2.3.40, Repoman-2.3.7
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/ivtvplayer/ivtvplayer-0.1.3-r2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-tv/ivtvplayer/ivtvplayer-0.1.3-r2.ebuild b/media-tv/ivtvplayer/ivtvplayer-0.1.3-r2.ebuild
new file mode 100644
index 000000000000..f9d1e9308789
--- /dev/null
+++ b/media-tv/ivtvplayer/ivtvplayer-0.1.3-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Simple IVTV command line TV and radio player with support of LIRC"
+HOMEPAGE="https://sourceforge.net/projects/ivtvplayer/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-tv/v4l-utils
+ || ( media-video/mplayer[v4l]
+ media-video/mplayer[dvb] )
+ media-sound/alsa-utils
+ dev-perl/XML-Simple
+ dev-perl/Gtk2
+ dev-perl/X-Osd
+ >=dev-perl/Lirc-Client-1.50"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ dobin bin/itv
+ dobin bin/iradio
+ use gtk && dobin bin/ictl
+ dodoc doc/README doc/CHANGES
+ dodoc -r conf
+}
+
+pkg_postinst() {
+ einfo ""
+ einfo "Example of itv, iradio and its LIRC configuration file is located in"
+ einfo "directory /usr/share/doc/${PF}/."
+ einfo ""
+}