summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-07-28 21:37:20 -0400
committerMichael Orlitzky <mjo@gentoo.org>2016-07-28 21:38:02 -0400
commit7da5ce67a08a90afbbe4b2c82393cd7fca0d74d6 (patch)
tree2870e00ebdbe3566e4c9ca2386447978dc5a2864 /media-tv
parentnet-analyzer/flow-tools: get to the bottom of the weird pidfile behavior in t... (diff)
downloadgentoo-7da5ce67a08a90afbbe4b2c82393cd7fca0d74d6.tar.gz
gentoo-7da5ce67a08a90afbbe4b2c82393cd7fca0d74d6.tar.bz2
gentoo-7da5ce67a08a90afbbe4b2c82393cd7fca0d74d6.zip
media-tv/nvtv: new revision with a patch to respect CFLAGS.
Gentoo-Bug: 240836 Package-Manager: portage-2.2.28
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/nvtv/files/respect-cflags.patch31
-rw-r--r--media-tv/nvtv/nvtv-0.4.7-r3.ebuild (renamed from media-tv/nvtv/nvtv-0.4.7-r2.ebuild)32
2 files changed, 40 insertions, 23 deletions
diff --git a/media-tv/nvtv/files/respect-cflags.patch b/media-tv/nvtv/files/respect-cflags.patch
new file mode 100644
index 000000000000..2fa991f72638
--- /dev/null
+++ b/media-tv/nvtv/files/respect-cflags.patch
@@ -0,0 +1,31 @@
+The rest of the build system will respect the user's CFLAGS if we
+don't wipe them out, so just delete the line that does that. The
+removal of the gtk-1.x stuff is so that we can run eautoreconf and
+have it work; we don't support gtk1 in Gentoo anyway.
+
+diff --git a/configure.in b/configure.in
+index f8f48cc..d8f1261 100755
+--- a/configure.in
++++ b/configure.in
+@@ -57,9 +57,6 @@ dnl
+ dnl Debugging enables, CFLAGS
+ dnl
+
+-dnl Clear -g -O2 from CFLAGS
+-CFLAGS=""
+-
+ AC_MSG_CHECKING(for debugging info)
+
+ AC_ARG_ENABLE(debug,
+@@ -110,11 +107,6 @@ if test ${with_gtk} = no ; then
+ fi
+
+ if test ${have_gtk} = no ; then
+- if test ${with_gtk} = yes -o ${with_gtk} = gtk1 ; then
+- AM_PATH_GTK(1.2.0, have_gtk=gtk1)
+- fi
+-fi
+-if test ${have_gtk} = no ; then
+ if test ${with_gtk} = yes -o ${with_gtk} = gtk2 ; then
+ AM_PATH_GTK_2_0(2.0.0, have_gtk=gtk2)
+ fi
diff --git a/media-tv/nvtv/nvtv-0.4.7-r2.ebuild b/media-tv/nvtv/nvtv-0.4.7-r3.ebuild
index 2f4a8cd01420..0cfa7fe9c230 100644
--- a/media-tv/nvtv/nvtv-0.4.7-r2.ebuild
+++ b/media-tv/nvtv/nvtv-0.4.7-r3.ebuild
@@ -4,6 +4,8 @@
EAPI=6
+inherit autotools
+
IUSE="X gtk"
DESCRIPTION="TV-Out for NVidia cards"
@@ -23,36 +25,20 @@ RDEPEND="sys-apps/pciutils[-zlib]
DEPEND="${RDEPEND}
X? ( x11-proto/xf86vidmodeproto )"
-src_configure() {
- local myconf
-
- if use gtk
- then
- myconf="${myconf} --with-gtk"
- else
- myconf="${myconf} --without-gtk"
- fi
-
- use X \
- && myconf="${myconf} --with-x" \
- || myconf="${myconf} --without-x"
+PATCHES=( "${FILESDIR}/respect-cflags.patch" )
- econf ${myconf}
+src_prepare() {
+ default
+ eautoreconf
}
-src_compile() {
- # The CFLAGS don't seem to make it into the Makefile.
- cd src
- emake CXFLAGS="${CFLAGS}"
+src_configure() {
+ econf $(use_with gtk) $(use_with X x)
}
src_install() {
dobin src/nvtv
dosbin src/nvtvd
-
- dodoc ANNOUNCE BUGS FAQ INSTALL README \
- doc/USAGE doc/chips.txt doc/overview.txt \
- doc/timing.txt xine/tvxine
-
+ dodoc ANNOUNCE BUGS FAQ README doc/*.txt doc/USAGE
newinitd "${FILESDIR}"/nvtv.start nvtv
}