summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2018-12-21 08:33:25 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2018-12-21 23:12:40 +0100
commit65bf8f8616e2f5c3afa1a525b85dd4c7d46e0cee (patch)
tree0b66e51a9b02bd5be4658305696dffaa27fd4a69 /media-video/cheese
parentapp-admin/packagekit-base: cleanup 1.1.7 (diff)
downloadgentoo-65bf8f8616e2f5c3afa1a525b85dd4c7d46e0cee.tar.gz
gentoo-65bf8f8616e2f5c3afa1a525b85dd4c7d46e0cee.tar.bz2
gentoo-65bf8f8616e2f5c3afa1a525b85dd4c7d46e0cee.zip
media-video/cheese: 3.28.0 → 3.30.0
Mostly translation updates only. Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Gilles Dartiguelongue <eva@gentoo.org>
Diffstat (limited to 'media-video/cheese')
-rw-r--r--media-video/cheese/Manifest2
-rw-r--r--media-video/cheese/cheese-3.26.0.ebuild76
-rw-r--r--media-video/cheese/cheese-3.30.0.ebuild71
3 files changed, 149 insertions, 0 deletions
diff --git a/media-video/cheese/Manifest b/media-video/cheese/Manifest
index 8c2f50e324e6..7e625e97ffe7 100644
--- a/media-video/cheese/Manifest
+++ b/media-video/cheese/Manifest
@@ -1 +1,3 @@
+DIST cheese-3.26.0.tar.xz 1841856 BLAKE2B 302a4a12511866197df8cf62ec00ade122f2e5dc6a4adcb78cd252594b23373c328845179135e8ae44526432ec1b6b9a8c26d2808a533833221076be0496a591 SHA512 6fd58623ca257dff0a53b3577005a8b818b706f5c3da4eab51de9a7f6368847b4fe62885f3a7ba6350ac782cbee51c7b35a0c055bf11bb270934041b15388297
DIST cheese-3.28.0.tar.xz 1544904 BLAKE2B cdad63b4175bb52c3a77ee5ed0058afdd8b5d509ef17b5931d2f01457b9ff327d3ad270ad963e3185c928ddc7203b00163137a789683669d3f8c39d5a9926da8 SHA512 c52b083b132a8c885df55def3d6bf96180fc93c8b7368f48412c8dd63e073a268ff0e86959a977bd8bf372a53e127419b96046d92cb3a96674f86cfb3477ceea
+DIST cheese-3.30.0.tar.xz 1546680 BLAKE2B 32cfc9553e1c9ebfe7d3eb5fdf19d74b49e9f69ea005f4c79097d69caa2125803c5c319e98ccd3e8f72157a5fd86c018f1be7af7045f6541ecd36d4162c5cdd1 SHA512 622910cedc8eadec4161f60e2bb3f02cbe11352b2431fdd9783f724b4119ffae6254b1566e1144c25491067f9c683a55eb85b265ef28992d852adce02fbdc8b4
diff --git a/media-video/cheese/cheese-3.26.0.ebuild b/media-video/cheese/cheese-3.26.0.ebuild
new file mode 100644
index 000000000000..fb4adf9d212d
--- /dev/null
+++ b/media-video/cheese/cheese-3.26.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+VALA_MIN_API_VERSION="0.26"
+
+inherit gnome2 vala virtualx
+
+DESCRIPTION="A cheesy program to take pictures and videos from your webcam"
+HOMEPAGE="https://wiki.gnome.org/Apps/Cheese"
+
+LICENSE="GPL-2+"
+SLOT="0/8" # subslot = libcheese soname version
+IUSE="+introspection test"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.39.90:2
+ >=x11-libs/gtk+-3.13.4:3[introspection?]
+ >=gnome-base/gnome-desktop-2.91.6:3=
+ >=media-libs/libcanberra-0.26[gtk3]
+ >=media-libs/clutter-1.13.2:1.0[introspection?]
+ >=media-libs/clutter-gtk-1:1.0
+ media-libs/clutter-gst:3.0
+ media-libs/cogl:1.0=[introspection?]
+
+ media-video/gnome-video-effects
+ x11-libs/gdk-pixbuf:2[jpeg,introspection?]
+ x11-libs/libX11
+ x11-libs/libXtst
+
+ >=media-libs/gstreamer-1.4:1.0[introspection?]
+ >=media-libs/gst-plugins-base-1.4:1.0[introspection?,ogg,pango,theora,vorbis,X]
+
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
+"
+RDEPEND="${COMMON_DEPEND}
+ >=media-libs/gst-plugins-bad-1.4:1.0
+ >=media-libs/gst-plugins-good-1.4:1.0
+
+ >=media-plugins/gst-plugins-jpeg-1.4:1.0
+ >=media-plugins/gst-plugins-v4l2-1.4:1.0
+ >=media-plugins/gst-plugins-vpx-1.4:1.0
+"
+# libxml2+gdk-pixbuf required for glib-compile-resources
+DEPEND="${COMMON_DEPEND}
+ $(vala_depend)
+ app-text/docbook-xml-dtd:4.3
+ app-text/yelp-tools
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ >=dev-util/gtk-doc-am-1.14
+ >=dev-util/intltool-0.50
+ dev-util/itstool
+ virtual/pkgconfig
+ x11-base/xorg-proto
+ test? ( dev-libs/glib:2[utils] )
+"
+
+src_prepare() {
+ vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ GST_INSPECT=$(type -P true) \
+ $(use_enable introspection) \
+ --disable-lcov \
+ --disable-static
+}
+
+src_test() {
+ virtx emake check
+}
diff --git a/media-video/cheese/cheese-3.30.0.ebuild b/media-video/cheese/cheese-3.30.0.ebuild
new file mode 100644
index 000000000000..31bc873f0bfe
--- /dev/null
+++ b/media-video/cheese/cheese-3.30.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2 virtualx
+
+DESCRIPTION="A cheesy program to take pictures and videos from your webcam"
+HOMEPAGE="https://wiki.gnome.org/Apps/Cheese"
+
+LICENSE="GPL-2+"
+SLOT="0/8" # subslot = libcheese soname version
+IUSE="+introspection"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.39.90:2
+ >=x11-libs/gtk+-3.13.4:3[introspection?]
+ >=gnome-base/gnome-desktop-2.91.6:3=
+ >=media-libs/libcanberra-0.26[gtk3]
+ >=media-libs/clutter-1.13.2:1.0[introspection?]
+ >=media-libs/clutter-gtk-0.91.8:1.0
+ media-libs/clutter-gst:3.0
+ media-libs/cogl:1.0=[introspection?]
+
+ media-video/gnome-video-effects
+ x11-libs/gdk-pixbuf:2[jpeg,introspection?]
+ x11-libs/libX11
+ x11-libs/libXtst
+
+ >=media-libs/gstreamer-1.4:1.0[introspection?]
+ >=media-libs/gst-plugins-base-1.4:1.0[introspection?,ogg,pango,theora,vorbis,X]
+
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
+"
+RDEPEND="${COMMON_DEPEND}
+ >=media-libs/gst-plugins-bad-1.4:1.0
+ >=media-libs/gst-plugins-good-1.4:1.0
+
+ >=media-plugins/gst-plugins-jpeg-1.4:1.0
+ >=media-plugins/gst-plugins-v4l2-1.4:1.0
+ >=media-plugins/gst-plugins-vpx-1.4:1.0
+"
+# libxml2+gdk-pixbuf required for glib-compile-resources
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.3
+ app-text/yelp-tools
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ >=dev-util/gtk-doc-am-1.14
+ >=dev-util/intltool-0.50
+ dev-util/itstool
+ virtual/pkgconfig
+ x11-base/xorg-proto
+"
+
+src_configure() {
+ gnome2_src_configure \
+ GST_INSPECT=$(type -P true) \
+ GTESTER_REPORT=$(type -P true) \
+ VALAC=$(type -P true) \
+ $(use_enable introspection) \
+ --disable-lcov \
+ --disable-static
+}
+
+src_test() {
+ "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/data" || die
+ GSETTINGS_SCHEMA_DIR="${S}/data" virtx emake check
+}