summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-12-19 03:56:05 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-12-19 04:09:40 +0100
commitb76210039400e19baf6bc617e50961e8d0813584 (patch)
tree89e206279e6e7b5faabbdf8ef624c7e2e81094c0 /media-video
parentmedia-video/simplescreenrecorder: Bump to version 0.3.9 (diff)
downloadgentoo-b76210039400e19baf6bc617e50961e8d0813584.tar.gz
gentoo-b76210039400e19baf6bc617e50961e8d0813584.tar.bz2
gentoo-b76210039400e19baf6bc617e50961e8d0813584.zip
media-video/simplescreenrecorder: Synced live ebuild.
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'media-video')
-rw-r--r--media-video/simplescreenrecorder/simplescreenrecorder-9999.ebuild33
1 files changed, 21 insertions, 12 deletions
diff --git a/media-video/simplescreenrecorder/simplescreenrecorder-9999.ebuild b/media-video/simplescreenrecorder/simplescreenrecorder-9999.ebuild
index 22b763bb40ea..a732537e48c5 100644
--- a/media-video/simplescreenrecorder/simplescreenrecorder-9999.ebuild
+++ b/media-video/simplescreenrecorder/simplescreenrecorder-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit flag-o-matic multilib-minimal
+inherit cmake-multilib flag-o-matic xdg-utils
if [[ ${PV} = 9999 ]]; then
inherit git-r3
@@ -23,7 +23,7 @@ else
fi
SLOT="0"
-IUSE="+asm debug jack mp3 pulseaudio theora vorbis vpx x264"
+IUSE="+asm jack mp3 pulseaudio theora vorbis vpx x264"
RDEPEND="
dev-qt/qtcore:5
@@ -69,24 +69,33 @@ pkg_setup() {
}
multilib_src_configure() {
- local myconf=(
- $(multilib_native_use_enable debug assert)
- $(multilib_native_use_with pulseaudio)
- $(multilib_native_use_with jack)
- $(use_enable asm x86-asm)
+ local mycmakeargs=(
+ -DENABLE_32BIT_GLINJECT="$(usex abi_x86_32)"
+ -DENABLE_X86_ASM="$(usex asm)"
+ -DWITH_PULSEAUDIO="$(multilib_native_usex pulseaudio)"
+ -DWITH_JACK="$(multilib_native_usex jack)"
+ -DWITH_GLINJECT="true"
)
# libav doesn't have AVFrame::channels
# https://github.com/MaartenBaert/ssr/issues/195#issuecomment-45646159
- if has_version media-video/libav; then
- myconf+=( --disable-ffmpeg-versions )
+ if has_version media-video/libav ; then
+ mycmakeargs+=( -DENABLE_FFMPEG_VERSIONS="false" )
fi
if multilib_is_native_abi ; then
- myconf+=( --with-qt5 )
+ mymakeargs+=( -DWITH_QT5="true" )
else
- myconf+=( --disable-ssrprogram )
+ mycmakeargs+=( -DWITH_SIMPLESCREENRECORDER="false" )
fi
- ECONF_SOURCE="${S}" econf "${myconf[@]}"
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
}